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  Dreamweaver MX / Introduction 

โปรแกรม Macromedia Dreamweaver MX 
 

การเปดโปรแกรม 
- Click ปุม Start > Programs > Macromedia > Macromedia Dreamweaver MX 
 

สวนประกอบของหนาจอ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
1. Title Bar  แสดงชื่อโปรแกรม / Page Title / Folder  และ ชื่อ File 
2. Menu Bar  แสดงคําส่ังหลัก 
3. Insert Panel  เปนที่เก็บเคร่ืองมือหลักสําหรับการออกแบบ Web Page 
4. Document Toolbars สําหรับเปล่ียนมุมมอง / กําหนด Page Title 
5. Work Area  พื้นที่สําหรับการออกแบบ Web Page 
6. Status Bar  สวนที่เปน Tag Selector สําหรับดู / แกไข Code HTML  

Window Size Pop-Up Menu สําหรบักําหนดพื้นที่ในการออกแบบเพื่อแสดงผลใน Browser  
Document Size / Download Time แสดงขนาดของ File และเวลาในการ Download 

7. Properties Panel สําหรับกําหนดรายละเอียดของ Object ตางๆ ที่เลือก 
8. Panels Groups เปนที่สําหรับเก็บเครื่องมือเพื่อชวยใหสามารถทํางานไดสะดวกยิ่งขึ้น จะมีอยูหลาย         

หมวด/หมู 
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ในสวน Title Bar 
 
 

แสดง Page Title ของ Web Page  แสดงชื่อแฟมขอมูล 
 
 

แสดงวามีการแกไขขอมูล และ File ยังไมได Save และถา Save แลว * จะหายไป 
 
 

แสดง Page Title คือ My  W e b S I T E  และ Save File ไวที่ Folder ชื่อ Web Print   และ File ชื่อ index  

 
การทํางานกับมุมมองในการแกไข Web Page 
 
• Show Code View   แสดงหนาจอเปน Code HTML 
• Show Design View   แสดงหนาจอปกติ 
• Show Code and Design Views  แสดงหนาจอเปน Code HTML และหนาจอปกติ รวมกัน 
 
การทํางานกับ Panel 
• การแสดง / ไมแสดง Panel ตางๆ    

ทําไดโดยเลือกคําส่ัง  Window  และเลือก  Panel  ที่ตองการ 
หรือ  Window / others และเลือก  Panel ที่ตองการ 

• การซอน / แสดง Palette ทั้งหมด ที่แสดงในหนาจอ  
       ทําไดโดยการกด  Function Key F4 

• การปด Panel  
Click ที่ปุม Panel Menu / Close Panel Group 

 
การทํางานรวมกับโปรแกรมอื่น 
 

การกําหนด Browser สําหรับการ Preview Web Page ที่ไดสรางไว 
- เลือกคําส่ัง Edit > Preferences 
- เลือกหมวดคําส่ัง Preview in Browser 
- Click ปุมเครื่องหมาย  +  และกําหนดรายละเอียดของ Browser ที่ตองการ 
• ควรกําหนดทั้ง Internet Explorer และ Netscape 
• ในการ Preview Web Page ใน Browser หลัก ใหกด  F12 
 

  หนา 2/41 



  Dreamweaver MX / Introduction 

การกําหนดโปรแกรม External HTML Editor 
- เลือกคําส่ัง Edit  / Edit with External Editor  จะออกไปที่หนาจอ File Type / Editors 
- Click ปุม Browse External Code Editor 
- เลือก File ของโปรแกรมที่ตองการ  เชน Notepad.exe 
- การใชงาน เลือกคําส่ัง Edit / Edit with …. 
 

การกําหนดใหโปรแกรม Photoshop เปนโปรแกรมสําหรับการแกไขรูปภาพ 
• อยูในหนาจอ File Type / Editors 
- Click เลือกบรรทัด .jpg .jpe .jpeg 
- Click ปุมเครื่องหมาย  +  บริเวณ Editors  และเลือก File สําหรับเปดโปรแกรม Photoshop  
- Click ที่ Make Primary และ OK 
 

การใช โปรแกรม Photoshop แกไขรูปภาพตามที่กําหนดไว 
- นํา Mouse ชี้ที่รูปภาพ และ Click Mouse ปุมขวา 
- เลือกคําส่ัง Edit with Photoshop  
• จะเปดโปรแกรม Photoshop และเปด File รูปภาพที่เลือกไว 
 

การแกปญหาไมสามารถพิมพภาษาไทยได และการไมแสดงภาษาไทยใน Browser 
 

วิธีที่ 1 ติดตั้งโปรแกรมเสริม Dreamweaver MX Thai Add on 
- Download ไดจาก www.thaiware.com 
วิธีที่ 2 ปรับคาในโปรแกรม Dreamweaver MX เอง 
- เปดโปรแกรม Dreamweaver MX 
- เลือกคําส่ัง Edit / Preferences และในสวน Category เลือก Fonts 
- ในสวน Font Settings เลือก Other 
- กําหนดรายละเอียด 

• Proportional Font  = Tahoma (Thai) ขนาด 12 pt 
• Fixed Font  ไมตองปรับแตง 
• Code View  = Microsoft Sans Serif (Thai) ขนาด 10 pt 
• Tag Inspector  = MS Sans Serif ขนาด 9 pt 

- เรียบรอยแลว ในสวน Category เลือก New Document 
- ในสวน Default Encoding เลือก Others และ OK 
 

การแสดง Toolbar 
จะมี Document Toolbar และ Standard Toolbar 
- Click ขวาที่ Document Toolbar  และเลือก Standard 
- ถาตองการยกเลิกใหทําซ้ํา 
- หรือ เลือกคําส่ัง View / Toolbars / และเลือก Toolbar ที่ตองการ 
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การใชเครื่องมือตางๆ เพ่ือชวยในการออกแบบ 
1. การกําหนดขนาดของหนาจอ  

โดยใช  Window Size Pop-Up Menu 
ปกติ Resolution ขนาด 800 x 600 จะใชขนาดหนาจอเทากับ 760 x 420 

• หากปรับขนาดเปนเต็มหนาจอแลว จะไมสามารถปรับเปล่ียนขนาดไดอีก 
• ตองการลดขนาดหนาจอ เลือกคําส่ัง Window และ Cascade 

2. แสดง Grid และกําหนดคําส่ัง Snap to Grid  
โดยใชคําส่ัง View > Grid 

3. แสดง Ruler  
โดยใชคําส่ัง View > Rulers 

4. แสดง Property Inspector และ Insert Panel 
โดยใชคําส่ัง  Window > Properties  และคําส่ัง  Window > Panel 

• การซอน / แสดง Palette ทั้งหมด ที่แสดงในหนาจอ โดยการกด F4 
 
การกําหนดรายละเอียดตางๆ ของ Web Page 
- เลือกคําส่ัง Modify > Page Properties  
- หรือ นํา Mouse ชี้บริเวณหนาจอ และ Click ขวา และเลือกคําส่ัง Page Properties 
- กําหนดรายละเอียดตามตองการ และ OK 
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Title    สําหรับกําหนด Page Title 
Background Image  สําหรับกําหนดรูป Background 
Background  สําหรับกําหนดสีพื้น 
Text   สําหรับกําหนดสีของ Text ภายใน Page 
Links   สําหรับกําหนดสีของ Link ภายใน Page 
Visited Links  สําหรับกําหนดสีของ Link ที่ผานการ Click แลว 
Active Links  สําหรับกําหนดสีของ Link ที่เกิดขึ้นระหวางกด 
Left Margin  การแสดงผลชิดกับขอบดานซายของ Browser ถา Set เปน 0 
Top Margin  การแสดงผลชิดกับขอบดานบนของ Browser ถา Set เปน 0 
Margin Width  ระยะความกวางของขอบ (ใชกับ Netscape) 
Margin Height  ระยะความสูงของขอบเอกสาร (ใชกับ Netscape) 
Document Encoding เลือกภาษาที่ตองการ Encoding เพื่อแสดงใน Browser 
Tracing Image  ใชในการเลือกรูปที่นําเขามาเปน Background เพื่อชวยในการออกแบบ 
Image Transparency การปรับคาความโปรงแสงของรูปที่นํามาเปน Tracing Image 
Document Folder  ตําแหนงของ Folder หลักของ File นั้น 
Site Folder  ตําแหนงของ Folder หลักของ Site นั้น 
 
การกําหนดสี 
สีที่ใชใน Web จะใชเพียง 256 สี และ Code สีจะประกอบดวย 3 สี คือ RGB (Red,Green,Blue) 
โดยมี Format การเขียนดังนี้   #RRGGBB 
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การจัดการกับโครงสรางของ Site 
 

ขั้นตอนในการจัดสราง Web Site 
1. วางแผน 
2. สราง Local Site 
3. สรางหนา  Web Page 
4. Upload ไปที่ Remote Site 

การวางแผนจดัสราง Web Site 
1. กําหนดจุดประสงคของ  Web Site 
2. กําหนดกลุมผูเขาชม 
3. เลือก Web Browser 
4. วางโครงรางของ Site 
5. ออกแบบหนาตาของ Web 
6. ออกแบบการเดินเรื่องและการเชื่อมโยงของหนา Web Page ใน Web Site 
7. รวบรวม File ส่ือทั้งหมดที่ตองใช 

 
FTP (File Transfer Protocol) Program 
Program FTP คือโปรแกรมสําหรับ Upload File Homepage ที่ไดสราง จากเครื่องคอมพิวเตอรของเรา ไปยัง 
Server ไดแก โปรแกรม WS_FTP , โปรแกรม Cute Ftp 
 

Dreamweaver Site Management 
Site Management จะทําหนาที่เปน Site Map ในเครื่องของเรา และยังเปน FTP ดวย โดยยึดตาม Structure 
ของ Local Site (Root Directory) เพื่อหลีกเลี่ยงความผิดพลาดของการ Link  
 
 
 
 
 
 
 
 
 
 
 
 
การแสดง Site Panel 

- เลือก  Window / Site 
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การสราง Local Site ใน Hard Disk 
- Click ที่ Define a Site ที่ Site Panel    

หรือ Click ที่ปุม Site ในสวนของ Site Panel  และเลือก New Site 
- พิมพชื่อ Site ที่ตองการ   และ  Next 
- ตองการสราง Server จําลอง ? ใหเลือก  No….   และ  Next 
- เลือกตัวเลือกที่ 1 (Edit copies on my machine….) และกําหนด Folder ที่เก็บขอมูล และ Next 
- กําหนดรูปแบบการติดตอกบั Server ใหเลือก None และ Next 
- โปรแกรมจะแสดงรายละเอียด และ Done 

 
การสราง File ใหม และการแกไข File เกา ที่ Site Panel 

- Click ที่ปุม File / New File และแกไขชื่อ File 
- ถาตองการแกไข / Open File เกา ให Double Click ที่ File ที่ตองการ 

 
การสราง Folder ใหม 

- Click ที่ปุม File / New Folder และแกไขชื่อ Folder 
 
การแกไขรายละเอียดของ Site 

- Click ที่ปุม Site ในสวนของ Site Panel  และเลือก Edit Sites 
- หรือ Click ที่ชองแสดงรายชื่อ Site และเลือก Edit Sites 
- และเลือกชื่อ Site ที่ตองการ และเลือก Edit 
- กําหนดรายละเอียดและ OK 

 
การแสดงรายละเดียด Site Map  

- Click ปุม      Expand / collapse   แสดงเต็มหนาจอ 
 

 
- แสดง Remote Site / Testing Server / Site Map ของ Local  / เลือกชื่อ Site ที่ตองการ 
 
- Click ปุม     Expand / collapse เพื่อกลับไปหนาจอปกติ 
 
- Assets แสดงรายละเอียดเกี่ยวกับ File รูปภาพ / อื่นๆ 
- คําส่ัง View 

o Show Files Marked as Hidden แสดง File ที่ถูกซอนใน Mode Hidden 
o Show Dependent Files  แสดง File ที่เชื่อมโยงอยูกับ Web Page 
o Show Page Titles   แสดง Page Title แทนแสดงชื่อ File 
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- ลักษณะการแสดงของ Link 
o OK Link  เปน Link ที่ทํางานได จะแสดงเปนสีดํา 
o Email Link แสดงเปน mailto:email address 
o URL Link แสดงเปน http://www.yahoo.com 
o Broken Link Link ที่มีปญหา จะแสดงเปนสีแดง 

 
 
 
 
 
 
 
 
 
 
 
การตรวจสอบ Site Map 
การตรวจสอบจุดเช่ือมโยง (Check a Link) 
- แสดง Site Map เต็มหนาจอ    เลือก Site Map ที่ตองการ 
- Click Mouse ปุมขวาที่ File ท ี่ตองการ และเลือกคําส่ัง Check Links  
- เลือกคําส่ัง Selected Files/Folders หรือ Entire Site  
- จะมีหนาจอ Results แสดงขึ้นมา  
การซอมแซมจุดเช่ือมโยงที่ผดิพลาด (Fixing broken links) 
- ในหนาจอ Results ในสวน Broken Links 
- Click ที่ชื่อ File ที่มีปญหา และ Click ปุม Browse for file เลือก File ปลายทางที่ตองการแกไข 
 

การเปลี่ยนจุดเช่ือมโยง (Changing a link Site Wide) 
- แสดง Site Map เต็มหนาจอ    เลือก Site Map ที่ตองการ 
- Click Mouse ปุมขวาที่ File ท ี่ตองการ และเลือกคําส่ัง Change Links  
- กําหนด File ใหมที่ตองการ และ OK และ Update 
 

การตรวจสอบการแสดงผลของ Browser (Check Target Browsers) 
- แสดง Site Map เต็มหนาจอ    เลือก Site Map ที่ตองการ 
- Click Mouse ปุมขวาที่ File ท ี่ตองการ และเลือกคําส่ัง Check Target Browsers  
- เลือก Browsers ที่ตองการ และ Check 
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การกําหนดรายละเอียดในการติดตอกับ Server เพ่ือการ Upload File 
- เลือก Edit Site และเลือก Site ที่ตองการ และ Edit 
- เลือกหมวดคําส่ัง Advanced 
- เลือก FTP และ Next 
- กําหนดรายละเอียดของ Server  
- Click ปุม Test Connection และ Next 
- Done 
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การ Upload File จาก Local Site ไปที่ Remote Site ครั้งแรก 
- แสดง Site Map เต็มหนาจอ  
- เลือก Site Map ที่ตองการ  และ Click Folder ที่เปน Root Directory ที่หนาจอ Local Folder 
- Click ที่        เพื่อ Connect กับ Remote  

 
- Click เพื่อ Put  File ไปที่ Remote  
 

 
การ Update File ระหวาง Local Site กับ Remote Site ครั้งที่ 2 เปนตนไป 
- แสดง Site Map เต็มหนาจอ  
- เลือก Site Map ที่ตองการ 
- เลือกคําส่ัง Site และ Synchronize  
- กําหนดรายละเอียด ที่ บรรทัด  Synchronize เปน Entire …. Site และ Preview 
- ตรวจสอบ File และ OK 
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การทํางานกับขอความ 
การขึ้นบรรทัดใหมใชการ Enter หรือ ใช Line Break (Shift + Enter) Tag BR จะอยูที่ Characters Panel 
Tag BR จะเวนระยะหางนอยกวาการ Enter 
 
การทําขอความใหเปนหัวขอ 
- เลือกขอความที่ตองการ 
- ในชอง Format เลือก รูปแบบ Heading ที่ตองการ (Heading 1 ขนาดใหญสุด) 
 
การ Format ขอความ 
- ใช  Text Properties Inspector เพื่อเปล่ียนแปลงรายละเอียด 
 

สวนประกอบของ Text Properties 
 

 
 
 
Format   กําหนดลักษณะขอความใหมีคุณสมบัติตางๆ เชน เปนยอหนา , หัวขอตางๆ 
Font Combination  ใชในการกําหนด Font List 
Size  กําหนดขนาดของ Font จะมีขนาด 1-7 และ 1 จะมีขนาดเล็กสุด และ 7 จะมีขนาดใหญสุด 
  None คือขนาดปกติของ Browser คือ = 3 และถากําหนดขนาดเปน +2 จะไดขนาดเปน 5  
Link  การกําหนด Link ใหกับขอความ 
Target  กําหนดขนาดของการแสดงหนาตางของขอมูลที่ Link ไป 
 

การกําหนดชนดิของ Font 
- เลือกขอความที่ตองการ 
- เลือกชุด Font ที่ตองการ ที่ Font Combination 
- การทํางานจะใช Font ลําดับที่ 1 กอน ถาหาก Browser ปลายทางมี Font นั้นอยู ถาไมมีจะใชลําดับตอไป 
 
การเพิ่ม Font List 
- Click  ที่    ในชอง Default Font ที่ Text Property 
- เลือก Edit Font List และ เลือก Font ที่ตองการ  

เชน   เลือก MS Sans Serif และ Click ปุม  
  เลือก AngsanaUPC และ Click ปุม 

เลือก CordiaUPC  และ Click ปุม 
- เรียบรอยและ OK 
• ในการ Format Font ใหเลือก Font List ที่กําหนดไว ขนาดของตัวอักษร จะไมเปล่ียนแปลงมาก 
• การลบ ทาํงานที่ Edit Font List และเลือกบรรทัดที่ตองการ และ Click ที่ปุมลบ 
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การทําขอความใหเปนลําดับ (Bullet List / Number List) 
- Click ที่ปุม Bullet List / Number List 
- พิมพขอความที่ตองการ และ Enter 
- เมื่อพิมพขอความครบแลว ให Enter เพิ่มอีก 1 ครั้ง เพื่อส้ินสุดการทํางาน 
 
การเปลี่ยนรูปแบบของ Bullet List / Number List 
- Click บริเวณขอความที่เปน List  
- Click ปุม List Item 
- ที่บรรทัด Style เลือกรูปแบบที่ตองการ และ OK 
 

การยอหนาไปทางขวา และยอหนากลับมาทางซาย 
- เลือกขอความ 
- และใชปุม   หรือใชปุม Tab / Shift + Tab 
 
การแทรกชองวางเพ่ือเวนวรรค 
ในภาษา HTML จะใหเวนวรรคไดเพียง 1 ตัวอักษรเทานั้น 
- เลือกตําแหนงขอความ 
- เลือกหมวด Characters และเลือก  Non-breaking Space    หรือ Ctrl + Shift + Spacebar 
 
การใสตัวอักษรพิเศษ 
- ทํางานที่หมวด Characters และเลือกรูปแบบที่ตองการ 
 
การใสวันที่ปจจุบัน 
- เลือกตําแหนงที่ตองการ 
- เลือกหมวด Common และเลือก                 Date   และเลือกรูปแบบที่ตองการ และ OK 
- ถาเลือก Update Automatically on Save คือทุกๆ ครั้งที่ Save File Home Page วันที่/เวลา จะเปลี่ยน

ของปจจุบัน 
 
การใสเสนคั่นแนวนอน 
- เลือกตําแหนงที่ตองการ 
- เลือกหมวด Common และเลือก                 Horizontal Rule    
- สามารถกําหนดรายละเอียดของเสนไดที่ Properties Panel  
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การจัดการเกี่ยวกับรูปภาพ 
File ที่นิยมนํามาใชกับ Web Page ไดแก 

• JPEG File (.JPG)   
สามารถแสดงสีไดถึง 16 ลานสี และมีขนาดของ File ที่มาใหญมาก เหมาะกับภาพถาย 

• GIF File (.GIF) 
สามารถแสดงสีได 256 สี  และมีขนาดของ File ที่เล็ก สวนใหญจะเปนภาพเคลื่อนไหว / ภาพการตูน 

• PNG File (.PNG) 
จะสามารถแสดงสีไดมากกวา GIF File และมีขนาดของ File ที่เล็กพอๆ กัน 

การนํารูปภาพมาใสใน Web Page 
- Click ตําแหนงที่ตองการ 
- Click ปุม            Image ที่ Common Panel   
- กําหนด Folder ที่เก็บรูปภาพ และ Double Click ที่ File ที่ตองการ 

 การนํารูปภาพมาใสใน Web Page รูปจะตองอยูภายใต Local Site ที่ตั้งไวแตแรก แตถาดึง File มาจากที่อื่น 
โปรแกรมจะถามวา ตองการ Copy File นั้นเขามาใน Folder ของ Local Site หรือไม ควรตอบ Yes เพื่อ
ตอน Upload File ไปที่ Server จะไดไมผิดพลาดเรื่องรูปที่จะหายไป 

 ในการ Preview ใน Browser ควรจะ Save File กอน เพื่อรูปจะไดแสดงใน Browser 
 

การปรับเปล่ียนขนาดของรูปภาพ 
- Click ที่ Image ที่ตองการ 
- ปรับขนาดตามตองการ ถาตองการใหรูปคงสัดสวน ใหกด Shift  และนํา Mouse ชี้ 

 การปรับขนาดของรูป จะไมทําใหขนาดของ File แตจะมีผลตอความละเอียดของภาพ ดังนั้นการปรับขนาดของรูป 
ควรทําใหเห็น Layout เทานั้น หลังจากนั้นจึงเขาไปปรับในโปรแกรมที่ใชแกไขรูปภาพ 

 การปรับขนาดของรูป สามารถกําหนดขนาดที่ตองการ โดยใสตัวเลขลงในชอง W และ H ใน Image Property 
 สามารถปรับไดเล็กสุด 8 X 8 Pixel ถาตองการเล็กกวา ตองปรับคาที่ W และ H ใน Image Property 

 

สวนประกอบของ Image Property 
 
 
 
 
 
 
Image   สําหรับตั้งชื่อ Image และแสดงรูป Preview และขนาดของ File 
W และ H  แสดงความกวาง / ยาว เทากับขนาดรูปจริงที่ Insert เขามา และ หนวยเปน Pixel 
Src  แสดงตําแหนงและชื่อ File ที่ Insert เขามา 
Link  ตําแหนงของ File หรือ URL ที่ตองการ Link ไป 
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Align  การเรียงรูปกับตัวอักษร 
Alternative กําหนดขอความเพื่อแสดงกอนที่รูปจะ Load เสร็จ 
Map  สําหรับตั้งชื่อ Image Map 
Icon ลูกศร สําหรับกดเลือกบริเวณที่ทํา Image Map ไว 
Square Tool สําหรับเลือกบริเวณที่ตองการทํา Image Map เปนรูปส่ีเหลี่ยม 
Circle Tool สําหรับเลือกบริเวณที่ตองการทํา Image Map เปนรูปวงกลม 
Polygon Tool สําหรับเลือกบริเวณที่ตองการทํา Image Map เปนรูปอิสระ 
V Space และ H Space กําหนดคาของชองวางที่อยูติดกับรูป เพื่อใหมีชองระหวางภาพ หรือระหวางตัวอักษรอื่น 
Target  ลักษณะของ Window ที่เปด เมื่อกด Link 
Low Src  การใหรูปที่มี Resolution ต่ํา หรือขนาด File ที่เล็กขึ้นกอนที่รูปที่เราเลือกจะถูก Load หมด 
Border  จะขึ้นเมื่อรูปที่เราเลือกถูกกําหนดใหใช Link ดวย ปกติเปน 0 
Refresh  การ Refresh รูปหลังจากที่เราปรับคาตางๆ เสร็จ เพื่อดูการแสดงผลใหม 
Alignment การจัดตําแหนงรูป ซาย กลาง ขวา 
Edit  สําหรับเปดโปรแกรมที่แกไขภาพ 
 

การจัดเรียงรูปกับขอความ (Align) 
Default   จะขึ้นอยูกับ Browser แตปกติจะเปนการเรียงขอความบริเวณดานลางของรูป 
Baseline  และ Bottom การเรียงขอความบริเวณดานลางของ Object 
Top และ Text Top การเรียงขอความบริเวณดานบนสุดของ Object 
Middle   การเรียงขอความโดยฐานของขอความอยูตรงกลางของ Object 
Absolute Middle  การเรียงแนวกลางขอความอยูแนวเดียวกับแนวกลางของ Object 
Absolute Bottom  การเรียงแนวลางขอความอยูแนวเดียวกับแนวต่ําสุดของ Object 
Left   การเรียง Object ใหชิดดานซาย และขอความจะลอมรอบทางดานขวา 
Right   การเรียง Object ใหชิดดานขวา และขอความจะลอมรอบทางดานซาย 
 

การใสรูปภาพเปนพื้นฉากหลัง 
- เลือกคําส่ัง Modify และ Page Properties 
- Click ปุม Browse ที่บรรทัด Background Image 
- เลือกรูปภาพที่ตองการ และ OK และ OK 
 
การจัดตําแหนงรูปภาพ 
- ใช   V Space และ H Space   ที่ Properties  
กําหนดคาของชองวางที่อยูติดกับรูป เพื่อใหมีชองระหวางภาพ หรือระหวางตัวอักษรอื่น 
- ใช Alignment Image 
- ใชตาราง 
- สามารถนํารูปมาแสดงตอกันไดทันที ในแนวนอน 
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การทํางานกับ Link (Hyperlink) 
 

การ Link ภายใน File และระหวาง File 
 การ Link คือการสั่งใหโปรแกรม Browser เชื่อมตอไปยัง Server ที่ตองการแลวแสดงขอมูลนั้นขึ้นมา  
 การ Link สามารถกําหนดไดทั้งขอความ และรูปภาพ  

 
ลักษณะของการ Link 
1. การทําขอความใหเปน Link 
2. การทํารูปภาพใหเปน Link (1 รูป 1 Link) 
3. การทํา Map Link (1 รูป หลาย Link) 
4. การ Link ไปยัง Web Site อื่นๆ 
5. การ Link ไปยังขอความหรือตอนใดตอนหนึ่งที่อยูใน File เดียวกัน 
6. การ Link ไปยังขอความหรือตอนใดตอนหนึ่งที่อยูใน File อื่น 
7. Email Address 
8. การทํา Download File 
 

การกําหนดขอความใหเปน Link 
- เลือกขอความที่ตองการ 
- Click ปุม Browse for file ที่บรรทัด Link 
- กําหนด File ที่ตองการ หรือ พิมพ URL ที่ตองการในชอง Link เชน http://www.hunsa.com 
- กําหนด Target (ลักษณะการเปดหนาตางใหม) และ OK 

_blank  เปดเปน Window เล็ก   
_parent  เปดเปน Window ใหญเต็มหนาจอ 

• จะแสดงตําแหนง / ชื่อ File หรือตําแหนง URL ที่ Link ไป ในชอง Link 
• หรือ ใชปุม Hyperlink   และกําหนดรายละเอียด และ OK 
 
การทํารูปภาพใหเปน Link 
- เลือกขอความที่ตองการ 
- Click ปุม Browse for file ที่บรรทัด Link 
- กําหนด File ที่ตองการ หรือ พิมพ URL ที่ตองการในชอง Link เชน http://www.hunsa.com 
- กําหนด Target (ลักษณะการเปดหนาตางใหม)  
- กําหนด Alt (ขอความที่ตองการแสดงเมื่อนํา Mouse ไปช้ีที่รูป และ OK 
 
การ Link ไปยัง File ใหม หรือ Web Site ใหม แตยังอยูในหนาตางเดิม 
กําหนด Link ใหกับขอความ หรือรูปภาพที่ตองการ และใส URL ที่ตองการลงไปในชอง Link ใน Properties 
Inspector โดยไมตองกําหนด Target 
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การ Link โดยใช Image Map Link 
การทําใหรูปภาพ 1 รูป เปนหลายๆ Link 
      สวนที่เปน Link 
 
 
 
 
ขั้นตอนการสราง Image Map Link 
- Click ที่รูปภาพที่ตองการ 
- Click เลือกเครื่องมือ         เพื่อกําหนดลักษณะพื้นที่ ที่จะใหเปน Link ที่ Image Properties 
- กําหนดพื้นที่ตามตองการ 
- กําหนด File หรือ URL ที่ตองการจะ Link ไป 
- กําหนด Target และ Alt ตามตองการ 
• ตองการแกไขรายละเอียดของ Map Link ให Click ที่     และ Click ที่ Map Link ที่ตองการ 
• ในรูป 1 รูป จะสราง Map Link กี่รูปก็ได 
 
การ Link ไปยังขอความหรือตอนใดตอนหนึง่ที่อยูใน File เดียวกัน (Anchor) 
จะใชกับ File ที่มีเนื้อหามากๆ เพื่อให Link ไปหาขอมูลที่ตองการไดอยางรวดเร็ว เชน File ที่มีหัวขออยูดานบน 
และมีรายละเอียดอยูดานลาง 
 
ขั้นตอนการกําหนด Link ภายใน File 
 

กําหนดชื่อของแตละจุดที่ตองการให Link ไป 
- Click ที่ตําแหนงที่ตองการ และ Click ที่ Icon  Name Anchor ที่ Common Panel 
- กําหนดชื่อที่ตองการ และ OK 
• จะมีรูป         แสดงที่ตําแหนงที่กําหนด 
 
การกําหนด Link ใหแตละตําแหนงที่ตองการ 
- เลือกขอความหรือรูปที่ตองการ 
- กําหนดตําแหนง Link ที่ตองการจะไป ในชอง Link  
 
รูปแบบ   #ช่ือตําแหนงที่ตองการที่ไดตัง้ไว  
เชน     #Top 
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การ Link ไปยังขอความหรือตอนใดตอนหนึง่ที่อยูใน File อื่น 
ขั้นตอนการทํา Link เหมือนกับการ Link ภายใน File เดียวกัน 
- กําหนดตําแหนง และชื่อ Anchor ในแตละ File ที่ตองการจะ Link ไป 
- ในการกําหนดตําแหนงของ  จะเปลี่ยนไปดังนี้ 
รูปแบบ  ช่ือ File#ช่ือตําแหนงที่ตองการที่ไดตั้งไว 
เชน  index.htm#main  เปนการกําหนด Link ภายใน Site เดียวกัน 
  http://www.bangkokmap.com/data.htm#sample1 เปนการกําหนด Link ระหวาง Site 
 

การ Link ไปยัง File อื่น และให File นั้นอยูในหนาตางใหม 
ขั้นตอนการทํา Link เหมือนกับการ Link ปกติ แตจะมีการกําหนดรายละเอียดของ Target เพิ่มขึ้นมา 
_blank  เปดเปน Window เล็ก   
_parent  เปดเปน Window ใหญเต็มหนาจอ 
 
การกําหนด Email Address ใหเปน Link 
- เลือกขอความหรือรูปที่ตองการ 
- ในชอง Link กําหนด mailto:xxx@xxx.com 
- หรือ Click ปุม   ที่ Common Panel  และกําหนดขอความ และ Email Address และ OK 
 
การสราง Download File 

• ทํา File ที่ตองการให Download เปน File ZIP และ Copy ไปไวใน Site ที่กําลังทํางานอยู 
- เลือกขอความหรือรูปที่ตองการ 
- กําหนดตําแหนง Link ใหเปน File ที่เตรียมไว ในชอง Link  
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การใช Frame ในการออกแบบ 
คือการแบงพื้นที่ของหนาจอ ออกเปนสวนๆ เพื่อใหเกิดความสวยงาม และจะชวย Load File ใหเร็วขึ้น 
ขอเสียของการใช Frame 
จะมี File เพิ่มขึ้นตามจํานวน Frame ที่กําหนด และทําใหโครงสรางของ Site มีความซับซอนมากขึ้น 
 

File ที่เกิดจากการสราง Frame 
  ถาออกแบบ Frame ดังนี้ 

             2 
2 3

 3 

1. File Frameset 1. File Frameset 
 
 
 
 
จะเกิด File ทั้งหมด 3 File คือ จํานวน Frame +1 
1. File Frameset 
2. File ดานบน / ดานซาย 
3. File ดานลาง / ดานขวา 
Frameset    คือ File ที่เก็บขอมูลของการแบงพื้นที่ Frame  / เปน File ตัวหลักที่เรียกใชงาน 
 

การสราง Frame 
- เปล่ียน Object Palette ใหเปนหมวดคําส่ัง Frames 
- เลือกรูปแบบของการแบงพื้นที่ ที่ตองการ ใน Frames Object 

 สามารถปรับขนาดพื้นที่แตละสวนไดตามตองการ โดยนํา Mouse มาชี้ ที่เสนแบงพื้นที่ (Frames Borders) 
 สามารถสราง Frame ยอยซอนใน Frame ที่มีอยูแลวได 
    ถา Frame Borders ไมแสดง ใหเลือกคําส่ัง View > Visual Aids > Frame Borders 

 

การเลือก Frame / Frameset 
- เลือกคําส่ัง Window > Others > Frames เพื่อแสดง Frames Palette ขึ้นมา 

  การเลือก Frameset  ให Click ที่ขอบ Border ของ Frame ที่ Frames Palette 
  การเลือก Frame ยอย  ให Click ในชอง Frame ยอย ที่ตองการ ที่ Frames Palette 

 
 

การเลือก Frame ยอย 

การเลือก Frameset  
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การ Save File ของ Frameset / Frame 
การ Save File Frameset
- Click ที่ Frame Borders 
- เลือกคําส่ัง File > Save Frameset   จะเปน File หลักที่เปดใชงาน 
การ Save File Frame ยอย
- Click ที่พื้นที่ของ Frame ที่ตองการ ที่หนาจอของการออกแบบ 
- เลือกคําส่ัง File > Save Frame 

  ตอง Save File Frame ยอยใหครบตามจํานวน Frame 
  เมื่อมีการแกไขขอมูล เมื่อจะ Save File ใหใชคําส่ัง File > Save All 
  หรือ Preview ดูใน Browser ไดเลย แลวโปรแกรมจะเตือนให Save กอน ใหตอบ OK 

 

แนวความคิดในการแบงพ้ืนที่ของ Frame 
    ใชเปน Menu ประมาณ 10-20% ของหนาจอ 
 
    แสดงเนื้อหา 
 
 
    แสดงเนื้อหา 

             1 

  2 

 
 2 1 

 
 
 สวน Menu ประมาณ 25% ของหนาจอ 
 
     1 และ 2 จะเปน Menu 
     3 จะเปน เนื้อหา 
   
 
 
  1 และ 3 จะเปน Menu 
  2 จะเปน เนื้อหา 
   
 

  การกําหนด Page Title จะตองกําหนดไวที่ Frameset 

 
1 

   2 

   3 

               1 
  2 
 
  3 

                 2 
1 

  3

 

การใสสีพ้ืนในแตละ Frame 
- Click บริเวณพื้นที่ของ Frame ที่ตองการ ที่หนาจอของการออกแบบ 
- Click Mouse ปุมขวา และเลือกคําส่ัง Page Properties 
- กําหนดรายละเอียด และ OK 
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การ Target Link เพ่ือควบคุมการแสดงของขอมูลใน Frame ที่ตองการ 
- ตั้งชื่อ Frame ยอยๆ ใหครบ 
- เมื่อกําหนด Link จาก Frame ที่ใชเปน Menu เรียบรอยแลว 
- กําหนด Target ตามตองการ ปกติจะเลือกชื่อ Frame ที่เปนเนื้อหา 
Frame Target ที่มีมากับโปรแกรม 
_Blank  การเปดหนาตาง Link เปนหนาตางใหม แลวใหคงหนาตางเดิมไว (เปดเปนหนาตางเล็ก) 
_Parent  การเปดหนาที่ Link ในหนา Frame หลักของหนานั้น (เปดเปนหนาตางใหญ) 
_Self  การเปด Link ในหนา Frame ที่กด Link หนาใหมจะแทนที่ใน Frame เดิม 
_Top  การเปด Link ที่กดขึ้นมาเต็มทั้งหนาจอ โดยแทนที่ทุก Frame ที่อยูในหนาเดิม 
 

การใชคําส่ัง NoFrames 
ใชแสดงขอมูลที่ตองการในกรณีที่ Browser ไมสามารถ แสดงผลของ Frame ได 

- เลือกคําส่ัง Modify > Frameset > Edit NoFrames Content 
  จะเปดหนาจอวาง และดานบนมีคําวา NoFrames Content แสดงอยู 
  สามารถกําหนดขอความ / รูปแบบไดตามตองการ เหมือนเปน Web Page หนาหนึ่ง 
  เมื่อกําหนดรายละเอียดเรียบรอยแลว  

- เลือกคําส่ัง Modify > Frameset > Edit NoFrames Content ซ้ําอีกครั้ง จะกลับไปที่หนาจอปกติ 
 

สวนประกอบของ Frameset Property 
 
 
 
 

 
 
 
 
Borders  เลือกการแสดงผลของ Border 

 Default  ให Browser กําหนดใหวาจะแสดงผลแบบไหน 
 Yes  แสดงผล Border เปน 3 มิติ สีเทา 
 No  แสดงผลเปนเสนสีเทาเรียบ 

Border Width ความกวางของ Border 
Border Color เลือกสีของ Border ใน Frameset นั้นๆ 
Row & Column Selection  การเลือกตั้งคา Value 
Value  คาความกวาง / ความสูง ของ Row / Column 
Units   หนวยที่ใชในการกําหนดความกวาง / ความสูง ของ Row / Column 

 Pixel     กําหนดความกวาง / ความสูง ของ Row / Column ใหคงที่ 
 Percent     กําหนดความกวางเปน % โดยสัมพันธกับหนาจอ 
 Relative     กําหนด Frame นั้นๆ ใหขยายตามความกวางที่เหลืออยูถา Frame อื่นๆ ถูกกําหนดความกวางไวแลว 
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สวนประกอบของ Frame Property 
 

 
 
 
 
 
 

 

Frame Name กําหนดชื่อ Frame เพื่อใชในการ Target 
Source File แสดงตําแหนงและชื่อ File ที่ใช 
Borders  เลือกการแสดงผลของ Border 
Border Color เลือกสีของ Border ใน Frame 
Scroll  กําหนดวาจะใหมี Scroll Bar หรือไม ในกรณีที่ขอมูลที่แสดงในหนาจอมีมากกวาพื้นที่แสดงผล 

 Yes  จะแสดง Scroll Bar เสมอ 
 No  ไมใหแสดง Scroll Bar 
 Auto  จะแสดง Scroll Bar อัตโนมัติถาขอมูลมีมากกวาพื้นที่แสดงผล 
 Default  สวนมากคา Default ใน Browser ตางๆ จะเปน Auto 

No Resize  ใชในการปองกันการขยับ Frame ที่ทํางานอยู 
Margin Width กําหนดชองวางระหวางตัวอักษรกับขอบของ Frame ดานขาง 
Margin Height กําหนดชองวางระหวางตัวอักษรกับขอบของ Frame ดานบน 
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การออกแบบ Web Page โดยใช Layer 
Layer จะนํามาใชในการจัดวางตําแหนงภายในหนาเอกสารใหมี Layout ที่สวยงาม โดยใชหลักการเหมือนกับ
แผนใสหลายๆ บนหนาจอ และ Browser ที่สนับสนุนการทํางานของ Layer จะเปน Version 4.0 ขึ้นไป โดย
ภายใน Layer สามารถบรรจุตัวอักษร,รูป,Plug-in หรือ Layer เอง ซึ่งมีประโยชนมากในการวาง Layout ที่มีการ
ซอนกันของ Object บนหนาจอ 

Layer ที่สราง

สัญลักษณของ Layer ที่
เปน Invisible Element 

 

การสราง Layer 
- Click Icon   Draw Layer ที่ Common Palette 
- กําหนดพื้นที่ของ Layer ตามตองการ 
 

การแสดง / ไมแสดง Layer Palette 
- เลือกคําส่ัง Window > Others > Layers ที่ Menu  
 
 

สวนประกอบของ Layer Palette 
 
 
 
 
 
 
 
 
 

 
 
การแสดง / ไมแสดง Layer 
- Click หนาชื่อ Layer ที่ตองการ 
 
 
 
 
 

Click ที่นี่ เพื่อแสดง Layer ทั้งหมด 

แสดง Layer 

คา Z-Index แสดงชั้น / ลําดับ
การซอนทับกันของ Layer 

การซอนกันของ Layer 
ยอย ใน Layer หลัก 

ชื่อ Layer 

การแสดง / ไมแสดง Layer 

ใชสําหรับปองกันไมให Layer ซอนทับกัน 
เพื่อใหงายตอการแปลงไปเปนตาราง 

ไมแสดง Layer 

การตั้งช่ือ Layer 
- Double Click ที่ชื่อ Layer ที่ตองการ และ พิมพชื่อ Layer ที่ตองการ และ Enter 
 

การเลือก Layer 
- Click ที่ชื่อ Layer ที่ตองการ ที่ Layer Palette 

  ตองการเลือกหลายๆ Layer ใช Shift
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การยายตําแหนง Layer 
- เลือก Layer ที่ตองการ และ Click ที่    และยายตําแหนงตามตองการ 
 

การเปลี่ยนลําดับการซอนกันของ Layer 
- เปล่ียนคา Z-Index ใหเปนตัวเลขมากกวา คาของ Layer ที่ตองการซอน ที่ Layer Palette 
- หรือ Click ที่ชื่อ Layer ที่ตองการ และยายตําแหนงใหอยูดานบนของ Layer ที่ตองการ 
 

การกําหนดใหมีการซอนกันของ Layer ยอย ใน Layer หลักได 
- เลือกคําส่ัง Edit > Preferences และเลือกหมวดคําส่ัง Layers 
- เลือก  ที่ บรรทัด  
 

การยาย Layer ใหไปอยูเปน Layer ยอย ใน Layer หลัก 
- เลือก Layer ที่ตองการจะยายไปเปน Layer ยอย ของ Layer อื่น และกด Ctrl และลากไปปลอยที่ตองการ 
- หรือ Click ที่สัญลักษณ       ของ Layer ที่เลือก และยายใหไปอยูในพื้นที่ของ Layer หลักที่ตองการ 
 

ผลที่ได 
 
 
      การเปลี่ยนลําดับ 
รายละเอียดใน Layer Property 
 
 
 
 
 
Layer ID  การตั้งชื่อของ Layer 
คา L  เปนตัวกําหนดตําแหนงของ Layer ใหหางจากขอบทางซายกี่ Pixel 
คา T  เปนตัวกําหนดตําแหนงของ Layer ใหหางจากขอบดานบนกี่ Pixel 
คา W และ H ใชกําหนดความกวางยาวของ Layer 
คา Z-Index ใชกําหนดการซอนทับของ Layer และคาที่มากกวาจะอยูดานบน 
Visible  กําหนดวาจะให Layer แสดงใหเห็นหรือไม ซึ่งคาปกติคือการแสดง Layer 
Bg Image กําหนดรูปเพื่อเปน Background ใน Layer 
Bg Color กําหนดสีของ Background ใน Layer 
Tag  ปกติจะใช Tag DIV เปนคา Default 
Overflow การสั่งให Layer เปนอยางไร เมื่อเนื้อหาที่อยูใน Layer มีขนาดมากกวาพื้นที่แสดงผลของ Layer 

Visible พื้นที่ของ Layer จะขยายเพิ่มขึ้นใหพอดีกับเนื้อหาที่เพิ่มขึ้น         Scroll    แสดง Scroll เมื่อเนื้อหาเกิน Layer 
Hidden  พื้นที่ของ Layer จะเทาเดิมและแสดงเนื้อหาเทาที่แสดงได           Auto     โปรแกรมใส Scroll ใหอัตโนมัติ 

Clip L,R,T,B กําหนดคาให Object ภายใน Layer อยูหางจากขอบของ Layer ทั้ง 4 ดาน 
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การแปลง Web Page ที่สรางจาก Layer ใหเปน Table เพ่ือใชกับ Browser Version 3.0 ที่ไม Support Layer 
  Layer จะตองไมซอนกัน และไมมี Layer ยอย อยูใน Layer หลัก 

- เลือกคําส่ัง File > Convert > 3.0 Browser Compatible และ OK 
  จะได File ใหม ที่มี Layout เปน Table และ File เกา ที่เปน Layer ก็ยังอยู 

 

การแปลง Web Page ที่สรางจาก Layer ใหเปน Table แตยังทํางานอยูใน File เดิม 
  Layer จะตองไมซอนกัน และไมมี Layer ยอย อยูใน Layer หลัก 

- เลือกคําส่ัง Modify > Convert  > Layers to Table และ OK 
 

การปรับขนาดของ Layer ใหเทากัน 
- เลือก Layer ที่ตองการ และเลือก Layer ที่ตองการเปนตนแบบ เปนตัวสุดทาย 
- เลือกคําส่ัง Modify > Align 
- เลือกคําส่ัง  Make Same Width หรือ Make Same Height 
 
 
 
 
 
 
 
การจัดเรียง Layer 

ตองการปรับขนาดใหเทากับ Layer นี้ 
ใหเลือก Layer นี้เปนตัวสุดทาย 

- เลือก Layer ที่ตองการ และเลือก Layer ที่ตองการเปนตนแบบ เปนตัวสุดทาย 
- เลือกคําส่ัง Modify > Align 
- เลือกคําส่ัง  Left หรือ  Right หรือ  Top หรือ  Bottom 
Align Right      Align Left 
 
 
 
 
 
 
 
 
Align Top       Align Bottom 
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การออกแบบโดยใชตาราง 
การสรางตาราง 
- Click ตําแหนงที่ตองการ 
- Click Icon       Insert Table ที่ Insert Palette 
- กําหนดรายละเอียด และ OK 
 

Rows / Columns จํานวนแถวแนวตั้งและแนวนอน 
Width ความกวางของตาราง (แบบ Percent จะเปนความกวางตามสัดสวนของหนาจอ / ระบุขนาดเปนหนวย Pixel) 
Border  ขอบของตาราง ถาไมตองการแสดงให = 0 
Cell Padding ความหางของ Object กับขอบ Cell    
Cell Spacing ความกวางของขอบ Cell 

 

การเลือก Cell ในตาราง 
 เลือก Cell  Click ที่ Cell ที่ตองการ 
 เลือก Row  ชี้ที่ขอบดานซายของ Row ที่ตองการ และ Click 
 เลือก Column  ชี้ที่ขอบดานบนของ Column ที่ตองการ และ Click 
 เลือกทั้งตาราง ชี้ที่ขอบดานลางของตาราง และ Click 
 เลือกที่บรรทัด Status Bar ในสวนของ body 

 

การแทรก Row / Column 
  การแทรก Row จะแทรกเหนือ Row ที่เลือก / การแทรก Column จะแทรกดานซายของ Column ที่เลือก 

- เลือก Row / Column ที่ตองการ 
- นํา Mouse ชี้บริเวณที่เลือก และ Click Mouse ปุมขวา 
- เลือกคําส่ัง Table และเลือกคําส่ัง Insert Row / Insert Column 
 

การลบ Row / Column 
- ขั้นตอนเหมือนเดิม เปล่ียนมาเลือกคําส่ัง Delete Row / Delete Column 
 

การรวม Cell 
- เลือก Cell ที่ตองการ Click Icon Merge Cell ที่ Table Property 
 

Icon Split CellIcon Merge Cell 

การแยก Cell 
- เลือก Cell ที่ตองการ Click Icon Split Cell ที่ Table Property 
- กําหนดรายละเอียด และ OK 

  ควรจะแบงในแนว Column กอน แลวคอยแบงในแนว Row 
 

การเปลี่ยนรูปแบบของตาราง 
- เลือกตาราง และเลือกคําส่ัง Commands > Format Table 
- เลือกรูปแบบที่ตองการ และ OK 
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การใสตัวอักษร / ขอความ และรูปภาพลงในตาราง 
ตัวอักษร / ขอความ 

สามารถ Copy และ Paste ลงใน Cell ได ถา Copy มาจาก File ที่เปน Text เชน .Doc  
ให Paste แบบ Paste as Text ในคําส่ัง Edit เพื่อรักษายอหนาตางๆ ใหเหมือนเดิม 

รูปภาพ เลือก Cell และ Insert Image ตามปกติ 
 

การแปลง Web Page ที่สรางจาก Table ใหเปน Layer แตยังทํางานอยูใน File เดิม 
- เลือกตารางที่ตองการ  
- เลือกคําส่ัง Modify >  Convert > Tables to Layers และ OK 
 

รายละเอียดใน Table Property 
 

Property ของการเลือก Table ทั้ง Table 
 
 
 
 
 
 
Table Name สําหรับตั้งชื่อ Table 
Rows / Cols สําหรับใสจํานวน Rows / Columns 
W และ H  กําหนดความกวาง / ความสูงของตาราง (เปน % และ pixels) 
CellPad  ความหางของ Object กับขอบ Cell    
CellSpace ความกวางของขอบ Cell 
Align  จัดตําแหนง Left,Right,Center ของตาราง 
Border  ความกวางของขอบตาราง 
       Clear Row Heights ลดขนาดของตาราง ใหกลับมาที่ความสูงจริง (อาจมีชองวางเกินออกมาในการออกแบบ) 
       Clear Column Width ลดขนาดของตาราง ใหกลับมาที่ความกวางจริง 
 เปล่ียนความกวางใหเปน % 

เปล่ียนความกวางใหเปน Pixel 
Background Image กําหนดรูปฉากหลังของตาราง 
Background Color กําหนดสีฉากหลังของตาราง 
Border Color  สีของขอบตาราง 
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การออกแบบโดยใช Page Layout 
ใชสําหรับจัดหนา Web Page เพื่อใหสรางตารางไดอยางยืดหยุน และงายตอการปรับแตงพื้นที่ 
 

การออกแบบโดยใช Layout View 
- เลือกหมวด Layout ที่ Insert Panel 
- ถามีขอความเตือน ให OK และเลือก Layout View 
- ตองการกลับไปที่หนาจอปกติ เลือก Standard View 

การสรางตารางที่เปนพื้นที่ที่ใชในการออกแบบหนา Web Page 
- Click ที่ปุม  Draw Layout Table 
- วาดพื้นที่ตามตองการ (ไมตองใหญมาก เพราะสามารถกําหนดขนาดไดที่ Properties ) 
- กําหนดรายละเอียดที่ Properties (760 x 420) 

 
 
 
 
 
Properties ของ Layout Table 
 
 
 
 
Width กําหนดความกวางของตาราง 
 Fixed  กําหนดความกวางของตารางตามตองการ หนวยเปน Pixels 
 Autostretch ใหโปรแกรมกําหนดความกวางของตารางใหโดยอัตโนมัติ 
Height กําหนดความสูงของตาราง 
Bg กําหนดสีพื้นของตาราง 
Cell Padding กําหนดความสูงของทุก Cell ในตาราง 
Cell Spacing กําหนดระยะหางระหวาง Cell 
Clear Row Heights ลบความสูงของตารางใหเทาขนาดวัตถุที่อยูภายในพื้นที่ตาราง 
 
การสราง Cell เพ่ือใส Object ตางๆ ที่ตองการ 

- Click ที่ปุม  Draw Layout Cell 
- วาดพื้นที่ตามตองการ  
- กําหนดรายละเอียดที่ Properties 
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Properties ของ Layout Cell 
 
 
 
 
Width กําหนดความกวางของตาราง 
 Fixed  กําหนดความกวางของตารางตามตองการ หนวยเปน Pixels 
 Autostretch ใหโปรแกรมกําหนดความกวางของตารางใหโดยอัตโนมัติ 
Height กําหนดความสูงของตาราง 
Bg กําหนดสีพื้นของตาราง 
Horz การจัดวางวัตถุที่อยูใน Cell ตามแนวนอน 
 Left ชิดขอบดานซายของ Cell 
 Center 
 Right 
 Default ชิดขอบดานซายของ Cell 
Vert การจัดวางวัตถุที่อยูใน Cell ตามแนวตั้ง 
 Top ชิดขอบดานบนของ Cell 
 Middle 
 Bottom 

Baseline   ชิดขอบดานบนของ Cell 
Default ชิดขอบดานบนของ Cell 

No Wrap  ไมใหมีการตัดคําไปขึ้นบรรทัดใหมเมื่อมีการเวนวรรค 
 

การกําหนด Object ลงใน Cell 
- Click ใน Cell ที่ตองการ และพิมพขอความ หรือใสรูปภาพตามตองการ 

 

การทํางานกับ Cell 
- Click ใน กรอบของ Cell ที่ตองการ  

o กด Delete เพื่อลบ Cell 
o ใชลูกศรที่ Keyboard เพื่อปรับตําแหนง Cell 
o กําหนดรายละเอียดที่ Properties 

 

การตัดที่วางสวนเกินในแนวตั้งของ Cell  
- เลือก Clear Cell Heights 
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การกําหนดให Column ยืดขนาดเองอัตโนมัต ิ
- เลือก Make Column Autostretch 

 
 
 
 
 
 
 
 
 

- หรือ เลือก ที่ Autostretch Properties 
 
 
 
 
 

- ในการทํา Column Autostretch นั้น โปรแกรมจะตองเติมชองวางลงไปให เรียกวา Spacer Image ใช
ในการควบคุมชองวางของ Cell ในตารางที่ไมคงที่ เพื่อปองกันไมให Cell เขามาเกยกันได 

 
 
 
 
 
 
 
 
 
 
 
 

 Create a spacer image file สราง spacer image file ขึ้นใหม 
 Use an existing …..  ใช spacer image file ที่มีอยูเดิม 
 Don’t use spacer ….  ไมใช spacer image file 

 
- กําหนดลักษณะของ File Spacer Image และ OK 
- กําหนด Folder ที่ตองการจัดเก็บ และ Save 
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การสราง Rollover และ Behavior Show-Hide Layer 
คือเทคนิคในการเปลี่ยนภาพ จากภาพหนึ่งไปเปนอีกภาพหนึ่ง โดยเลื่อน Mouse ไปที่ภาพนั้น และเมื่อเล่ือน 
Mouse ออกมา รูปภาพก็จะกลับเปนรูปเดิม สวนมากจะใชกับสวนที่เปน Menu หรือ Navigation bar 

 

ขั้นตอนการทํา Rollover 
• ตองเตรียมรูปภาพใหพรอม และ Save ไวที่ Local Site ที่ตองการ ใหเรียบรอย 
- Click ตําแหนงที่ตองการ 
- สรางตาราง 1 Column และ Row = จํานวนบรรทัดของ Menu ที่ตองการสราง และปรับขนาดใหเหมาะสม 
- Click Cell ที่ตองการที่ตาราง และ Click Icon            Rollover Image ที่ Common Palette 
- กําหนดรายละเอียด เรียบรอยและ OK 
 
 
 
 
 
 
 
 
 
 
 
Image Name   การตั้งชื่อของภาพ และควรตั้งชื่อทุกภาพที่นํามาใช 
 

Original Image   รูปที่ตองการแสดงตอนแรก ขณะที่ยังไมไดลาก Mouse ผาน 
 

Rollover Image   รูปที่ตองการใหเปล่ียน ขณะที่ลาก Mouse ผาน 
 

Preload Rollover Image  กําหนดให Load ภาพที่ 2 มาไวที่แคชของ Browser กอน  
เพื่อปองกันการ Delay ของภาพเมื่อลาก Mouse ผาน 

 

Alternate Text   กําหนดคําอธิบายภาพ 
 

When Clicked, Go to URL  กําหนดหนา Home Page หรือ URL ที่ตองการจะ Link ไป 
 
• ทําใหครบทุก Menu เรียบรอยและ Preview ดูใน Browser 
• ถาใชภาพเคลื่อนไหวที่เปนแบบแสดงเพียงรอบเดียวแลวหยุด ใหเอา  ออกที่ Preload Rollover Image 

เพื่อปองกันการไมแสดงภาพเคลื่อนไหว เมื่อลาก Mouse ผาน 
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การสราง Rollover แบบเปล่ียน 2 ภาพพรอมกัน 
• ลักษณะคือเมื่อเล่ือน Mouse ไปที่รูป ก็จะเปลี่ยนเปนรูปที่ 2 และแสดงรูปอีกรูปขึ้นมาบริเวณดานซายดวย 
• ตองเตรียมรูปภาพใหพรอม และ Save ไวที่ Local Site ที่ตองการ ใหเรียบรอย 
• ตองสรางภาพเริ่มตนเพื่อใสลงไปใน Cell ดานซาย โดยใหมีเดียวกันกับสี Background ของ Home Page ที่

สราง และใหมีขนาดเทากับรูปที่ตองการใหแสดงออกมาบริเวณดานซาย (เปนรูปส่ีเหลี่ยมธรรมดา) 
 

ขั้นตอนการทํา Rollover 
- Click ตําแหนงที่ตองการ 
- สรางตาราง 2 Column และ Row = จํานวนบรรทัดของ Menu ที่ตองการสราง และปรับขนาดใหเหมาะสม 
- Click Cell ที่ตองการที่ตาราง ในสวน Column ทางขวาของตาราง และ นําภาพเริ่มตนมาใสใหครบ  

โดยใชคําส่ัง Insert Image และตั้งชื่อใหเรียบรอย และไมตองกําหนด Rollover 
- Click Cell ที่ตองการที่ตาราง ในสวน Column ทางซายของตาราง และ นําภาพที่สรางเปนสี Background ไวแลวมาใส  

และกําหนดขนาดใหพอดีกบัรูปที่ตองการใหเปล่ียน และตั้งชื่อใหเรียบรอย 
- แสดง Behaviors Palette ขึ้นมา โดยใชคําส่ัง Window > Behaviors 
- Click ที่รูปที่ตองการที่อยู Column ทางขวาของตาราง จากตัวอยาง เลือก Image ชื่อ window 
- Click ที่    ที่ Behaviors Palette และเลือกคําส่ัง Swap Image 
 
 
 
 
 
 
จากตัวอยาง 
Image ชื่อ window  คือ รูปที่แสดงตอนแรก ที่อยูทางดานขวาของตาราง 
Image ชื่อ white1   คือ รูปที่แสดงตอนแรก ที่อยูทางดานซายของตาราง 
วิธีกําหนดรูป Rollover 
- เลือกรูปที่ตองการจะใหเปล่ียนเปนรูปอื่นเมื่อเล่ือน Mouse ไปที่รูป  ที่อยูทางดานขวาของตาราง 

จากตัวอยาง เลือก Image ชื่อ window 
- เลือกรูปที่ตองการจะใหเปล่ียนแทนรูปเดิม ที่ Set Source to 

จะมี * แสดงขึ้นมา เพื่อแสดงวามีการกําหนดภาพที่จะมาแทนที่แลว 
- เลือกรูปที่ตองการจะใหเปล่ียนเปนรูปอื่นเมื่อเล่ือน Mouse ไปที่รูป  ที่อยูทางดานซายของตาราง 

จากตัวอยาง เลือก Image ช  white1 ื่อ
- เลือกรูปที่ตองการจะใหเปล่ียนแทนรูปเดิม ที่ Set Source to 

จะมี * แสดงขึ้นมา เพื่อแสดงวามีการกําหนดภาพที่จะมาแทนที่แลว 
- เรียบรอย และ OK จะกลับไปที่หนาจอ Behaviors Palette 
• ทําใหครบทุก Menu เรียบรอยและ Preview ดูใน Browser 
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Events     คือเงื่อนไขของเหตุการณที่จะเกิดขึ้นในหนา Home Page นั้น 
Actions     คือคําส่ังที่ให Browser ทําเมื่อเกิด Event นั้นๆ ขึ้นมา 
 
 
 
 
การสราง Rollover แบบเปล่ียนภาพหลายๆ ภาพพรอมกัน ลงในพื้นที่วางเดียวกัน
• หลังจากที่สราง Rollover แบบเปลี่ยน 2 ภาพพรอมกัน เรียบรอยแลว จึงมากําหนดภาพที่ 3 ที่ตองการ 
• ลักษณะคือเมื่อเล่ือน Mouse ไปที่รูป ก็จะเปลี่ยนเปนรูปที่ 2 และแสดงรูปอีกรูปขึ้นมาบริเวณดานซายดวย 

และแสดงรูปอีก 1 รูปที่ตําแหนงอื่น หรือเปล่ียนรูปที่ตําแหนงอื่นอีก 1 จุด 
• ควรสรางรูปที่ตองการใหเปล่ียนแปลงที่ตําแหนงอื่น ใหมีขนาดของรูปเทากัน เพื่อรายละเอียดของรูปจะได

ไมเปล่ียนแปลง 
 

ขั้นตอนการทํา Rollover 
- สราง Layer และกําหนดพื้นที่และตําแหนงตามตองการ 
- นํา Image มาใสใน Layer และปรับขนาด Layer ใหพอดีกับรูปภาพ และตั้งชื่อ Layer ใหเรียบรอย 

(Image อาจเปนรูปวางๆ และมี Background เปนสีเดียวกับสีพื้นก็ได) 
- Click เลือกภาพที่เล่ือน Mouse ผาน และเปล่ียนรูป (รูปที่เปน Menu) 
- Double Click ที่ Event ชื่อ onMouseOver ที่ Behaviors Palette 
 
 
 
 
 
 
 
 
 
- Click เลือกบรรทัดที่เปนชื่อ Image ที่อยูใน Layer ที่ตองการ 

จากตัวอยาง เลือก image “bank” in layer “Layer1” 
- กําหนดรูปที่ตองการจะใหเปล่ียนไป ที่ Set Source to 
- เรียบรอย และ OK จะกลับไปที่หนาจอ Behaviors Palette 
• ทําใหครบทุก Menu เรียบรอยและ Preview ดูใน Browser 
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การสราง Menu โดยใชคําส่ัง Navigation Bar 
• ตองเตรียมรูปภาพใหพรอม และ Save ไวที่ Local Site ที่ตองการ ใหเรียบรอย 
• ใน Home Page หนึ่งๆ จะมี Navigation Bar ได 1 ชุดเทานั้น จึงควรใช Frame เขามาชวย 
 

ขั้นตอนการสราง Navigation Bar 
- Click ตําแหนงที่ตองการ 
- Click ที่ Icon    Navigation Bar 
- กําหนดรายละเอียดใหเรียบรอย และ OK 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Nav Bar Elements  แสดงชื่อของปุม Link ที่มี 
Element Name   กําหนดชื่อของปุม Link ที่ตองการใหมี 
Up Image   กําหนด File ที่ตองการใชแสดงเริ่มตน 
Over Image   กําหนด File ที่ตองการใชแสดง เมื่อเล่ือน Mouse มาชี้ 
Down Image   กําหนด File ที่ตองการใชแสดง เมื่อ Click ที่ปุม 
Over While Down Image  กําหนด File ที่ตองการใชแสดงแทน Over Image หลังจากที่ Click ปุมไปแลว 1 ครั้ง 
Alternate Text   กําหนดคําอธิบายปุม 
When Clicked, Go To URL  กําหนด File หรือ URL ที่ตองการ Link ไป 
In    กําหนดลักษณะการเปดของหนาตางที่ Link ไป 
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Options    กําหนดลักษณะการ Load ภาพ 
Preload Images   กําหนดให Browser Load ภาพทั้งหมด มาไวในเครื่องกอนทํา Rollover 
Show “Down Image” Initially กําหนดใหแสดง Down Image ในตอนเริ่มตน 

Insert    กําหนดลักษณะการจัดเรียงของปุม 
Horizontally   ลักษณะการจัดเรียงของปุมในแนวนอน 
Vertically   ลักษณะการจัดเรียงของปุมในแนวตั้ง 

 
การแกไข Navigation Bar 
- Click บริเวณพื้นที่ของ Frame ที่มี Navigation Bar อยู 
- เลือกคําส่ัง Modify > Navigation Bar 
- กําหนดรายละเอียดใหเรียบรอย และ OK 
 
คําสั่ง Behavior Show-Hide Layers 
ใชสําหรับการสั่งใหแสดง / ซอน Layer ที่ตองการ ในการทํางานกับ Layer ในลักษณะเมื่อนํา Mouse ไปช้ี Layer 
ที่ตองการ และใหมีขอความหรือรูปภาพแสดงขึ้นมา 
 
ขั้นตอนการทํา Show-Hide Layers 
- สราง layer และ Inset Image ตามตองการ และตั้งชื่อ Layer ใหเรียบรอย 
- ปดการแสดงของ Layer ที่ตองการซอน 
- กําหนด Link ใหกับ Layer หลัก ตามตองการ 
- Click เลือก Layer / รูปที่ตองการ ใหเปน Layer หลัก 
- Click เครื่องหมาย + ที่ Behavior Palette และเลือกคําส่ัง Show-Hide Layers 
- เลือก Layer ที่ตองการ แสดง / ซอน และ Click ปุม Show จะมีคําวา Show แสดงขึ้นที่ Layer นั้น และ OK 
- เปล่ียน Event เปน onMouseOver ที่ Behavior Palette 
- Click เครื่องหมาย + ที่ Behavior Palette และเลือกคําส่ัง Show-Hide Layers 
- เลือก Layer ที่ตองการ แสดง / ซอน และ Click ปุม Hide จะมีคําวา Hide แสดงขึ้นที่ Layer นั้น และ OK 
- เปล่ียน Event เปน onMouseOut ที่ Behavior Palette 
• เรียบรอยและ Save และ Preview ดูใน Browser 
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การใช Timeline ในการสราง Animation 
Timeline ใน Dreamweaver ใช Dynamic HTML เพื่อเปล่ียนคุณสมบัติของ Layer และรูปภาพตามเวลาที่เปล่ียนเฟรมตอ
เฟรม หรือ การทําให Layer สามารถเคลื่อนที่ไดอัตโนมัติ และ Timeline ยายตําแหนงไดเฉพาะ Layer แตไมสามารถยาย
ตําแหนงรูปภาพหรือตัวอักษรได ถาตองการใหรูปภาพหรือตัวอักษรเคลื่อนที่ได ตอง Insert รูปภาพหรือตัวอักษร ลงใน Layer 
 
 
 
 
 
 Animation Channel 

Animation bars 

Behavior Channel 

 
ขั้นตอนการสราง Timeline Animation 
- สราง Layer และใสรูปภาพหรือตัวอักษร และปรับขนาดและตําแหนงใหเรียบรอย 
- แสดง Timeline Inspector ขึ้นมา โดยเลือกคําส่ัง Window > Others > Timelines 
- Click เลือก Layer ที่ตองการ ใหเลือกที่ Layer Palette จะดีกวาเพื่อปองกันความผิดพลาด 
- นํา Mouse ชี้ที่ ตําแหนงสําหรับการยาย Layer และลากไปไวที่ Timeline Inspector ที่บรรทัดที่ 1 และที่ Frame แรก 

• ปกติจะกําหนดจํานวน Frame ให 15 Frame 
• จะมี Keyframe เริ่มตนที่ Frame ที่ 1 และ Keyframe สุดทายที่ Frame ที่ 15 
• ตองการให Animation เลนนานขึ้น ใหนํา Mouse ชี้  Keyframe สุดทาย และขยายไปถึง Frame ที่ตองการ 

 
 
 
 
 
 
 
การทําให Layer เคล่ือนที่ได 
- กด Ctrl และ Click ที่ Frame ที่ตองการที่ Animation bars เพื่อเพิ่ม Keyframe ขึ้นมาใหม 
- ยายตําแหนง Layer ที่มีรูปภาพอยูที่หนาจอ ไปที่ตําแหนงที่ตองการ 

• ถาตองการใหการเคลื่อนที่ไมกระโดด ควรกําหนด Keyframe ในลักษณะที่มีการเคล่ือนที่ไปแลว ใหมีการ
เคลื่อนที่กลับดวย และควรกําหนด ใหมีระยะหางที่เทาๆ กัน 

• สามารถยายตําแหนง Keyframe ได และถาตองการใหเคลื่อนที่ชาลง ใหเพิ่มจํานวน Frame 
• กําหนด Autoplay เพื่อให Timeline Play อัตโนมัติ เมื่อแสดงใน Browser 
• กําหนด Loop เพื่อให Timeline Play วนไปเรื่อยๆ และจะเกิด Go to Timeline Frame ใน Behavior Channel 

โดยจะอยูหลัง Frame สุดทายของ Animation 
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การลบ Animation ที่สรางไว 
- Click Animation ที่ตองการ ที่ Animation bars และกดปุม Delete 
 

การลบ Keyframe 
- Click ที่ Keyframe ที่ตองการ ที่ Animation bars และ Click Mouse ปุมขวา และเลือกคําส่ัง Remove Keyframe 
 
การทําใหภาพเปล่ียนรูปเองอัตโนมัต ิ
 

การทําใหภาพเปล่ียนรูปเองอัตโนมัติ ในกรณีที่รูปอยูกับที ่
• รูปที่นํามาใชควรมีขนาดของรูปที่เทากัน 
- สราง Layer และนํารูปมาใสใน Layer และปรับขนาดตามตองการ 
- นํา Layer มาใสใน Animation Channel 
- Insert Keyframe ที่ Frame ที่ตองการใหมีการเปลี่ยนรูป และนํา Mouse Click ที่ Behavior Channel 
- Click ที่เครื่องหมาย +  ที่ Behavior Palette และเลือกคําส่ัง Swap Image 
 
 
 
 
 
 
 
- เลือกชื่อ Image ที่ตองการ และกําหนดรูปที่ตองการใหเปล่ียน ที่ Set Source to และ OK 
- ทําจนครบตามตองการและ Preview ดูใน Browser 
• การลบ Behavior ทําไดโดย Click ที่ Behavior ที่ตองการ และ Click ขวา และเลือกคําส่ัง Remove Behavior 
 
การทําใหภาพเปล่ียนรูปเองอัตโนมัติ ในกรณีที่รูปเคล่ือนไหว 
• ขั้นตอนเหมือนกับรูปอยูกับที่ เพียงแตกําหนดการเคลื่อนไหวเขาไป 
• ในการเปลี่ยนรูปควรเลือกตําแหนงที่เปน Keyframe เพื่อความสวยงาม 
• ควรตรวจดูตําแหนงของรูป กอนกําหนดคําส่ังเปลี่ยนรูป โดยนํา Mouse Click ที่ Keyframe ที่ตองการ 
• สามารถเปลี่ยนขนาดของรูปไดในขณะที่มีการเคล่ือนที่ 
 

การเปลี่ยนแปลงรูปภาพที่ไดกําหนดไปแลว 
- Click  ที่ Behavior ของ Frame ที่ตองการ 
- Double Click ที่ Event ที่ Behavior Palette 
- เปล่ียนรูปตามตองการ และ OK 
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การสราง Form ใน Web Page 
Form ถูกใชสําหรับการเก็บขอมูลของผูที่เขามาเยี่ยมชม Web Site นั้นๆ เพื่อการทําประโยชนตางๆ ทั้งผูใชและเจาของ Web Site  
 

ในการทํางานหลักของ Form ตองมีสวนประกอบสําคัญ 2 สวน คือ 
1. Coding ของ Form ใน HTML 
2. โปรแกรมในสวนของ Server ที่จะทําการประมวลผลคําส่ังที่สงมาจากเครื่อง Client (ผูใช) แลวสงผลกลับไปแสดงที่ Client 

โปรแกรมสวนมากจะเปน Perl / CGI (Common Gateway Interface) 
        สงขอมูลจาก Form 
 
 
    ประมวลผลและสงผลกลับ 

ServerClient 

การสราง Form 
- เลือกตําแหนงที่ตองการ 
- เปล่ียน Insert Palette ใหเปนหมวดคําส่ัง Forms 
- Click Icon         Insert Form ที่ Insert Palette 

  จะไดกรอบสีแดง แสดงขอบเขตของ Form ที่สรางขึ้น 
- สรางตารางขึ้นมาใน Form เพื่อชวยในการออกแบบ 
- กําหนดรายละเอียดของ Form 
 

รายละเอียดของ Form Property 
- Click บริเวณที่เปนกรอบสีแดง ที่แสดงขอบเขตของ Form 
 
 
 
 
 

Form Name สําหรับตั้งชื่อ Form 
Action  การกําหนดตําแหนงของโปรแกรม CGI ใน Server หรือ กําหนดให Mail Form ไปที่ไหน 
Method  วิธีการสงขอมูลของ Form 
 

การเพิ่ม Object ตางๆ เขาไปใน Form 
- Click ตําแหนงที่ตองการ 
- Click เลือก Object ที่ตองการ Insert ที่ Form Palette 
- กําหนดรายละเอียดตามตองการ 
 

Object ตางๆ ใน Form Palette 
       Text Field ใชสําหรับสรางชองเพื่อการปอนตัวอักษร / ตัวเลข / ขอความ  
รูปแบบ 
 
        Single Line     Multi Line          Password 
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สวนประกอบของ Text Field Property 
 
 
 
 

Text Field  ตั้งชื่อ Field ใหแสดงเมื่อสงถึงผูรับที่จะนําขอมูลไปใช 
Character Width  ความกวางของ Text Field ที่จะใหกรอกขอมูล 
Maximum Character กําหนดจํานวนตัวอักษรที่จะใหปอนลงไปได ในแบบ Single Line และ แบบ Password 
Num Lines  กําหนดจํานวนบรรทัดในแบบ Multi Line 
Single Line  สําหรับการปอนขอความบรรทัดเดียว 
Multi Line  สําหรับการปอนขอความมากๆ 
Password  สําหรับปอน Password เมื่อปอนขอมูลจะแสดงเปนดอกจัน 
Initial Value  กําหนดขอความที่จะแสดงเมื่อ Form นั้นถูก Load ขึ้นมาในตอนแรก 
Wrap   กําหนดใหโปรแกรมตัดคําระหวางการปอนขอมูล 
 

          Button ใชสําหรับการสงขอมูลของ Form ที่ปอนรายละเอียดเรียบรอยแลว 
รูปแบบ 
  

Submit form Reset form None 
สวนประกอบของ Button Property 

 
 
 

Button Name สําหรับตั้งชื่อปุม / ชื่อ Field ที่สอดคลองกับโปรแกรม CGI 
Label  สําหรับกําหนดขอความที่ตองการแสดงบนปุม 
Submit form สําหรับสงขอมูลของ Form ที่ปอนรายละเอียดเรียบรอยแลว ไปยัง Server 
Reset form สําหรับลบขอความทั้งหมดที่ปอนใน Form แลว เพื่อทําการปอนใหม 
None  ไมเลือกทั้ง Submit และ Reset เปนเพียงแคปุมกดเทานั้น 
 

        Checkbox ใชสําหรับการเลือกขอมูลที่สามารถเลือกไดหลายๆ ตัว 
รูปแบบ 
 

สวนประกอบของ Checkbox Property 
 
 
 

CheckBox  กําหนดชื่อของ CheckBox 
Checked Value  กําหนดคาหรือขอความที่จะสงให Server เมื่อถูกเลือก 
Checked  กําหนดใหปุมถูกเลือกไวกอนเลยขณะที่ Load Form 
Unchecked  ใหปุมวางไวสําหรับเลือก 
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         Radio Button ใชสําหรับการเลือกที่ตองเลือกเพียงอยางใดอยางหนึ่งในกลุมขอมูล 
รูปแบบ  
 

สวนประกอบของ Radio Button Property 
 

 
 
RadioButton   กําหนดชื่อของ Radio Button ซึ่งใหสัมพันธกับโปรแกรม CGI 
Checked Value  กําหนดคาหรือขอความที่จะสงให Server เมื่อถูกเลือก 
Checked  กําหนดใหปุมถูกเลือกไวกอนเลยขณะที่ Load Form 
Unchecked  ใหปุมวางไวสําหรับเลือก 
 

        List / Menu ใชสําหรับทํา List ที่มีตัวเลือกหลายๆ อันแลวใหผูใชเลือกอันใดอันหนึ่ง 
รูปแบบ 
 
     

            แบบ Menu             แบบ List 
 

สวนประกอบของ List / Menu Property 
 
 
 
 
 

List / Menu กําหนดชื่อของ Menu หรือ Field 
Menu  การเลือกแบบ Menu เมื่อกดแลวจะมี Menu ออกมาใหเลือก สวนมากเลือกไดตัวเลือกเดียว 
List  การแสดงตัวเลือกทั้งหมดออกมาใหเลือก โดยกําหนดไดจะใหเลือกตัวใดตัวหนึ่ง หรือ มากกวา 1 ตัว 
Height  กําหนดจํานวนบรรทัดที่ตองการแสดงในแบบ List 
Selections ใชกับการเลือกแบบ List เทานั้น โดยสามารถกําหนดวาสามารถเลือกไดหลายตัว  

โดยการ  ในชอง Allow Multiple 
Initially Selected แสดงคาที่ถูกใสไวใน List Values 
List Values สําหรับใสตัวเลือกที่ตองการใน List / Menu 
 

การกําหนดตัวเลือกที่ตองการใน List / Menu 
- Click ที่ปุม List Values 
- พิมพขอความที่ตองการใหเปน List / Menu ในสวน Item Label และกดปุม Tab  
- พิมพคาที่ตองการใหสงไปที่ Server ซึ่งจะเปนตัวเลข หรือตัวอักษรก็ไดและกดปุม Tab 
- กําหนดตัวเลือกใหครบตามที่ตองการ และ OK 
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File Field สําหรับใหผูใชเลือก File ในเครื่อง Client แลว Upload File นั้นไปที่ Server ผานทาง Form สวนมากตองใช
กับโปรแกรมในสวนของ Server เชน CGI,ASP 

รูปแบบ  
 
 

สวนประกอบของ File Field Property 
 

 
 
 
FileField Name  กําหนดชื่อ Field 
Character Width  กําหนดความกวางของชอง 
Maximum Character กําหนดจํานวนตัวอักษร 
ปุม Browse  สําหรับเลือก File 
 
        Image Field     การนําเอารูปภาพมาใชแทนปุม ซึ่งสามารถกําหนดคาใหกับรูปไดวาใหทํางานอยางไร 
 

สวนประกอบของ Image Field Property 
 
 
 

ImageField  กําหนดชื่อ Field ถาใสเปนคําวา Submit จะทํางานเหมือนปุม Submit 
W และ H   แสดงความกวางและความสูงของรูปภาพ 
Source   สําหรับเลือก File ที่ตองการ 
Alternate  กําหนดขอความแสดงที่รูปในขณะ Load รูป 
Align   การจัดเรียงรูปกับขอความ 
Edit Image  เปดโปรแกรมแกไขรูปภาพ 
 

Hidden Field ใชในการเก็บขอมูลของ Form ที่ไมตองการใหผูใชกรอก เพื่อปองกันการสับสนของการรับขอมูล เปน 
Field ที่ผูออกแบบใสไวเพื่อการแยกแยะขอมูล 

รูปแบบ  
 

สวนประกอบของ Hidden Field Property 
 
 
 

HiddenField ตั้งชื่อ Hidden Field 
Value  กําหนดคาใหกับตัวแปร 
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       Jump Menu  การทํารายการหรือหัวขอใหเลือกได และเมื่อเลือกแลวจะ Link ไปยัง Home Page ที่ตองการ 
รูปแบบ 
 
 

แบบ Menu  แบบ List 
 

สวนประกอบของ Jump Menu Property 
 

  
 
 
 
 

การกําหนดรายละเอียดของ List ที่ตองการสราง 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Menu Items สวนแสดงรายชื่อ List ที่สราง 
Text  กําหนดรายชื่อของ List ที่ตองการ 
When Selected, Go To URL กําหนด Web Site ที่ตองการ Link ไป 
Open URLs In กําหนดลักษณะหนาตางของ Link ที่เปดใน Browser 
Menu Name กําหนดชื่อของ Jump Menu 
Insert Go Button After Menu  ใหแสดงปุมคําวา Go อยูขางๆ Jump Menu 
Select First Item After URL Change  กําหนดใหแถบสีฟา แสดงอยูที่ตัวเลือกรายการแรก 
 สําหรับการเพิ่ม List  
 สําหรับการลบ List 
  สําหรับการเปลี่ยนลําดับของ List 
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