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การทดลองที ่1 

Logic Gate พืน้ฐาน 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

2. เพื่อเรียนรู้การท างานของลอจิกเกทพื้นฐาน (AND, OR, NOT, NAND, NOR และ       
XNOR) ได ้

 3. สามารถดาวน์โหลดวงจรลงไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
1. ค าจ ากดัความของระดับลอจิกในวงจรดิจิตอล 

 ในการศึกษาวงจรดิจิตอลนั้นจะตอ้งท าความเขา้ใจกบัเร่ืองของระดบัสัญญาณท่ีใชใ้นวงจร
ก่อน โดยระดบัสัญญาณท่ีส าคญัในวงจรดิจิตอลไดแ้ก่ ระดบัลอจิกสูง (HIGH หรือบางคร้ังแทด้ว้ย 
1) และลอจิกต ่า (LOW หรือบางคร้ังแทนดว้ย 0) ซ่ึงระดบัลอจิกเหล่าน้ีใช้แทนช่วงของระดบั
แรงดนัไฟฟ้านัน่เอง 

 ระบบดิจิตอลมีการแบ่งอุปกรณ์ออกเป็น 2 ตระกูล ได้แก่ ทีทีแอล (TTL) และซีมอส 
(CMOS) ซ่ึงช่วงระดบัแรงดนัท่ีใชแ้ทนค่าลอจิกในวงจรดิจิตอลจะต่างกนั ส าหรับไอซีทีทีแอลจะ
ใชแ้หล่งจ่ายแรงดนัไม่เกิน 5 โวลต ์+/- 5% โดยระดบัแรงดนัท่ีมีค่าต ่ากวา่ 0.8 โวลต์จะใชแ้ทน
สถานะลอจิกต ่า และระดบัแรงดนัท่ีสูงกวา่ 2 โวลตข้ึ์นไปจะใชแ้ทนระดบัลอจิกสูง ส่วนไอซีซีมอส
จะเป็นไอซีท่ีมีช่วงการใช้แรงดนัไฟเล้ียงท่ียืดหยุน่ไดม้ากกวา่โดยสามารถใชไ้ดต้ั้งแต่ 3 โวลต ์ถึง 
18 โวลต์ ซ่ึงการก าหนดช่วงของระดบัลอจิกจะสัมพนัธ์กบัระดบัไฟเล้ียงท่ีจ่ายให้แก่ไอซี โดยท่ี
ระดบัแรงดนัตั้งแต่ 0 จนถึงประมาณ1/3 ของแรงดนัไฟเล้ียง จะใชแ้ทนระดบัลอจิกต ่า และ แรงดนั
ตั้งแต่ช่วงประมาณ 2/3 ของแรงดนัไฟเล้ียงจนถึงระดบัไฟเล้ียงจะใชแ้ทนระดบัลอจิกสูง แสดงดงั
รูปท่ี 1.1 
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รูปท่ี 1.1 ช่วงแรงดนัไฟฟ้าและระดบัลอจิก 

2. แอนด์เกท (AND Gate) 

 แอนด์เกทเป็นวงจรลอจิกเกทพื้นฐานท่ีใหส้ัญญาณเอาตพ์ุทเป็น HIGH เม่ือสัญญาณอินพุท
ทั้งหมดอยูใ่นสภาวะ HIGH และใหเ้อาตพ์ุทเป็น LOW เม่ือสัญญาณขาใดขาหน่ึงเป็น LOW ซ่ึง
สามารถเขียนเป็นสมการบูลีนไดด้งัน้ี 

Y = A_AND_B หรือบางคร้ังสามารถเขียนไดด้งัน้ี Y = A • B 

 สมการดงักล่าวอ่านวา่ Y เท่ากบั A แอนด์ B ส าหรับสัญลกัษณ์จุดในสมการเราอาจเขียน
หรือไม่เขียนก็ไดซ่ึ้งสมการดงักล่าวจะเป็น 

Y = A B 

 การท างานของแอนด์เกทสามารถเปรียบเทียบเป็นวงจรเสมือนท่ีประกอบข้ึนจากสวิตช์ท่ี
ต่ออนุกรมกนัดงัรูปท่ี 2 นัน่คือหลอดไฟจะติดไดใ้นกรณีท่ีสวิทช์ A และ B ปิด (ON) ทั้งคู่ และ
หลอดไฟจะดบัลงในกรณีท่ีสวิตช์ตวัใดตวัหน่ึงเปิด (OFF) ซ่ึงสามารถเขียนเป็นตารางความจริง 
(Truth Table) ไดด้งัตารางท่ี 1.1 ในทางปฏิบติัแอนด์เกทท่ีมีใชง้านโดยทัว่ไปจะอยูใ่นรูปของไอซี  
เช่น ไอซีเบอร์ 7408 

 

ลอจิกสูง 

ลอจิกต ่า 

ลอจิกสูง 

ลอจิกต ่า 
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รูปท่ี 1.2 วงจรเสมือนแอนดเ์กท รูปท่ี 1.3 สัญลกัษณ์ของแอนดเ์กท 

 

 

 
 
 
 
 
 

 
3. ออร์เกท (OR Gate) 

ออร์เกทเป็นวงจรลอจิกพื้นฐานท่ีให้สัญญาณเอาตพ์ุทเป็น HIGH เม่ือสัญญาณอินพุทขาใด
ขาหน่ึงอยู่ในสภาวะ HIGH และให้สัญญาณเอาต์พุทเป็น LOW เม่ือสัญญาณอินพุททุกขาเป็น 
LOW ซ่ึงสามารถเขียนเป็นสมการบูลีนไดด้งัน้ี 

Y = A OR B หรือบางคร้ังสามารถเขียนไดด้งัน้ี Y = A + B 

 สมการดงักล่าวอ่านวา่ Y เท่ากบั A แอนด์ B การท างานของออร์เกทสามารถเปรียบเทียบ
เป็นวงจรเสมือนท่ีประกอบข้ึนจากสวิตช์ท่ีต่อขนานกนัดงัรูปท่ี 1.5 นัน่คือหลอดไฟจะติดไดใ้น
กรณีท่ีสวทิช์ A และ B ตวัใดตวัหน่ึงปิด (ON) และหลอดไฟจะดบัลงในกรณีท่ีสวิตช์ทั้งสองตวัเปิด 
(OFF) ซ่ึงสามารถเขียนเป็นตารางความจริง (Truth Table) ไดด้งัตารางท่ี 1.2 ในทางปฏิบติัออร์เกท
ท่ีมีใชง้านโดยทัว่ไปจะอยูใ่นรูปของไอซี  เช่น ไอซีเบอร์ 7432 

อนิพุท เอาต์พุท 

A B Y 

0 0 0 

0 1 0 

1 0 0 

1 1 1 

ตารางท่ี 1.1 ตารางความจริงของแอนดเ์กท          รูปท่ี 1.4 โครงสร้างของไอซีเบอร์ 7408 

A

B
Y = A•B
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รูปท่ี 1.5 วงจรสเหมือนออร์เกท รูปท่ี 1.6 สัญลกัษณ์ของออร์เกท 

 

 

 

 

 

 

 
4. นอตเกท (NOT Gate) 

 นอตเกทเป็นวงจรลอจิกพื้นฐานท่ีให้สัญญาณเอาต์พุทตรงกนัขา้มกบัสัญญาณอินพุท ซ่ึง
สามารถเขียนเป็นสมการบูลีนไดด้งัน้ี 

         

  

 

การท างานของออร์เกทสามารถเปรียบเทียบเป็นวงจรเสมือนท่ีประกอบข้ึนจากสวิตช์ท่ีต่อ
ขนานกนัดงัรูปท่ี 1.8 นัน่คือหลอดไฟจะติดไดใ้นกรณีท่ีสวทิช์ A เปิด (OFF) และหลอดไฟจะดบัลง
ในกรณีท่ีสวติช์ A เปิด (ON) ซ่ึงสามารถเขียนเป็นตารางความจริง (Truth Table) ไดด้งัตารางท่ี 1.3

ในทางปฏิบติันอตเกทท่ีมีใชง้านโดยทัว่ไปจะอยูใ่นรูปของไอซี  เช่น ไอซีเบอร์ 7404 

 
รูปท่ี 1.8 วงจรสเหมือนนอตเกท รูปท่ี 1.9 สัญลกัษณ์ของนอตเกท 

อนิพุท เอาต์พุท 

A B Y 

0 0 0 

0 1 1 

1 0 1 

1 1 1 

ตารางท่ี 1.2  ตารางความจริงของออร์เกท                รูปท่ี 1.7 โครงสร้างของไอซีเบอร์ 7432 

Y = A   หรือบางคร้ังสามารถเขียนไดด้งัน้ี Y =A’ 

A

B

Y = A+B

Y = A
_
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5. แนนด์เกท (NAND Gate) 
 แนนด์เกทเป็นเกทพื้นฐานท่ีเกิดจากการน าแอนด์และนอตเกทมาผสมกนั โดยการน านอต
เกทต่อเขา้ทางเอาตพ์ุทของแอนดเ์กท ซ่ึงสามารถเขียนเป็นสมการบูลีนไดด้งัน้ี 

 
 การท างานของออร์เกทสามารถเปรียบเทียบเป็นวงจรเสมือนท่ีประกอบข้ึนจากสวิตช์ท่ีต่อ
ขอนุกรมกันดังรูปท่ี 1.11 นั่นคือหลอดไฟจะติดได้ในกรณีท่ีสวิทช์ตวัใดตวัหน่ึง หรือทั้งคู่เปิด 
(OFF) และหลอดไฟจะดบัลงในกรณีท่ีสวติช์ทั้งสองตวัเปิด (ON) ซ่ึงสามารถเขียนเป็นตารางความ
จริง (Truth Table) ไดด้งัตารางท่ี 1.4 ในทางปฏิบติันอตเกทท่ีมีใชง้านโดยทัว่ไปจะอยูใ่นรูปของ
ไอซี  เช่น ไอซีเบอร์ 7400 

      

 
 

 

 

 

 

 

อนิพุท เอาท์พุท 

A Y 

0 1 

1 0 

ตารางท่ี 1.3 ตารางความจริงของนอตเกท       รูปท่ี 1.10 โครงสร้างของไอซีเบอร์ 7404 

Y = A • B 

รูปท่ี 1.11 วงจรเสมือนแนนด์เกท         รูปท่ี 1.12 สัญลกัษณ์ของแนนด์เกท 

อนิพุท เอาต์พุท 
A B Y 
0 0 1 
0 1 1 
 1 0 1 
1 1 0 

ตารางท่ี 1.4 ตารางความจริงของแนนดเ์กท       รูปท่ี 1.13 โครงสร้างของไอซีเบอร์ 7400 

A

B

Y = A•B
___
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6. นอร์เกท (NOR Gate) 

 นอร์เกทเป็นเกทพื้นฐานท่ีเกิดจากการน าออร์เกทและนอตเกทมาผสมกนั โดยการน านอต
เกทต่อเขา้ทางเอาตพ์ุทของออร์เกท ซ่ึงสามารถเขียนเป็นสมการบูลีนไดด้งัน้ี 

 
Y = A + B 

  
การท างานของนอร์เกทสามารถเปรียบเทียบเป็นวงจรเป็นวงจรเสมือนท่ีประกอบข้ึนจาก

สวิตช์ท่ีต่อขอนุกรมกนัดงัรูปท่ี 1.14 นั่นคือหลอดไฟจะติดได้ในกรณีท่ีสวิทช์ทุกตวัเปิด (OFF) 

และหลอดไฟจะดบัลงในกรณีท่ีสวิตช์ตวัใดตวัหน่ึงปิด (ON) ซ่ึงสามารถเขียนเป็นตารางความจริง 
(Truth Table) ไดด้งัตารางท่ี 1.5 ในทางปฏิบติันอตเกทท่ีมีใชง้านโดยทัว่ไปจะอยูใ่นรูปของไอซี  
เช่น ไอซีเบอร์ 7402 

 

 

 
 
 
 
 
 
 
 

 
 
 

       รูปท่ี 1.14 วงจรเสมือนนอร์เกท             รูปท่ี 1.15 สัญลกัษณ์ของนอร์เกท 

อนิพุท เอาต์พุท 
A B Y 
0 0 0 
0 1 1 
1 0 1 
1 1 1 

      ตารางท่ี 1.5 ตารางความจริงของนอร์เกท    รูปท่ี 1.16 โครงสร้างของไอซีเบอร์ 7402 

A

B

Y = A+B
___
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7. เอก็ซ์คลูซีฟออร์เกท (Exclusive – OR Gate) 

 เอก็ซ์คลูซีฟออร์เกทเป็นเกทท่ีให้เอาตพ์ุทเป็น 1 เม่ืออินพุทแตกต่างกนัและจะใหเ้อาตพ์ุท
เป็น 0 ในกรณีท่ีอินพุทมีค่าเหมือนกนั ซ่ึงสามารถเขียนสมการบูลีนไดด้งัน้ี 

Y = A  B 

 ส าหรับลกัษณ์และและตารางความจริงแสดงดงัรูปท่ี 1.17 และตารางท่ี 1.6 ตามล าดบั ซ่ึง
ไอซีท าหนา้ท่ีเป็นเอก็คลูซีฟออร์เกทท่ีมีอยูต่ามทอ้งตลาดไดแ้ก่เบอร์ 7486 

 

 

A

B

Y = A  +  B

 
 

 
รูปท่ี 1.18 ไอซีเอก็คลูซีฟออร์เกทเบอร์ 7486 

8. เอก็ซ์คลูซีฟนอร์เกท (Exclusive – NOR Gate) 

 เอ็กซ์คลูซีฟนอร์เกทเป็นเกทท่ีเกิดจากการน านอตเกทไปต่อทางเอาต์พุทของเอ็กซ์คลู
ซีฟออร์เกทเพื่อกลบัผลเอาตพ์ุทให้มีค่าตรงกนัขา้มกบั เอ็กซ์คลูซีฟนอร์เกท ดงันั้นเอาตพ์ุทของมนั
จะมีค่าเป็น 0 เม่ืออินพุทแตกต่างกนั และจะให้เอาตพ์ุทเป็น 1 ในกรณีท่ีอินพุทมีค่าเหมือนกนั ซ่ึง
สามารถเขียนสมการบูลีนไดด้งัน้ี 

  
Y = A  B 

อนิพุท เอาต์พุท 
A B Y 
0 0 0 
0 1 1 
1 0 1 
1 1 0 

รูปท่ี 1.17 สัญลกัษณ์ของเอก็ซ์คลูซีฟออร์เกท ตารางท่ี 1.6 ตารางความจริงของเอก็ซ์คลูซีฟออร์เกท 
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  ส าหรับลกัษณ์และและตารางความจริงแสดงดงัรูปท่ี 1.19 และตารางท่ี 1.7 ตามล าดบั ซ่ึง
ไอซีท าหนา้ท่ีเป็นเอก็คลูซีฟนอร์เกทท่ีมีอยูต่ามทอ้งตลาดไดแ้ก่เบอร์ 74266 

 

 

A

B

Y = A  +  B
_____

 
 

 

รูปท่ี 1.20 ไอซีเอก็คลูซีฟนอร์เกทเบอร์ 7486 

ขั้นตอนการทดลอง ตอนที ่1 แอนด์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition 

2. สร้างโปรเจคโดยใชเ้มนู File -> New Project Wizard ดงัรูปท่ี 1.21 

3. จากนั้นหนา้ต่าง New Project Wizard : Introduction จะปรากฏข้ึน ใหค้ลิกท่ี Next ดงัรูปท่ี 1.22 

อนิพุท เอาต์พุท 

A B Y 

0 0 1 

0 1 0 

1 0 0 

1 1 1 

รูปท่ี 1.19 สัญลกัษณ์ของเอก็ซ์คลูซีฟนอร์เกท  ตารางท่ี 1.7 ตารางความจริงของเอก็ซ์คลูซีฟนอร์เกท 
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รูปท่ี 1.21 การเรียกเมนูสร้างโปรเจคใหม่ 

 
รูปท่ี 1.22 การสร้างโปรเจคใหม ่
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4. จากนั้นหนา้ต่าง New Project Wizard : Directory Name Top-Level Entity จะปรากฏข้ึน ให้ใส่
ช่ือโปรเจคในช่ือ lab_1a ลงในช่อง What is the name of this project เสร็จแลว้คลิกท่ีปุ่ม Next 

แสดงดงัรูปท่ี 1.23 

 
รูปท่ี 1.23 การสร้างโปรเจคใหม ่

5. จากนั้นหนา้ต่าง New Project Wizard : Add Files จะปรากฏข้ึน คลิก Next ดงัรูปท่ี 24 

 

รูปท่ี 1.24 การสร้างโปรเจคใหม ่
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6. จากนั้นหนา้ต่าง New Project Wizard : Family & Device Settings จะปรากฏข้ึน ในช่อง 
Device family ให้เลือกรุ่นของไอซีเป็น Cyclone III และในช่อง Available devices ให้เลือกเบอร์
ของไอซีเป็น EP3C10E144C8 เสร็จแลว้คลิกเลือกท่ีปุ่ม Finish ดงัรูปท่ี 1.25 

 

รูปท่ี 1.25 การสร้างโปรเจคใหม ่

7. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New ดงัรูปท่ี 1.26 

 
รูปท่ี 1.26 การสร้างไฟลใ์หม่ 
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8. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK ดงัรูปท่ี 1.27 

 

รูปท่ี 1.27 เลือกสร้างไฟลก์ราฟิกส าหรับวาดวงจร 

9. ท าการวาดอุปกรณ์ลงบน Graphic Editor โดยเลือกท่ี Editor -> Insert Symbol เพื่อเรียกหนา้ต่าง 

Symbol ข้ึนมาดงัรูปท่ี 1.28 

 

รูปท่ี 1.28 เรียกหนา้ต่าง Symbol 
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10. จากนั้นจะมีหน้าต่าง Symbol ปรากฏข้ึนมา ให้คลิกเลือกท่ี C:/altera/81/quartus/libraries -> 

primitives  -> logic -> and2 หรือใหค้น้หาโดยพิมพค์  าวา่ and2 ในช่อง Name เสร็จแลว้คลิกท่ี OK 

ดงัรูปท่ี 1.29 

 

รูปท่ี 1.29 การสร้างแอนดเ์กท 2 อินพุท 

11. เรียกหนา้ต่าง Symbol ข้ึนมาอีกคร้ังเพื่อสร้างพอร์ต input และ output ดงัรูปท่ี 1.30 และ ดงัรูป
ท่ี 1.31 ตามล าดบั เสร็จแลว้คลิกท่ี OK  

                    
รูปท่ี 1.30 การสร้างอินพุท                                      รูปท่ี 31 การสร้างเอาตพ์ุท 

12. จากนั้นท าการวางอุปกรณ์ ดงัรูปท่ี 1.32 



42 

 

รูปท่ี 1.32 การจดัวางอุปกรณ์ 

13. ท าการเปล่ียนช่ือพอร์ตอินพุตและเอาทพ์ุตจาก PIN_NAME ให้เป็นดงัรูปท่ี 1.33 โดยดบัเบิล
คลิกท่ีตวัหนงัสือ PIN_NAME โปรแกรมจะข้ึนแถบสีด าตรงช่ือพอร์ต ซ่ึงขณะน้ีเราสามารถพิมพ์
ช่ือพอร์ตทบัลงไปไดท้นัที 

 

รูปท่ี 1.33 การเปล่ียนช่ือพอร์ตอินพุต และเอาทพ์ุต 

14. เสร็จแลว้ท าการลากเส้นเช่ือมต่อขาของอุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูปท่ี 1.34 โดยเล่ือนเมาส์
มาท่ีบริเวณขั้วของอุปกรณ์ ขณะน้ีจะสังเกตไดว้่าเคอร์เซอร์เปล่ียนจากลูกศรกลายเป็นเส้นครอส
แฮร์ (Cross Hair : เคร่ืองหมายบวกขนาดใหญ่) ให้คลิกแลว้ลากเพื่อเช่ือมต่อกบัขั้วอุปกรณ์ โดยใน
การลากเส้น ใหล้ากให้พอดีกบัขั้วอุปกรณ์ห้ามลากเกินเขา้ไปในตวัอุปกรณ์ ซ่ึงอาจท าให้โปรแกรม
ตีความไดว้า่จุดนั้นไม่มีการเช่ือมต่อ 

 

รูปท่ี 1.34 การลากเส้นเช่ือมต่ออุปกรณ์เขา้ดว้ยกนั 

15. ขณะน้ีวงจรไดถู้กวาดเสร็จเรียบร้อยแลว้ ใหท้  าการบนัทึกโดยใชเ้มนู File -> Save  

AND2

inst

VCC
pin_name INPUT

VCC
pin_name1 INPUT

pin_name2OUTPUT

VCC
A INPUT

VCC
B INPUT

A_AND_BOUTPUT

AND2

inst

VCC
A INPUT

VCC
B INPUT

A_AND_BOUTPUT

AND2

inst
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รูปท่ี 1.35 การบนัทึกไฟล ์

16. จากนั้นหนา้ต่าง Save As จะปรากฏข้ึน ใหค้ลิกท่ี Save ดงัรูปท่ี 1.36 

 
รูปท่ี 1.36 การบนัทึกไฟล ์
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การคอมไพล์วงจร และการจ าลองการท างาน 

17. ต่อไปเราจะท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้เร่ิมจากคลิกเมนู Processing -> Start 

Compilation ดงัรูปท่ี 1.37 

 

รูปท่ี 1.37 เมนูเรียกหนา้ต่างคอมไพลเ์ลอร์ 

18. เม่ือโปรแกรมท าการคอมไพลเ์สร็จ จากนั้นหนา้ต่าง Quartus II 8.1 Web Edition จะปรากฏข้ึน 

ใหค้ลิกท่ี OK 

 
รูปท่ี 1.38 หนา้ต่างแสดงการคอมไพลเ์ลอร์เสร็จแลว้ 

19. ต่อไปจะท าการก าหนดรูปคล่ืนสัญญาณให้กบัวงจรเพื่อจ าลองการท างาน โดยการเรียกท่ีเมนู 
File -> New จะปรากฏหนา้ต่าง New ข้ึนมา ให้เลือกท่ี Vector Waveform File จากนั้นคลิกท่ี OK 

ดงัรูปท่ี 1.39 



45 

 

รูปท่ี 1.39 สร้างไฟล ์Vector Waveform ส าหรับบนัทึกผลการจ าลองการท างาน 

20. จากนั้นหนา้ต่าง Vector Waveform File จะปรากฏข้ึนมา ให้บนัทึกไฟล์ในช่ือ lab_1a.scf โดย
ใชเ้มนู File -> Save ดงัรูปท่ี 1.40 

 

รูปท่ี 1.40 การบนัทึกไฟล ์
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21. จากนั้นหนา้ต่าง Save As จะปรากฏข้ึน ใหค้ลิกท่ี Save ดงัรูปท่ี 1.41 

 

รูปท่ี 1.41 การบนัทึกไฟล ์

22. ท าการเพิ่ม Node เพื่อวเิคราะห์สัญญาณโดยคลิกขวาบน Vector Waveform Editor จากนั้นจะมี
เมนู Popup ข้ึนมา ให ้เลือกท่ี Insert -> Insert Node Bus… 

 

รูปท่ี 1.42 การเพิ่ม Node เพื่อวเิคราะห์สัญญาณ 

23. คลิกท่ี Node Finder… เพื่อคน้หาโหนด 
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รูปท่ี 1.43 การเพิ่ม Node เพื่อวเิคราะห์สัญญาณ 

24. คลิกท่ีปุ่ม List เพื่อแสดงรายการโหนดท่ีสามารถล าลองการท างานได้ แลว้เลือกท่ีปุ่ม  เสร็จ
แลว้คลิกท่ีปุ่ม OK 

 

รูปท่ี 44 การเพิ่ม Node เพื่อวิเคราะห์สัญญาณ 

25. จากรูปท่ี 1.44 จะเห็นไดว้า่การจดัเรียงล าดบัสัญญาณท่ีโปรแกรมสร้างมาให้อาจท าให้สับสนใน
การพิจารณาซ่ึงเราสามารถเปล่ียนล าดับของสัญญาณได้โดยคลิกท่ีรูปพอร์ตแล้วลากไปวางยงั
ต าแหน่งท่ีตอ้งการดงัรูปท่ี 1.45 

 

รูปท่ี 1.45 ล าดบัสัญญาณใน Waveform Editor 
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26. เพื่อใหง่้ายแก่การก าหนดค่าสัญญาณท่ีช่วงเวลาต่าง ๆ ให้ท าการเปิด Option Snap to Grid ก่อน
โดยเลือกจาก เมนู View -> Snap to Grid แต่ถา้มีการเปิดการใชง้านอยูแ่ลว้ให้ขา้มขั้นตอนน้ีไปได้
เลย 

 

รูปท่ี 1.46 การแสดงฟังกช์นั Snap to Grid 

27 ก าหนดขนาดของ Grid โดยเลือกจากเมนู Edit -> Grid Size…  

 

รูปท่ี 1.47 ก าหนดขนาดของ Grid 

28. หลงัจากนั้นจะมีหนา้ต่าง Grid Size ข้ึนมา ให้ป้อนค่า 100.0ns แลว้คลิก OK จะสังเกตไดว้า่ใน
ขณะท่ีหนา้ต่าง Vector Waveform Editor จะมีเส้นประแนวตั้งปรากฏข้ึนทุก ๆ 100ns 
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รูปท่ี 1.48 ก าหนดขนาดของ Grid เท่ากบั 100 ns 

29. ก าหนดสัญญาณอินพุท A และ B โดยเร่ิมจากการก าหนดค่าสัญญาณลอจิกให้แก่สัญญาณลอจิก
ให้แก่สัญญาณ A ในช่วงเวลา 100 us จนถึง 200 us ให้เป็น “1” โดยคลิกท่ีค่าเวลา 100 us บน
สัญญาณ A แลว้ลากแถบสีทึบไปจนถึงค่าเวลา 200 us จากนั้นคลิกท่ีปุ่ม   บนแถบเคร่ืองมือบน
ปุ่มรูปพลัส์ “1”  

 

รูปท่ี 1.49 คลิกเลือกช่วงรูปคล่ืนท่ีตอ้งการก าหนดค่าระดบัสัญญาณลอจิก 

30. ก าหนดค่าสัญญาณอินพุทในช่วงเวลาท่ีเหลือดงัน้ี  
 สัญญาณ A เป็น “1” ในช่วงเวลา 100us-200us และ 300us-400us  

 สัญญาณ B เป็น “1” ในช่วงเวลา 200us-400us 

 

รูปท่ี 1.50 รูปคล่ืนอินพุท A และ B ส าหรับจ าลองการท างาน 
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31. ก าหนดช่วงเวลาส้ินสุดของการจ าลองการท างาน (End Time) โดยใชเ้มนู File -> End Time  

 

รูปท่ี 1.51 ก าหนดเวลาส้ินสุดการจ าลองการท างาน 

32. จากนั้นก าหนดใหช่้วงเวลาส้ินสุดการจ าลองการท างานมีค่าเท่ากบั 1 us เสร็จแลว้คลิกท่ีปุ่ม OK 

 

รูปท่ี 1.52 ก าหนดจุดส้ินสุดการจ าลองการท างานท่ี 1us 

33. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
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รูปท่ี 1.53 การเรียกหนา้ต่าง Simulator จากเมนู 

34. จากนั้นคลิกท่ีปุ่ม OK ดงัรูปท่ี เสร็จแลว้ดูผลการจ าลองการท างานดงัรูปท่ี 1.54 

 

รูปท่ี 1.54 หนา้ต่างแจง้ผลการจ าลองการท างาน 

Name:                                     100.0ns                200.0ns                300.0ns                 

400.0ns   

    A  

  

    B  

  

   
A_AND_B 

 

  

รูปท่ี 1.55 ผลการจ าลองการท างาน 
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35. วเิคราะห์รูปคล่ืนท่ีค่าเวลาต่าง ๆ แลว้ป้อนค่าลอจิกลงในตาราง 

 
A B A_AND_B 
0 0  
0 1  
1 0  
1 1  

ตารางท่ี 1.8 ตารางความจริงของแอนดเ์กท 2 อินพุท 

36. จากขั้นตอนการคอมไพล์ท่ีผ่านมา นอกจากคอมไพล์เลอร์จะค านวณค่าความหน่วงเวลาเพื่อ
จ าลองการท างานแลว้ มนัยงัสร้างไฟลส์ าหรับโปรแกรมลงไอซี FPGA ใหเ้ราอีกดว้ย 

การเปลีย่นต าแหน่งของขา I/O และการโปรแกรมลงไอซี 
37. หลงัจากท่ีเราท าการคอมไพล์วงจรแลว้ โปรแกรม Quartus II 8.1 Web Edition จะท าการ
ก าหนดขา I/O ต่าง ๆ ในวงจรเองโดยอตัโนมติั ซ่ึงสามารถดูไดจ้ากหนา้ต่าง Pin Planner โดยใช้
เมนู Assignments -> Pins 

 

รูปท่ี 1.56 การเรียกหนา้ต่าง Pin Planner 
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38. จากนั้นจะมีหนา้ต่าง Pin Planner ปรากฏข้ึนมา แสดงดงัรูปท่ี 1.57 

 

รูปท่ี 1.57 หนา้ต่าง Pin Planner 

34. จากนั้นให้ท าการเปล่ียนค่าอินพุท และเอาตพ์ุทในช่อง Location และช่อง I/O Standard ดงั
ตารางท่ี 1.9 

I/O Bank Location I/O Standard 
A 74 3.3V LVCMOS 
B 76 3.3V LVCMOS 

A_AND_B 1 3.3V LVCMOS 

ตารางท่ี 1.9 การตั้งค่าไอซีเพื่อใชง้านจริง 

35. เม่ือเปล่ียนต าแหน่งขา เรียบร้อยแลว้ใหค้อมไพลใ์หม่อีกคร้ัง 

36. ต่อวงจรในชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA ดงัรูปท่ี 1.58 
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รูปท่ี 1.58 การต่อวงจรบนชุดทดลอง 

37. เช่ือมต่อสาย USB Blaster เขา้ท่ีพอร์ต USB ของคอมพิวเตอร์ และปลายอีกดา้นหน่ึงเช่ือมต่อ
เขา้กบัช็อกเกท JTAG ท่ีอยูบ่นชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA ดงัรูปท่ี 1.59 

 

รูปท่ี 1.59 ต่อสาย USB Blaster  เขา้กบัชุดทดลอง 
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38. จากนั้นเลือกท่ีเมนู Tools -> Programmer จะปรากฏหนา้ต่าง Programmer ข้ึนมาดงัรูปท่ี 1.60 

ให้ท าการเลือกท่ีปุ่ม Hardware Setup จะมีหนา้ต่าง Hardware Setup ในช่อง Currently Selected 

Hardware ใหเ้ลือกท่ี USB Blaster [USB-0] หลงัจากนัน่คลิกเลือกท่ีปุ่ม Close 

 

 

รูปท่ี 1.60 การเลือกสายดาวน์โหลดโปรแกรม 

39. หลงัจากเลือกสายดาวน์โหลดแลว้ ใหค้ลิก Enable ท่ีช่อง Program/Configure ดงัรูปท่ี 1.61  

 

รูปท่ี 1.61 การโปรแกรมลงในชุดทดลอง 

40. หลงัจากนั้นเลือกท่ีปุ่ม Start เพื่อโปรแกรมขอ้มูลลงชุดทดลอง  
41. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED D0 

จากนั้นบนัทกัผลลงในตาราง  
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A  

(SW1) 

B  

(SW0) 

A_AND_B  

(LED DO) 

LOW LOW  

LOW HIGH  

HIGH LOW  

HIGH HIGH  

ตารางท่ี 10 ตารางความจริงของแอนดเ์กท 2 อินพุท 

ขั้นตอนการทดลอง ตอนที ่2 ออร์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1b โดยใชเ้มนู File -> New Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิกท่ี 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ or2, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.62 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_1b.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

 

 

 

VCC
A INPUT

VCC
B INPUT

A_OR_BOUTPUT

OR2

inst
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Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  
  

    B  
  

    A_OR_B  

  

รูปท่ี 1.63 ผลการจ าลองการท างานของวงจร 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 67 
B 74 

A_OR_B 1 

ตารางท่ี 1.11 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 1.75 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 1.75 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึก
ผลลงในตาราง 

A  
(SW1) 

B 
(SW0) 

A_OR_B  
(LED DO) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 1.12 ตารางความจริงของออร์เกท 2 อินพุท 

ขั้นตอนการทดลอง ตอนที ่3 นอตเกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1c โดยใชเ้มนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 
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3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ not, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.76 วงจรส าหรับการทดลองตอนท่ี 3 

 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1c.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_1c.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

      A  
  

     A_NOT  

  

รูปท่ี 1.77 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 

A_NOT 1 

ตารางท่ี 1.13 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 1.78 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

VCC
A INPUT A_NOTOUTPUT

NOT

inst
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รูปท่ี 1.78 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึกผลลงใน
ตาราง 

 

 

ตารางท่ี 1.14 ตารางความจริงของนอตเกท 

ขั้นตอนการทดลอง ตอนที ่4 แนนด์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1d โดยใชเ้มนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

A 
(SW0) 

A_NOT  
(LED D0)  

LOW  
HIGH  
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4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nand2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.79 วงจรส าหรับการทดลองตอนท่ี 4 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1d.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_1d.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  
  

    B  
  

    A_NAND_B  

  

รูปท่ี 1.80 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA 

A 76 
B 74 

A_NAND_B 1 

ตารางท่ี 1.15 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

VCC
A INPUT

VCC
B INPUT

A_NAND_BOUTPUT

NAND2

inst
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12. ต่อวงจรตามรูปท่ี 1.81 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 1.81 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึก
ผลลงในตาราง 

A  
(SW1) 

B  
(SW0) 

A_NAND_B  
(LED D0) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 1.16 ตารางความจริงของแนนดเ์กท 2 อินพุต 
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ขั้นตอนการทดลอง ตอนที ่5 นอร์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1e โดยใชเ้มนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nor2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.82 วงจรส าหรับการทดลองตอนท่ี 5 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1e.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_1e.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

 

รูปท่ี 1.83 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

VCC
A INPUT

VCC
B INPUT

A_NOR_BOUTPUT

NOR2

inst

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  
  

    B  
  

    A_NOR_B  
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ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 
B 74 

A_NOR_B 1 

ตารางท่ี 1.17 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 1.84 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 1.84 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวิตช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED จากนั้นบนัทึกผล
ลงในตาราง 
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A  
(SW1) 

B  
(SW0) 

A_NOR _B  
(LED D0) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 1.18 ตารางความจริงของนอร์เกท 2 อินพุต 
 

ขั้นตอนการทดลอง ตอนที ่6 เอก็ซ์คลูซีฟออร์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1f โดยใชเ้มนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xor, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.85 วงจรส าหรับการทดลองตอนท่ี 6 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1f.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_1f.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

 

 

 

VCC
A INPUT

VCC
B INPUT

A_XOR_BOUTPUT

XOR

inst
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Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  

  

    B  

  

    A_XOR_B  

  

รูปท่ี 1.86 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 
B 74 

A_XOR_B 1 

ตารางท่ี 1.19 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 1.87 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 1.87 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED จากนั้นบนัทึกผล
ลงในตาราง 

A  
(SW1) 

B  
(SW0) 

 A_XOR_B 
(LED D0) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 1.20 ตารางความจริงของเอก็ซ์คลูซีฟออร์เกท 2 อินพุต 

ขั้นตอนการทดลอง ตอนที ่7 เอก็ซ์คลูซีฟนอร์เกท 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าตามขั้นตอนเดิม สร้างโปรเจคใหม่ในช่ือ 
lab_1g โดยใชเ้มนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 
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3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xnor, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 1.88 วงจรส าหรับการทดลองตอนท่ี 7 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_1g.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_1g.scf เพื่อจ าลองการท างานของวงจร แลว้บนัทึกผล
การจ าลองการท างาน 

 
รูปท่ี 1.89 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 

 

VCC
A INPUT

VCC
B INPUT

A_XNOR_BOUTPUT

XNOR

inst

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  
  

    B  
  

    A_XNOR_B  
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ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 
B 74 

A_XNOR_B 1 

ตารางท่ี 1.21 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 1.90 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 1.90 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED จากนั้นบนัทึกผล
ลงในตาราง 
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A  
(SW1) 

B  
(SW0) 

A_XNOR_B 
(LED D0) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 1.22 ตารางความจริงของเอก็ซ์คลูซีฟนอร์เกท 2 อินพุต 

สรุปผลการทดลอง 
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การทดลองที ่2 

ลอจกิเกททีม่ีเอาต์พุท 3 สถานะ(Tristate Logic)  

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของลอจิกเกทแบบสามสถานะ 

3. เรียนรู้การวาดสายเช่ือมต่อแบบบสั รวมถึงการแยก และการรวมสัญญาณบนสาย

เช่ือมต่อแบบบสัได ้

 4. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากลอจิกเกทท่ีมีเอาตพ์ุทแบบ 3 สถานะได ้

 5. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 ลอจิกเกทท่ีเราไดเ้รียนรู้มาในการทดลองท่ี 1 เป็นลอจิกเกทแบบพื้นฐานซ่ึงสามารถให้ค่า
เอาตพ์ุทในทางลอจิกเป็นระดบัสูง และต ่าเท่านั้นแต่ยงัมีลอจิกเกทอีกประเภทหน่ึงซ่ึงให้เอาตพ์ุทได้
มากกว่า 2 สถานะ โดยลอจิกเกทประเภทน้ีเราเรียกวา่ ลอจิกเกทท่ีมีเอาต์พุท 3 สถานะ (Tristate 

Logic) แต่ส่วนมากเราจะนิยมเรียกทบัศพัทว์า่ ไทรสเตทลอจิกเกท 
 ไทรสเตทลอจิกเกท สามารถให้เอาตพ์ุททั้งหมด 3 สถานะ ไดแ้ก่ ลอจิกสูง ลอจิกต ่า และ
สถานะอิมพีแดนซ์สูง (High Impedance) ซ่ึงสถานะอิมพีแดนซ์สูงเป็นสถานะท่ีเสมือนลอจิกเกท
ตวันั้นถูกตดัขาดออกจากวงจร ส าหรับลอจิกเกทประเภทน้ีจะมีขาอินพุทเพิ่มมาอีก 1 ขา นัน่คือขา 
Enable ซ่ึงเป็นขาท่ีใช้ควบคุมให้เอาต์พุทของลอจิกเกทมีค่าเป็นลอจิก (สูง-ต ่า) หรือสภาวะ
อิมพีแดนซ์สูง ดงัตวัอยา่งตารางความจริงของนอตเกทแบบไทรสเตท 
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 รูปท่ี 2.1 นอตเกทแบบไทรสเตท           ตารางท่ี 2.1 ตารางความจริงของนอตเกทแบบไทรสเตท 

 ไทรสเตทลอจิกถูกน ามาใชป้ระโยชน์อยา่งมากในบสัส่ือสารขอ้มูลของระบบคอมพิวเตอร์ 
ซ่ึงมรการแชร์บสัขอ้มูลร่วมกนัระหวา่งอุปกรณ์ต่าง ๆ ภายในระบบ โดยท่ีในขณะอุปกรณ์ตวัไหน
ตอ้งการส่ือสารขอ้มูลตวัควบคุมระบบจะส่งสัญญาณ Enable เพื่อเปิดให้อุปกรณ์ตวันั้นรับ – ส่ง
ขอ้มูลได ้ส่วนอุปกรณ์ตวัอ่ืน ๆ จะไม่ไดรั้บสัญญาณ Enable ท าให้มีสภาพเหมือนอุปกรณ์ตวัอ่ืน ๆ 
ไม่ไดต่้ออยูบ่นระบบบสันั้น ๆ 

ขั้นตอนการทดลอง ตอนที ่1 การท างานของลอจิกเกททีม่ี 3 สถานะ 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_2a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ not, tri, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 2.2 วงจรส าหรับทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_2a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_2a.scf เพื่อจ าลองการท างานของวงจร แลว้สังเกตผล
การจ าลองการท างานจะเห็นไดว้า่ช่วงท่ีสัญญาณจากขา Enable มีค่าเป็น 0 ค่าสัญญาณทางเอาตพ์ุท

VCC
ENABLE INPUT

VCC
A INPUT A_NOTOUTPUT

NOT

inst

TRI

inst1

อนิพุท เอาต์พุท 

EN A Y 

0 0 Hi-Z 
0 1 Hi-Z 
1 0 1 
1 1 0 

A
Y = A

_

Enable
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จะเป็นค่าอิมพีแดนซ์สูง โดยแสดงด้วยเส้นทึบหนาใน Waveform Editor และในช่วงสัญญาณ 
Enable เป็น 1 ค่าเอาตพ์ุทจะมีค่าตามการท างานปกติของนอตเกท 

 

รูปท่ี 2.3 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 

ENABLE 74 
A_NOT 1 

ตารางท่ี 2.2 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 2.4 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 2.4 การต่อวงจรบนชุดทดลอง 

13. ทดสอบเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึก
ผลลงในตาราง 

ENABLE 
(SW1) 

A 
(SW0) 

A NOT  
(LED D0) 

LOW LOW  
LOW HIGH  
HIGH LOW  
HIGH HIGH  

ตารางท่ี 2.3 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 การน าลอจิกเกททีม่ี 3 สถานะมาประยุกต์ในการส่งข้อมูลบนบัส
ร่วมกนั 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_2b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 
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3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ not, tri, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูปท่ี 2.5 ซ่ึงมีจุดท่ีควรสังเกตดงัน้ี 

a. สายสัญญาณในวงจรมีทั้งเส้นหนา และเส้นบาง ซ่ึงสายสัญญาณเส้นบางคือสายสัญญาณ
เด่ียว และสายสัญญาณเส้นหนาจะใชแ้ทนบสัสัญญาณ 

b. ในการเช่ือมต่อสัญญาณเส้นเด่ียวเขากบับสัจะตอ้งมีการก าหนดลาเบล (Label) ให้แก่มนั
ดว้ย 

c. อินพุทและเอาต์พุทท่ีเช่ือมต่อกับบัสจะต้องก าหนดเป็นแบบเวกเตอร์ นั่นคือมีการ
ก าหนดขนาดให้แก่มนัดว้ย เช่น A[2..0] คือสายสัญญาณ A มีขนาด 3 บิต โดยการเรียง
บิตจะเป็น (A2) (A1) (A0) หรือก็คือ MSB คือ A2 และ LSB คือ A0 นัน่เอง   

 

รูปท่ี 2.5 วงจรส าหรับการทดลองตอนท่ี 2 

d. การวาดสายสัญญาณแบบบสัแสดงดงัรูปท่ี 2.6 โดยเร่ิมจากการคลิกท่ีปุ่ม  ต่อจากน้ี
เราสามารถลากเส้นสัญญาณท่ีตอ้งการให้เป็นบสัไดแ้ลว้ 
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รูปท่ี 2.6 ปุ่มท่ีอยูใ่นโปรแกรม 

e. การก าหนดลาเบลให้กบัสายสัญญาณ และบสัดงัรูปท่ี 2.7a และ ดงัรูปท่ี 2.7b โดยเร่ิม
จากคลิกซา้ยเลือกสายสัญญาณหรือบสัท่ีตอ้งการก าหนดช่ือลาเบล จากนั้นสายสัญญาณ
จะเปล่ียนเป็นสีน ้ าเงินพร้อมมีเคอร์เซอร์ส่ีเหล่ียมขนาดเล็กกระพริบ ซ่ึงขณะน้ีเรา
สามารถพิมพช่ื์อลาเบลท่ีตอ้งการลงไปไดท้นัที 

                                                                        

รูปท่ี 2.7a คลิกซา้ยบนสายสญัญาณท่ีตอ้งการก าหนดลาเบล        รูปท่ี 2.7b พิมพช่ื์อลาเบลท่ี
ตอ้งการ 

f. หากตอ้งการแกไ้ขลาเบลท่ีเขียนไปแลว้ ใหท้  าการดบัเบิลคลิกท่ีตวัหนงัสือท่ีเป็นลาเบล
แลว้ใหพ้ิมพท์บัแกไ้ขไดเ้ลย 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_2b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล์ Vector Waveform ในช่ือ lab_2a.scf เพื่อจ าลองการท างานของวงจร โดยสัญญาณท่ี
จะน ามาท าการจ าลองการท างานไดแ้ก่ Control (1),  A[2..0] (1), B[2..0] และ OUT[2..0] (0) 

ส าหรับการก าหนดสัญญาณเพื่อการจ าลองการท างานให้ก าหนดสัญญาณ A และ B เป็นแบบ 

Count ซ่ึงท าไดโ้ดยการคลิกขวาท่ีช่ือสัญญาณ จากนั้นจะมีเมนู Pop-up ปรากฏข้ึน ให้เลือกท่ีเมนู 
Value -> Count Value… แลว้ก าหนดค่า Starting Value ของสัญญาณ A เป็น 0 และ Staring 

Value ของสัญญาณ B มีค่าเท่ากบั 3 ดงัรูปท่ี 2.9a และ รูปท่ี 2.9b ตามล าดบั จากนั้นจ าลองการ
ท างานและบนัทึกผลการทดลอง 
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รูปท่ี 2.8 คลิกขวาท่ีสัญญาณเพื่อเรียกเมนู Pop-up 

 

 

รูปท่ี 2.9a การก าหนดค่าเร่ิมตน้ใหแ้ก่ 

สัญญาณ A 

รูปท่ี 2.9b การก าหนดค่าเร่ิมตน้ใหแ้ก่ 

สัญญาณ B 
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Name:                                   100.0ns    200.0ns    300.0ns    400.0ns    500.0ns    600.0ns    700.0ns    800.0ns   900.0ns        1.0us 

  

    CONTROL  

  

    A[2..0]  

  

    B[2..0]  

  

   OUT[2..0]  

  

 รูปท่ี 2.10 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
CONTROL 42 

A0 72 
A1 70 
A2 68 
B0 79 
B1 76 
B2 74 

OUT0 1 
OUT1 3 
OUT2 7 

ตารางท่ี 2.4 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

 

 

 

0 1 2 3 4 5 6 7 0 1 

3 4 5 6 7 0 1 2 3 4 
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12. ต่อวงจรตามรูปท่ี 2.11 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

D7 D6  D5  D4  D3  D2 D1  D0
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FPGA 
UNIT

   SW7   SW6    SW5   SW4

   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4

SW0

SW1

SW2

SW3

SW4

SW5

SW6

SW7

LOGIC
SWITCH

    

    

    

    

    

    

PIN79

PIN74

PIN1
P

o
rt

_C
Port_D

P
o

rt
_A

Port_B

PIN7

PIN72
PIN42 PIN68

 

รูปท่ี 2.11 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1, SW2, SW3, SW4, SW5, SW6 

และ SW7 แลว้ดูผลทางลอจิก ท่ี LED_D0, LED_D1 และ LED_D2 จากนั้นบนัทึกผลลงในตาราง 
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SW7 
(Control) 

SW6 
(A2) 

SW5 
(A1) 

SW4 
(A0) 

SW2 
(B2) 

 SW1 
(B1) 

SW0 
(B0) 

LED_D2 
(OUT2) 

LED_D1 
(OUT1) 

LED_D0 
(OUT0) 

0 0 0 0 0 1 1    
0 0 0 1 1 0 0    
0 0 1 0 1 0 1    
0 0 1 1 1 1 0    
0 1 0 0 1 1 1    
1 1 0 1 0 0 0    
1 1 1 0 0 0 1    
1 1 1 1 0 1 0    
1 0 0 0 1 0 0    
1 0 0 1 1 0 1    

ตารางท่ี 2.5 ตารางความจริงจากการทดลองตอนท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่3 
วงจรเข้ารหัส (Encoder) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรเขา้รหสั 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรเขา้รหสั 

 4. สามารถดาวน์โหลดวงจรลงไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
         วงจรเขา้รหสั (Encoder) คือ วงจรท่ีใชส้ าหรับแปลงขอ้มูลตวัเลขต่าง ๆ เช่น ขอ้มูลปมท่ีถูกกด
บนคียบ์อร์ด ใหอ้ยูใ่นรูปแบบของรหสัเลขฐานสองซ่ึงแทนดว้ยระดบัลอจิก 1 และ 0 ขอ้สังเกตอยา่ง
หน่ึงของวงจรเข้ารหัสคือ มนัจะมีอินพุทท่ีแอคทีฟในเวลาหน่ึง ๆ ได้เพียงอินพุทเดียวเท่านั้ น 
จ  านวนรูปแบบสูงสุดของอินพุทท่ีเป็นไปไดน้ั้นจะข้ึนอยูก่บัจ  านวนบิตทางดา้นเอาตพ์ุทโดยจะมีค่า
เป็น 2n บิต เม่ือ n คือ จ านวนบิตของเอาตพ์ุท 

         ส าหรับตวัอยา่งและตารางความจริงของวงจรเขา้รหสัแบบ 4 สาย เป็น 2 สาย (4 to 2 line 

Encoder) แสดงดงัรูปท่ี 3.1 และตารางท่ี 3.1 ตามล าดบั 

 

 
 
 
 
 

 

อนิพุท เอาต์พุท 
A3 A2 A1 A0 Y1 Y0 
0 0 0 1 0 0 
0 0 1 0 0 1 
0 1 0 0 1 0 
1 0 0 0 1 1 

รูปท่ี 3.1 วงจรเขา้รหสัแบบ 4 สายเป็น 2 

สาย 

ตารางท่ี 3.1 ตารางความจริงของวงจรเขา้รหสั             
แบบ 4 สายเป็น 2 สาย 
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จากตารางความจริงของวงจรเขา้รหัสแบบ 4 สาย เป็น 2 สาย เราสามารถน ามาเขียนเป็น
สมการบูลีน และวาดเป็นวงจรลอจิกไดด้งัน้ี  
 

Y0  =  A1  +  A3 

Y1  =  A1  +  A3 

 
 

รูปท่ี 3.2 วงจรเขา้รหสัแบบ 4 สายเป็น 2 สาย      รูปท่ี 3.3 วงจรเขา้รหสัแบบ 4 สายเป็น 2 สาย  

ขอ้เสียของวงจรเขา้รหสัแบบน้ีคือ ในขนาดท่ีมีอินพุทแอคทีฟข้ึนมามากกวา่ 1 อินพุท เช่น 
การกดสวิตช์ พร้อมกนั 2 ตวั จะท าให้การเขา้รหัสเกิดความผิดพลาดได ้ดงันั้นเราจึงตอ้งมีการให้
ความส าคญัแก่ล าดบัของอินพุทดว้ย ซ่ึงวงจรเขา้รหัสแบบน้ีเราเรียกวา่ วงจรเขา้รหสัแบบให้ความ
ล าดบัส าคญั (Priority Encoder) ซ่ึงจะมีการก าหนดล าดบัความส าคญัให้แก่อินพุทแต่ละตวัมีค่า
ต่างกนั โดยอินพุทท่ีมีล าดบัความส าคญัสูงกวา่จะถูกเขา้รหสัออกมาเพียงตวั ในกรณีท่ีมีอินพุทเขา้
มา 2 ตวัพร้อมกนัวงจรจะท าการเขา้รหสัเฉพาะอินพุทท่ีมีความส าคญัสูงกวา่เท่านั้น ส าหรับตาราง
ความจริงของวงจรเขา้รหสัแบบให้ความส าคญัสามารถแสดงดงัตารางท่ี  3.2 ซ่ึงตวัอยา่งของไอซีท่ี
ท าหนา้ท่ีเป็นวงจรเขา้รหสัแบบใหล้ าดบัความส าคญัไดแ้ก่ ไอซีเบอร์ 74148  

 
 

 
 
 
 

 

รูปท่ี 3.4 วงจรเขา้รหสัแบบ 8  สาย
เป็น 3 สาย 

ตารางท่ี 3.2 ตารางความจริงของวงจรเขา้รหสัแบบ 8 สาย 

เป็น 3 สาย 

อนิพุท เอาต์พุท 
A7 A6 A5 A4 A3 A2 A1 A0 Y2 Y1 Y0 
0 0 0 0 0 0 0 1 0 0 0 
0 0 0 0 0 0 1 x 0 0 1 
0 0 0 0 0 1 x x 0 1 0 
0 0 0 0 1 x x x 0 1 1 
0 0 0 1 x x x x 1 0 0 
0 0 1 x x x x x 1 0 1 
0 1 x x x x x x 1 1 0 
1 x x x x x x x 1 1 1 
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ไอซี 74148 มีสัญลกัษณ์และตารางความจริงดงัรูปท่ี 3.5 และ ตารางท่ี 3.3 โดยดา้นอินพุต
และเอาตพ์ุทเป็นชนิดแอคทีฟโลว ์(Active Low) ซ่ึงมีขาอินพุท 9 ขา โดยแบ่งเป็นขาอินพุทส าหรับ
เขา้รหสั 8 ขา (IO-I7) และขาส าหรับเปิดสัญญาณอินพุท (EI) ส่วนทางดา้นเอาตพ์ุทจะมี 5 ขา โดย
ใชเ้ป็นขาหรับรหสั ไบนารีท่ีผา่นการเขา้รหสัแลว้ 3 ขา (A0-A2) ขา GS ส าหรับใชบ้่งบอกวา่มี
อินพุทแอคทีฟ และขา EO ส าหรับเปิดไอซี 74148 ตวัถดัไปในกรณีท่ีใชง้านเป็นระบบเขา้รหสัท่ี
มากกวา่ 8 บิต 

 
 
 

 
 
 

รูปท่ี 3.5 ไอซี 74148                             ตารางท่ี 3.3 ตารางความจริงของไอซี 74148 

ส าหรับการทดลองน้ีจะมีการน าไลบราร่ีของไอซี 74148 ซ่ึงมีอยูใ่นโปรแกรม Quartus II 

8.1 Web Edition มาใชง้าน โดยไลบราร่ีน้ีจะเก็บอยูท่ี่ C:/altera/81/quartus/libraries -> Others -> 

74148 ซ่ึงเม่ือวาด 74148 ลงในวงจรแลว้เราสามารถดบัเบิ้ลคลิกท่ีสัญลกัษณ์ของ 74148 จะมี
สัญลกัษณ์ วงกลมทั้งขาอินพุทและเอาตพ์ุทของ 74148 เป็นแบบ Active Low หรือก็คือ 74148 เป็น
อุปกรณ์ท่ีท างานในสภาวะลอจิกต ่านัน่เอง 

อนิพุท เอาต์พุท 
EI 0 1 2 3 4 5 6 7 A2 A1 A0 GS EO 
1 X X X X X X X X 1 1 1 1 1 
0 1 1 1 1 1 1 1 1 1 1 1 1 0 
0 X X X X X X X 0 0 0 0 0 1 
0 X X X X X X 0 1 0 0 1 0 1 
0 X X X X X 0 1 1 0 1 0 0 1 
0 X X X X 0 1 1 1 0 1 1 0 1 
0 X X X 0 1 1 1 1 1 0 0 0 1 
0 X X 0 1 1 1 1 1 1 0 1 0 1 
0 X 0 1 1 1 1 1 1 1 1 0 0 1 
0 0 1 1 1 1 1 1 1 1 1 0 0 1 
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รูปท่ี 3.6a สัญลกัษณ์ของ 74148 ใน Quartus II 8.1 Web Edition 

 

รูปท่ี 3.6b วงจรภายใน 74148 เม่ือท าการดบัเบิลคลิกบนตวัสัญลกัษณ์ 74148 

ENCODER

5N

0N

1N

2N

3N

4N

EIN

6N

7N

A1N

A0N

A2N

EON

GSN

74148

inst

gndEIN INPUT

vcc7N INPUT

vcc6N INPUT

vcc5N INPUT

vcc4N INPUT

vcc3N INPUT

vcc2N INPUT

vcc1N INPUT

vcc0N INPUT

EONOUTPUT

GSNOUTPUT

A0NOUTPUT

A1NOUTPUT

A2NOUTPUT

AND3

81

AND4

78

AND4

76
AND4

77

AND6

80

NOR4

9

NOR4

109

NOR4

8

NAND8

83

AND2

108

AND2

107

AND2

69

AND2

70
AND2

71

AND2

73

AND2

74
AND2

75

NAND2

84NOT

54

NOT

106

NOT

105

NOT

104

NOT

103

NOT

55

NOT

57

NOT

61

NOT

62

NOT

65

NOT

60

NOT

63

VCC
87

74148

TITLE
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COMPANY
ALTERA CORPORATION

DESIGNER
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NUMBER 1.00 REV A

DATE
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SHEET
1

OF
1
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ขั้นตอนการทดลอง ตอนที ่1 วงจรเข้ารหัส 4 สายเป็น 2 สาย 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_3a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ or2, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

 

รูปท่ี 3.7 วงจรส าหรับการทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_3a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_3a.scf เพื่อจ าลองการท างานของวงจร 

Name:                         100.0ns        200.0ns       300.0ns       400.0ns       500.0ns       600.0ns 

  

    A3  

  

    A2  

  

    A1  

  

    A0  

  

    Y1  

  

    Y0  

  

รูปท่ี 3.8 ผลการจ าลองการท างาน 
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9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A0 83 
A1 79 
A2 76 
A3 74 
Y0 1 
Y1 3 

ตารางท่ี 3.4 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 3.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 3.9 การต่อวงจรบนชุดทดลอง 
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13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1, SW2 และ SW3 แลว้ดูผลทาง
ลอจิก ท่ี LED_D0 และ LED_D1 จากนั้นบนัทึกผลลงในตาราง 

 
A3 

(SW3) 
A2 

(SW2) 
A1 

(SW1) 
A0 

(SW0) 
LED_D1 

(Y1) 
LED_D0 

(Y0) 
LOW LOW LOW HIGH   
LOW LOW HIGH LOW   
LOW HIGH LOW LOW   
HIGH LOW LOW LOW   

ตารางท่ี 3.5 ตารางความจริงจากการทดลองท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 การใช้ไอซีวงจรเข้ารหัส 74148 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_3b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74148, gnd, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 3.10 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_3b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  
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8. สร้างไฟล ์Vector Waveform ในช่ือ lab_3b.scf เพื่อจ าลองการท างานของวงจร 

Name:                                 100.0ns    200.0ns     300.0ns    400.0ns     500.0ns     600.0ns    700.0ns    800.0ns     900.0ns         1.0us 

  

     A7  

  

    A6  

  

    A5  

  

    A4  

  

    A3  

  

    A2  

  

    A1  

  

    A0  

  

   Y[2..0]  

  

    GSN  

  

    EON  

  

รูปท่ี 3.11 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 
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ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A0 53 A7 72 
A1 55 Y0 1 
A2 59 Y1 3 
A3 64 Y2 7 
A4 66 EON 11 
A5 68 GSN 28 
A6 70   

ตารางท่ี 3.6 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 3.12 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 3.12 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2, SW3, SW4, SW5, SW6 

และ SW7 และดูผลทางลอจิกท่ี LED_D0, LED_D1, LED_D2, LED_1 และ LED_2 
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A0 
(SW7) 

A1 
(SW6) 

A2 
(SW5) 

A3 
(SW4) 

A4 
(SW3) 

A5 
(SW2) 

A6 
(SW1) 

A7 
(SW0) 

EON 
(LED_2) 

GSN 
(LED_1) 

Y2 
(LED_D2) 

Y1 
(LED_D1) 

Y0 
(LED_D0) 

1 1 1 1 1 1 1 0      
1 1 1 1 1 1 0 1      
1 1 1 1 1 0 1 1      
1 1 1 1 0 1 1 1      
1 1 1 0 1 1 1 1      
1 1 0 1 1 1 1 1      
1 0 1 1 1 1 1 1      
0 1 1 1 1 1 1 1      
1 0 1 0 1 1 1 1      
1 1 1 1 0 0 1 0      
1 1 1 1 1 1 1 1      

ตารางท่ี 3.7 ตารางความจริงจากการทดลองท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่4 
วงจรถอดรหัส (Decoder) 

วตัถุประสงค์ 
1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร

ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรถอดรหสั 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรถอดรหสัได ้
 4. สามารถดาวน์โหลดวงจรลงไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรถอดรหสั (Decoder) คือ วงจรท่ีใชแ้ปลงรหสัเลขฐานสองใหก้ลายเป็นรหสัตวัเลขต่าง 
ๆ เช่นต าแหน่งคียข์องสวิทช์ ซ่ึงเราอาจมองไดว้า่หนา้ท่ีการท างานของวงจรถอดรหัสจะมีลกัษณะ
ตรองกนัขา้มกบัวงจรเขา้รหสันัน่เอง จ านวนรูปแบบสูงสุดของเอาตพ์ุทท่ีเป็นไปไดน้ั้นจะข้ึนอยูก่บั
จ  านวนบิตทางดา้นอินพุทโดยจะมีค่าเป็น 2n บิต เม่ือ n คือจ านวนบิตของอินพุท 

 
 

              
 
 

รูปท่ี 4.1 วงจรถอดรหสัแบบ 2 สายเป็น 4 
สาย  

ตารางท่ี 4.1 ตารางความจริงของวงจรถอดรหสั
แบบ 2 สายเป็น 4 สาย 

 

อนิพุท เอาต์พุท 
A1 A2 Y3 Y2 Y1 Y0 
0 0 0 0 0 1 
0 1 0 0 1 0 
1 0 0 1 0 0 
1 1 1 0 0 0 
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จากตารางความจริงของวงจรถอดรหสัแบบ 2 สายเป็น 4 สาย เราสามารถน ามาเขียนเป็น
สมการบูลีน และวาดเป็นวงจรลอจิกไดด้งัน้ี 

 
 
 
 
 
 
 
 
 
 
 รูปท่ี 4.2 สมการบูลีนของวงจรถอดรหสั
แบบ 2 สายเป็น 4 สาย  

รูปท่ี 4.3 วงจรถอดรหสัแบบ 2 สายเป็น 4 สาย 

ตวัอยา่งของวงจรถอดรหสัท่ีมีการใชก้นัโดยทัว่ไปไดแ้ก่วงจรถอดรหสัเลขฐานสองให้เป็น
ตวัเลข 7 ส่วน (7-Segment) ซ่ึงตวัเลข 7 ส่วนคืออุปกรท่ีมีการน าเอา LED 7 ตวัมาจดัเรียงเพื่อใช้
แสดงเป็นตวัเลข หรือในบางคร้ังใชแ้ทนตวัหนงัสือบางตวั ในส่วนของ LED ท่ีน ามาต่อกนัแต่ละ
ส่วนหรือบางคร้ังเรียกวา่เซกเมนต ์(Segment) จะมีช่ือเรียงตามล าดบัตวัอกัษร ตวัเลขเจ็ดส่วนท่ีมีใช้
ในปัจจุบนัแบ่งเป็น 2 ชนิดตามโครงสร้าง ไดแ้ก่ คอมมอนแอโนด และคอมมอนแคโถด ซ่ึงมีวงจร
ภายในดงัรูปท่ี 4.4 

 
รูปท่ี 4.4 ตวัอยา่งการวางตวัเลข 7 ส่วน 

Y0 = A1A0 

Y1 = A1 A0 

Y2 = A1 A0 

Y3 = A1A0 
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 ตวัอย่างของไอซีท่ีท าหน้าท่ีเป็นวงจรถอดรหสัไดแ้ก่ไอซีเบอร์ 7447 ซ่ึงท าหนา้ท่ีเป็นตวั
ถอดรหสัเลขฐานสองให้เป็นตวัเลข 7 ส่วน (7-Segment) แบบคอมมอนแอโนด ในส่วนของการ
ท างานของไอซีเบอร์ 7447 นั้นจะเป็นดงัตารางท่ี ซ่ึงท่านสามารถศึกษาการใชง้านโดยละเอียดได้
จาก Datasheet ของผูผ้ลิตอีกคร้ัง 

อนิพุท เอาต์พุท 

Decimal 
    Or 
Function 

LT RBI 
D C B A  BI / 

RBO a b c d e f g 

0 H H L L L L H L L L L L L H 
1 H X L L L H H H L L H H H H 
2 H X L L H L H L L H L L H L 
3 H X L L H H H L L L L H H L 
4 H X L H L L H H L L H H L L 
5 H X L H L H H L H L L H L L 
6 H X L H H L H H H L L L L L 
7 H X L H H H H L L L H H H H 
8 H X H L L L H L L L L L L L 
9 H X H L L H H L L L H H L L 

10 H X H L H L H H H H L L H L 
11 H X H L H H H H H L L H H L 
12 H X H H L L H H L H H H L L 
13 H X H H L H H L H H L H L L 
14 H X H H H L H H H H L L L L 
15 H X H H H H H H H H H H H H 
BI X X X X X X L H H H H H H H 

RBI H L L L L L L H H H H H H H 
LT L H X X X X H L L L L L L L 

ตารางท่ี 4.2 ตารางความจริงของไอซี 7447 
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รูปท่ี 4.5 ไอซี 7447 

 
รูปท่ี 4.6 รูปแบบการถอดรหสัของไอซี 7447 

 
ขั้นตอนการทดลอง ตอนที ่1 วงจรถอดรหัส 2 สายเป็น 4 สาย 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_4a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ and2, not, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 4.7 วงจรส าหรับการทดลองตอนท่ี 1 
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6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_4a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_4a.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                 200.0ns                 300.0ns                 400.0ns 

  

    A1  

  

    A0  

  

    Y3  

  

    Y2  

  

    Y1  

      

    Y0  

  

รูปท่ี 4.8 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A0 76 
A1 74 
Y0 1 
Y1 3 
Y2 7 
Y3   11 

ตารางท่ี 4.3 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 
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12. ต่อวงจรตามรูปท่ี 4.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 4.9 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED_D0, 

LED_D1, LED_D2 และ LED_D3 จากนั้นบนัทึกผลลงในตาราง 

 

 

A1 
(SW1) 

A0 
(SW0) 

Y3 
(LED_D3) 

Y2 
(LED_D2) 

Y1 
(LED_D1) 

Y0 
(LED_D0) 

LOW LOW     
LOW HIGH     
HIGH LOW     
HIGH HIGH     

ตารางท่ี 4.4 ตารางความจริงจากการทดลองท่ี 1 
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ขั้นตอนการทดลอง ตอนที ่2 การใช้ไอซีวงจรถอดรหัส 7447 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_4b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 7447, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 4.10 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_4b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

9. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A 83 Seg_c 7 
B 79 Seg_d 11 
C 76 Seg_e 28 
D 74 Seg_f 31 

Seg_a 1 Seg_g 33 
Seg_b 3   

ตารางท่ี 4.5 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

 

VCC
A INPUT

VCC
B INPUT

VCC
C INPUT

VCC
D INPUT

Seg_aOUTPUT

Seg_bOUTPUT

Seg_cOUTPUT

Seg_dOUTPUT

Seg_eOUTPUT

Seg_fOUTPUT

Seg_gOUTPUT

BCD TO 7SEG

LTN

B

C

D

RBIN

BIN

A

OB

OC

OE

OD

OF

OG

OA

RBON

7447

inst
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10. ต่อวงจรตามรูปท่ี 4.11 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

Cyclone III
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FPGA 
UNIT

   SW7   SW6    SW5   SW4

   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4

SW0

SW1

SW2

SW3

SW4

SW5

SW6

SW7

LOGIC
SWITCH

    

    

    

    

    

    

PIN1

PIN74

DIGITA DIGITA

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

DT  G   F    E     D    C    B     A                   DT  G   F    E     D    C    B     A                   

CA

CK

CA

CK

SEVENT
SEGMENT

PIN33

PIN83

PIN11

P
o

rt_C
Port_D

P
o

rt
_A

Port_B

 

รูปท่ี 4.11 การต่อวงจรบนชุดทดลอง 

11. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2 และ SW3 แลว้ดูผลทาง
ลอจิก ท่ี SEVEN SEGMENT DIGIT จากนั้นบนัทึกผลลงในตาราง 
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D 
(SW3) 

C 
(SW2) 

B 
(SW1) 

A 
(SW0) 

รูปแบบ LED บน 
(SEVEN 

SEGMENT) 

 D 
(SW3) 

C 
(SW2) 

B 
(SW1) 

A 
(SW0) 

รูปแบบ LED บน 
(SEVEN 

SEGMENT) 

0 0 0 0  1 0 0 0  
0 0 0 1  1 0 0 1  
0 0 1 0  1 0 1 0  
0 0 1 1  1 0 1 1  
0 1 0 0  1 1 0 0  
0 1 0 1  1 1 0 1  
0 1 1 0  1 1 1 0  
0 1 1 1  1 1 1 1  

ตารางท่ี 4.6 ตารางความจริงจากการทดลองท่ี 2 

สรุปผลการทดลอง 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



100 
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การทดลองที ่5 
วงจรมัลตเิพลก็ซ์ (Multiplexor) 

วตัถุประสงค์ 
1. เรียนรู้การใช้งานโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร

ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 
 2. เพื่อเรียนรู้การท างานของวงจรมลัติเพล็ก 
 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรมลัติเพล็ก 
 4. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้
อุปกรณ์ส าหรับการทดลอง 
 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรมลัติเพล็กซ์ (Multiplexor) เป็นวงจรท่ีท าหน้าท่ีเป็นตวัเลือกข้อมูลดิจิตอล โดย
ลกัษณะของวงจรจะมีชุดของอินพุทมากกวา่  1 ชุด แต่จะมีเอาตพ์ุทเพียงชุดเดียว ซ่ึงการท างานของ
วงจรมลัติเพล็กจะท าหน้าท่ีเป็นตวัเลือกชุดขอ้มูลทางอินพุทให้ออกมาเพียงชุดเดียวเท่านั้น ซ่ึงอาจ
เปรียบไดก้บัสวทิช์เลือก Selector Switch) นัน่เอง 

 

รูปท่ี 5.1 วงจรมลัติเพล็กซ์ 

 ในตารางท่ี 5.1 และ รูปท่ี 5.2 เป็นตารางความจริง รวมถึงสมการบูลีนและวงจรลอจิกของ
วงจรมลัติเพล็กซ์แบบ 2 สายเป็น 1 สาย 
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ส าหรับตวัอยา่งของไอซีท่ีท าหนา้ท่ีเป็นวงจรมลัติเพล็กซ์ไดแ้ก่ ไอซีเบอร์ 74153 ซ่ึงเป็น

ไอซีมลัติเพล็กซ์แบบ 4 สาย เป็น 1 สาย 2 ชุด โดยใชข้าเลือกขอ้มูลร่วมกนั และมีขาเปิดการท างาน 
(Enable) เอาตพ์ุทแยกจากกนัทั้ง 2 ชุด ซ่ึงสามารถเลือกเปิดการท างานเอาตพ์ุทชุดใดชุดหน่ึงโดย
อิสระ 
 

 
 
 
 

 
 
 
 
 

 
 

 

อนิพุท เอาต์พุท 
Sel D1 D0 Y 
0 0 0 0 
0 0 1 1 
0 1 0 0 
0 1 1 1 
1 0 0 0 
1 0 1 0 
1 1 0 1 
1 1 1 1 

ตารางท่ี 5.1 ตารางความจริงของวงจร
มลัติเพล็กซ์แบบ 2 สายเป็น 1 สาย 

รูปท่ี 5.2 วงจรมลัติเพล็กซ์แบบ 2 สายเป็น 1 สาย 

Select Data  
G 

output 
B A C0 C1 C2 C3 
X X X X X X L L 
L L L X X X L L 
L L H X X X L H 
L H X L X X L L 
L H X H X X L H 
h L X X L X L L 
H L X X H X L H 
H H X X X L L L 
H H X X X H L H 

รูปท่ี 5.3 ไอซี 74153 ตารางท่ี 5.2 ตารางความจริงของไอซี 74153 
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ขั้นตอนการทดลอง ตอนที ่1 วงจรมัลติเพลก็ซ์ 2 สายเป็น 1 สาย 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_5a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor เลือกอุปกรณ์ and2, or2, not, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 5.4 วงจรส าหรับการทดลองตอนท่ี 1  

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_5a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_5a.scf เพื่อจ าลองการท างานของวงจร 

Name:                    100.0ns    200.0ns    300.0ns    400.0ns    500.0ns    600.0ns    700.0ns    800.0ns   900.0ns        1.0us 

  

    Sel  

  

    D1  

  

    D2  

  

    Y  

  

รูปท่ี 5.5 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins  
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11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
D0 79 
D1 76 
Sel 74 
Y 1 

ตารางท่ี 5.3 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 5.6 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4
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SW1
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SW3
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SW6

SW7
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SWITCH

    

    

    

    

    

    

PIN79

PIN74

PIN1

P
o

rt_
C

Port_D

P
o

rt
_

A

Port_B

 

รูปท่ี 5.6 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี 
LED_D0 จากนั้นบนัทึกผลลงในตาราง 
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Sel 
(SW2) 

D1 
 (SW1) 

D0 
(SW0) 

Y0 
(LED_D0) 

LOW LOW LOW  
LOW LOW HIGH  
LOW HIGH LOW  
LOW HIGH HIGH  
HIGH LOW LOW  
HIGH LOW HIGH  
HIGH HIGH LOW  
HIGH HIGH HIGH  

ตารางท่ี 5.4 ตารางความจริงจากการทดลองท่ี 1 

 

ขั้นตอนการทดลอง ตอนที ่2 ไอซีวงจรมัลติเพลก็ซ์ 74153 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_5b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74153, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 5.7 วงจรส าหรับการทดลองท่ี 2 

VCC
A INPUT

VCC
B INPUT

VCC
GN INPUT

VCC
C0 INPUT

VCC
C1 INPUT

VCC
C2 INPUT

VCC
C3 INPUT

YOUTPUT

MULTIPLEXER

1C1

1GN

1C0

2C0

2GN

2C2

1C2

1C3

B

A

2C1

2C3

1Y

2Y

74153

inst
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6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_5b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_5b.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     GN  

  

    C3  

  

    C2  

  

    C1  

  

    C0   

  

    B  

  

    A  

  

   Y  

  

รูปท่ี 5.8 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
C0 72 A 64 
C1 70 B 59 
C2 68 GN 55 
C3 66 Y 1 

ตารางท่ี 5.5 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 
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12. ต่อวงจรตามรูปท่ี 5.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 5.9 การต่อวงจรบนชุดทดลอง 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



108 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2, SW3, SW4, SW5 และ 
SW6 แลว้ดูผลทางลอจิกท่ี LED_D0 จากนั้นบนัทึกผลลงในตาราง 

 
GN 

(SW6) 
B 

(SW5) 
A 

(SW4) 
C3 

(SW3) 
C2 

(SW2) 
C1 

(SW1) 
C0 

(SW0) 
Y0 

(LED_D0) 
0 0 0 0 0 0 1  
0 0 0 0 0 1 0  
0 0 0 0 1 1 1  
0 0 0 1 1 0 0  
0 0 1 1 1 0 1  
0 0 1 1 0 1 0  
0 0 1 1 0 1 1  
0 0 1 0 0 0 0  
0 1 0 0 1 0 1  
0 1 0 0 1 1 0  
0 1 0 0 1 1 1  
0 1 0 1 0 0 0  
0 1 1 1 0 0 1  
0 1 1 1 0 1 0  
0 1 1 1 1 1 1  
0 1 1 0 1 0 0  

ตารางท่ี 5.6 ตารางความจริงจากการทดลองท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่6 

วงจรดมีัลตเิพลก็ซ์ (Demultiplexor) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรดีมลัติเพล็ก 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรดีมลัติเพล็ก 
 4. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรดีมลัติเพล็กซ์ (Demultiplexor) เป็นวงจรท่ีท าหน้าท่ีกระจายขอ้มูลจากอินพุทท่ีมีอยู่
เพียง 1 ชุดให้ออกไปท่ีเอาต์พุทใดเอาต์พุทหน่ึงโดยอาศยัขาควบคุมในการกระจายขอ้มูล ซ่ึงการ
ท างานของดีมลัติเพล็กซ์จะมีลกัษณะตรงกนัขา้มกบัวงจรมลัติเพล็กซ์นัน่เอง 

 

รูปท่ี 6.1 วงจรดีมลัติเพล็กซ์ 

ในตารางท่ี 6.1 และรูปท่ี 6.2 เป็นตารางความจริง รวมถึงสมการบูลีนและวงจรลอจิกของ
วงจรดีมลัติเพล็กซ์แบบ 1 สายเป็น 2 สาย 
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ตารางท่ี 6.1 ตารางความจริงของวงจรดี
มลัติเพล็กซ์แบบ 1 สายเป็น 2 สาย 

รูปท่ี 6.2 วงจรดีมลัติเพล็กซ์แบบ 1 สายเป็น 2 สาย 

 ตวัอย่างของไอซีท่ีท าหน้าท่ีเป็นวงจรดีมลัติเพล็กซ์ไดแ้ก่ ไอซีเบอร์ 74155 ซ่ึงเป็นไอซีดี
มลัติเพล็กซ์แบบ 1 สาย เป็น 4 สาย 2 ชุด โดยใชข้าเลือกขอ้มูลร่วมกนั และมีขาสโตรบ  (Strobe) 

เปิดการท างาน (Eanable) เอาตพ์ุทแยกจากกนัทั้ง 2 สองชุด ซ่ึงสามารถเลือกเปิดการท างานเอาตพ์ุ
ทชุดใดชุดหน่ึงโดยอิสระ ขอ้มูลท่ีถูกป้อนเขา้มาท่ีขา 1C  จะถูกกลบัสัญญาณเอาตพ์ุท ส่วนสัญญาณ
ท่ีเขา้มา 2C จะไม่มีการกลบัสัญญาณ ซ่ึงการกลบัสัญญาณจากขอ้มูล 1C  จะท าให้เราสามารถน า
ไอซี 74155 ไปใชเ้ป็นตวัถอดรหสัแบบ 3 สายเป็น 8 สาย ได ้หรืออาจใชเ้ป็นวงจรมลัติเพล็กซ์แบบ 
1 สายเป็น 8 สายได ้โดยไม่ตอ้งเพิ่มอุปกรณ์ภายนอก ส าหรับการทดลองในบทน้ีเราจะทดลอง
เฉพาะในส่วนของการท าหนา้ท่ีเป็นวงจรดีมลัติเพล็กซ์แบบ 1 สาย เป็น 4 สายเท่านัน่ 

 
รูปท่ี 6.3 ไอซี 74155 

 

 

อนิพุท เอาต์พุท 

Sel D Y1 Y0 

0 0 0 0 

0 1 0 1 

1 0 0 0 

1 1 1 0 
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Select Strobe Data Output 
B A 1G 1C 1Y0 1Y1 1Y2 1Y3 
X X H X H H H H 
L L L H L H H H 
L H L H H L H H 
H L L H H H L H 
H H L H H H H L 
X X X L H H H H 

 

Select Strobe Data Output 
B A 2G 2C 2Y0 2Y1 2Y2 2Y3 
X X H X H H H H 
L L L H L H H H 
L H L H H L H H 
H L L H H H L H 
H H L H H H H L 
X X X L H H H H 

ตารางท่ี 6.2 ตารางความจริงของไอซี 74155 

ขั้นตอนการทดลอง ตอนที ่1 วงจรดีมัลติเพลก็ซ์  1สายเป็น 2 สาย 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_6a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor เลือกอุปกรณ์ and2, not, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 6.4 วงจรส าหรับทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_6a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_6a.scf เพื่อจ าลองการท างานของวงจร 

Name:                    100.0ns    200.0ns    300.0ns    400.0ns    500.0ns    600.0ns    700.0ns    800.0ns   900.0ns        1.0us 

  
    Sel  

  
    D1  

  
    Y1  

  
    Y0  

  

รูปท่ี 6.5 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
Sel 74 
D 76 

Y0 1 
Y1 3 

ตารางท่ี 6.3 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 
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12. ต่อวงจรตามรูปท่ี 6.6 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

D7 D6  D5  D4  D3  D2 D1  D0

  

  

  

  

  

  

  

  

  

  

  

  

8     4     2    1

  

  

  

  

  

  
LOGIC

MONITOR

DATABCD

Cyclone III

EP3C10E144C8N

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

    
    

    
    

    
    

    
    

    

    
    

    
    

    
    

    
    

    

FPGA 
UNIT

   SW7   SW6    SW5   SW4

   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4

SW0

SW1

SW2

SW3

SW4

SW5

SW6

SW7

LOGIC
SWITCH

    

    

    

    

    

    

PIN76

PIN74

PIN1
P

o
rt

_
C

Port_D

P
o

rt
_

A

Port_B

PIN3

 

รูปท่ี 6.6 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี 
LED_D0 และ LED_D1 จากนั้นบนัทึกผลลงในตาราง 

Sel  
(SW1) 

D  
(SW0) 

Y1 
(LED_D1) 

Y0 
(LED_D0) 

LOW LOW   
LOW HIGH   
HIGH LOW   
HIGH HIGH   

ตารางท่ี 6.4 ตารางความจริงจากทดลองตอนท่ี 1 
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ขั้นตอนการทดลอง ตอนที ่2 ไอซีวงจรมัลติเพลก็ซ์ 74155 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_6b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74155, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 6.7 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_6b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_6b.scf เพื่อจ าลองการท างานของวงจร 
 

VCC
D INPUT

VCC
A INPUT

VCC
B INPUT

VCC
G INPUT

Y0OUTPUT

Y1OUTPUT

Y2OUTPUT

Y3OUTPUT

DECODER

1C

2CN

SELB

SELA

1GN

2GN

1Y2N

1Y1N

1Y0N

2Y1N

2Y0N

1Y3N

2Y3N

2Y2N

74155

inst
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รูปท่ี 6.8 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
G 74 Y0 1 
B 76 Y1 3 
A 79 Y2 7 
D 83 Y3 11 

ตารางท่ี 6.5 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

 

 

 

Name:                          100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns     800.0ns    900.0ns         1.0us 

  

     G  

  

    D  

  

    B  

  

    A  

  

    Y3   
  

    Y2  
  

     Y1  
  

    Y0  
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12. ต่อวงจรตามรูปท่ี 6.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

D7 D6  D5  D4  D3  D2 D1  D0

  

  

  

  

  

  

  

  

  

  

  

  

8     4     2    1

  

  

  

  

  

  
LOGIC

MONITOR

DATABCD

Cyclone III

EP3C10E144C8N

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

    
    

    
    

    
    

    
    

    

    
    

    
    

    
    

    
    

    

FPGA 
UNIT

   SW7   SW6    SW5   SW4

   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4

SW0

SW1

SW2

SW3

SW4

SW5

SW6

SW7

LOGIC
SWITCH

    

    

    

    

    

    

PIN83

PIN74

PIN1
P

o
rt

_
C

Port_D

P
o

rt
_

A

Port_B

PIN11

 

รูปท่ี 6.9 การต่อวงจรบนชุดทดลอง 
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13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2 และ SW3 แลว้ดูผลทาง
ลอจิก ท่ี LED_D0, LED_D1, LED_D2 และ LED_D3 จากนั้นบนัทึกผลลงในตาราง 

GN 
(SW3) 

B 
(SW2) 

A 
(SW1) 

D 
(SW0) 

Y3 
(LED_D3) 

Y2 
(LED_D2) 

Y1 
(LED_D1) 

Y0 
(LED_D0) 

1 0 1 0     
1 0 1 1     
0 0 0 0     
0 0 0 1     
0 0 1 0     
0 0 1 1     
0 1 0 0     
0 1 0 1     
0 1 1 0     
0 1 1 1     

ตารางท่ี 6.6 ตารางความจริงจากการทดลองตอนท่ี 2  

สรุปผลการทดลอง 
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การทดลองที ่7 

วงจรเปรียบเทียบ (Comparator) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรเปรียบเทียบ 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรเปรียบเทียบได ้
 4. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรเปรียบเทียบ (Comparator) คือวงจรท่ีใช้ส าหรับเปรียบเทียบค่าลอจิกทางอินพุทท่ี
มากกวา่ 1 ชุดข้ึนไปโดยอาจเป็นการเปรียบเทียบค่าอินพุทวา่มีลอจิกเท่ากนั มากกวา่ หรือนอ้ยกวา่ 
เป็นตน้ ซ่ึงวงจรเปรียบเทียบจะมีประโยชน์มากในการตรวจสอบเง่ือนไขเพื่อการตดัสินใจของ
โปรแกรมต่างๆ เช่นโปรแกรมในเคร่ืองคดัแยกขนาดของผลิตการเกษตร วงจรเปรียบเทียบอยา่งง่าย
สามารถสร้างไดจ้ากเอ็กซ์คลูซีฟนอร์เกท นัน่คือ ในกรณีท่ีอินพุทมีค่าเท่ากนั มนัจะให้ค่าเอาต์พุท
เป็นลอจิก  1 และในกรณีท่ีเอาตพ์ุทมีค่าต่างกนัมนัจะใหเ้อาตพ์ุทเป็นลอจิก 0  

 นอกจากน้ีเราสามารถน าเอก็ซ์คูซีฟนอร์เกทมาท าเป็นวงจรก็ไดเ้ช่นกนั ซ่ึงเกททั้งสองจะให้
ลอจิกทางเอาตพ์ุทในลกัษณะคลา้ยกนัเพียงแต่มีค่าตรงขา้มกนัเท่านัน่ 

 

A_Equal_B
A

B
 

 

รูปท่ี 7.1 การน าเอก็ซ์คูซีฟนอร์เกทมาท าวงจรเปรียบเทียบอยา่งง่าย 
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Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    A  

  

    B  

  

    A_Equal_B  

  

รูปท่ี 7.2 ผลการจ าลองการท างานของวงจรการเปรียบเทียบอยา่งง่าย 

 ส าหรับวงจรจรเปรียบเทียบท่ีเพิ่มความสามารถในการตรวจสอบเง่ือนไขท่ีมากข้ึนแสดงดงั
รูปท่ี 7.2 ซ่ึงสร้างจากตารางความจริงในตารางท่ี ซ่ึงวงจรน้ีสามารถตรวจสอบค่าอินพุทท่ีมากกว่า 
นอ้ยกวา่ และเท่ากนัได ้ 

อนิพุท เอาต์พุท 
A B A<B A=B A>B 
0 0 0 1 0 
0 1 1 0 0 
1 0 0 0 1 
1 1 0 1 0 

ตารางท่ี 7.1 ตารางความจริงของวงจร
เปรียบเทียบ 

รูปท่ี 7.3 วงจรเปรียบเทียบ 

 ตวัอยา่งของไอซีส าเร็จรูปท่ีท าหนา้ท่ีเป็นตวัเปรียบเทียบลอจิกไดแ้ก่ไอซีเบอร์ 7485 ซ่ึงท า
หนา้ท่ีเปรียบเทียบแมก็นีจูด (Magnitude) ของอินพุทขนาด 4 บิต 2 ชุด ไดแ้ก่อินพุท A และ B โดย
มนัสามารถเปรียบเทียบไดว้า่อินพุท A และ B มากกวา่ หรือนอ้ยกวา่ได ้(A=B), (A>B), (A<B) ซ่ึง
การต่อใชง้านสามารถน าไปเปรียบเทียบอินพุทท่ีมากกวา่ 4 บิตได ้ซ่ึงสามารถศึกษาไดโ้ดยละเอียด
จาก Datasheet ของผูผ้ลิต แต่ส าหรับการทดลองน้ีเราจะทดลองเฉพาะการเปรียบเทียบอินพุทขนาด 
4 บิตเท่านั้น 
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รูปท่ี 7.4 ไอซี 7485 ตารางท่ี 7.2 ตารางความจริงของไอซี 7485 

ขั้นตอนการทดลอง ตอนที ่1 วงจรเปรียบเทยีบพืน้ฐาน 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_7a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ and2, or2, not, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 7.5 ผลการจ าลองการท างาน 

Comparing Input Outputs 

A3, B3 A2, B2 A1, B1 A0, B0 A>B A<B A=B 
A3>B3 X X X H L L 
A3<B3 X X X L H L 
A3=B3 A2>B2 X X H L L 
A3>B3 A2<B2 X X L H L 
A3<B3 A2=B2 A1>B1 X H L L 
A3=B3 A2=B2 A1<B1 X L H L 
A3>B3 A2=B2 A1=B1 A0>B0 H L L 
A3<B3 A2=B2 A1=B1 A0<B0 L H L 
A3=B3 A2=B2 A1=B1 A0=B0 L L H 
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6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_7a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_7a.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

   A  

  

   B  

  

   A_Less_B  

  

  A_Equal_B  

  

  A_Greater_B  

  

รูปท่ี 7.6 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 76 
B 74 

A_Lass_B 7 
A_Equal_B 3 

A_Greater_B 1 

ตารางท่ี 7.3 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 
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12. ต่อวงจรตามรูปท่ี 7.7 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 7.7 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิก ท่ี 
LED_D0, LED_D2 และ LED_D3 จากนั้นบนัทึกผลลงในตาราง 

B 
(SW1) 

A 
(SW0) 

(A_Less_B) 
LED D2 

(A_Equal_B) 
LED D1 

(A_Greater) 
LED D0 

LOW LOW    
LOW HIGH    
HIGH LOW    
HIGH HIGH    

ตารางท่ี 7.4 ตารางความจริงจากการทดลองตอนท่ี 1  
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ขั้นตอนการทดลอง ตอนที ่2 การใช้ไอซีวงจรเปรียบเทียบ 7485 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_7b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 7485, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 
รูปท่ี 7.8 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_7b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_7b.scf เพื่อจ าลองการท างานของวงจร โดยก าหนด
สัญญาณให้เป็นดงัต่อไปน้ี 

 a. ก าหนดสัญญาณให้เป็นแบบ Count ซ่ึงท าไดโ้ดยการคลิกขวาท่ีช่ือสัญญาณจากนั้นจะมี
เมนู Value -> Count Value… ดงัรูปท่ี 7.8a 
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รูปท่ี 7.8a ก าหนดค่าในช่อง Radix 

b. ก าหนดค่าในช่อง Radix. ใหเ้ป็น Hexadecimal  ในสัญญาณ A ใหก้ าหนดค่าในช่อง 
Starting Value เป็น 0 และ Increment By มีค่าเท่ากบั 1 ดงัรูปท่ี 7.8b 

 

รูปท่ี 7.8b ก าหนดค่าเร่ิมตน้ใหก้บัสัญญาณ A 

c. ก าหนดค่าในช่อง Radix .ใหเ้ป็น Hexadecimal  ในสัญญาณ B ใหก้ าหนดค่าในช่อง 
Starting Value เป็น 0 และ Increment By มีค่าเท่ากบั F ดงัรูปท่ี 7.8c 
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รูปท่ี 7.8c ก าหนดค่าเร่ิมตน้ใหก้บัสัญญาณ B 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     A[3..0]  
  

    B[3..0]  
  

    ALB  

  

    AEB  
  

    AGB  
  

รูปท่ี 7.9 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 

 

 

0 1 2 3 4 5 7 6 8 9 A B C D E F 0 1 2 3  

0 E F C D A B 8 9 6 7 4 5 2 3 0 1 D F  E 
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ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A0 83 B2 68 
A1 79 B3 66 
A2 76 ALB 7 
A3 74 AEB 3 
B0 72 AGB 1 
B1 70   

ตารางท่ี 7.5 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 7.10 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1, SW2, SW3, SW4, SW5, SW6

และ SW7 แลว้ดูผลทางลอจิก ท่ี LED_D0, LED_D1 และ LED_D2 จากนั้นบนัทึกผลลงในตาราง 
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B3 

(SW7) 

B2 

(SW6) 

B1 

(SW5) 

B0 

(SW4) 

B3 

(SW3) 

B2 

(SW2) 

B1 

(SW1) 

B0 

(SW0) 

ALB 

(LED_D2) 

AEB 

(LED_D1) 

AGB 

(LED_D0) 

0 0 0 0 0 0 0 0    

0 0 0 0 0 0 0 1    

0 0 0 1 0 0 0 0    

0 0 0 1 0 0 1 0    

0 0 1 0 0 0 0 1    

0 0 1 1 0 1 0 0    

0 1 0 0 0 0 1 1    

0 1 1 1 1 0 0 0    

1 0 0 0 0 1 1 1    

1 1 1 1 1 1 1 1    

ตารางท่ี 7.6 ตารางความจริงจากทดลองตอนท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่8 

วงจรบวกเลขฐานสอง (Adder) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรบวกเลขฐานสองแบบ Half Adder และ Full Adder 

3. วิเคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรบวกเลขฐานสองไดแ้บบ Half Adder 
และ Full Adder ได ้

 4. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรบวกเลขฐานสองแบ่งเป็นสองชนิดได้แก่ วงจรบวกเลขฐานสองแบบ Half Adder 

และ Full Adder ซ่ึงวงจรแบบ Half Adder จะเป็นวงจรบวกแบบไม่มีการน าตวัทดจากหลกัต ่ากวา่
มาร่วมค านวณดว้ย แต่ส าหรับวงจรแบบ Full Adder จะเป็นวงจรบวกท่ีมีการน าเอาตวัทดของของ
หลกัท่ีต ่ากวา่มาร่วมค านวณดว้ย ซ่ึงวงจรทั้งสองสามารถสร้างข้ึนจากการเขียนตารางความจริงโดย
ใชห้ลกัการบวกเลขฐานสองมาพิจารณา 
 ส าหรับวงจรบวกแบบ Half Adder สามารถเขียนเป็นตารางความจริงไดด้งัตารางท่ี 8.1 

และสามารถสร้างวงจรไดด้งัรูปท่ี 8.1 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

อนิพุท เอาต์พุท 
A  

(ตวัตั้ง) 
B 

(ตวับวก) 
C 

(ผลบวก) 
Co 

(ตวัทด) 
0 0 0 0 
0 1 1 0 
1 0 1 0 
1 1 0 1 

ตารางท่ี 8.1 ตารางความจริงของวงวงจร Half Adder       รูปท่ี 8.1 วงจร Half Adder 

A (       )

B (      )
C (     )

Co (     )

C   = AB + AB
Co = AB
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ส่วนวงจรบวกแบบ Full Adder จะสามารถเขียนเป็นตารางความจริงและวงจรไดด้งัตาราง
ท่ี 8.2 และรูปท่ี 8.2 ตามล าดบั ซ่ึงจะสังเกตไดว้า่อินพุทของวงจร Full Adder จะมีอินพุทของตวัทด
บิตต ่ากวา่มาค านวณดว้ย 

อนิพุท เอาต์พุท 

Ci 
(ตัวทดเข้า) 

A 
(ตัวติดตั้ง) 

B 
(ตัวบวก) 

C=A+B+Ci 
(ผลบวก) 

Co 
(ตัวทดออก) 

0 0 0 0 0 
0 0 1 1 0 
0 1 0 1 0 
0 1 1 0 1 
1 0 0 1 0 
1 0 1 0 1 
1 1 0 0 1 
1 1 1 1 1 

ตารางท่ี 8.2 ตารางความจริงของวง Full Adder 

Half Adder

Half Adder

C (     )

Co (     )

Ci (         )

A (       )

B (      )

                                        
   C   = ABCi + ABCi + ABCi + ABCi
   Co = AB + ACi + BCi 

                                                     
  Half Adder 2                         
   C   = (A      B)      Ci
   Co = AB + Ci(A        B)  

รูปท่ี 8.2 วงจร Full Adder 
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ไอซีส าเร็จรูปท่ีท าหนา้ท่ีเป็นวงจรบวกแบบ Full Adder ไดแ้ก่เบอร์ 7483 ซ่ึงเป็นไอซี Full 

Adder ขนาด 4 บิต โดยภายในประกอบไปดว้ยวงจร Full Adder 4 ชุด มีการต่อขาตวัทดจากแต่ละ

หลกัไปเป็นอินพุทของหลกัถดัไปอยูภ่ายในตวัมนั และมีขาตวัทดจากหลกัสุดทา้ยเพื่อใชส้ าหรับต่อ

ขยายในการค านวณระบบตวัเลขท่ีมีบิตมากข้ึน ส าหรับสัญลกัษณ์และตารางความจริงของ 7483  

แสดงดงัรูปท่ี 8.3 และตารางท่ี 8.3 ตามล าดบั 

 

 

 

 

 

 

 

 

 
 

 

 

ขั้นตอนการทดลอง ตอนที ่1 วงจร Half Adder 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_8a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xor, and2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

Comparing Input Output 

C(n-1) An Bn En Cn 

L L L L L 

L L H H L 

L H L H L 

L H H L H 

H L L H L 

H L H L H 

H H L L H 

H H H H H 

รูปท่ี  8.3 ไอซี 7483 ตารางท่ี 8.3 ตารางความจริงของไอซี 7483 
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รูปท่ี 8.4 วงจรส าหรับการทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_8a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_8a.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 
  

   A  

  

   B  

  

   Sum  
  

  Count   
  

รูปท่ี 8.5 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 74 
B 76 

Sum 3 
Cout 1 

ตารางท่ี 8.4 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 
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12. ต่อวงจรตามรูปท่ี 8.6 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 8.6 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี 
LED_D0, LED_D1 จากนั้นบนัทึกผลลงในตาราง 

A 
(SW1) 

B 
(SW0) 

Sum 
(LED D1) 

Count 
(LED D0) 

LOW LOW   
LOW HIGH   
HIGH LOW   
HIGH HIGH   

ตารางท่ี 8.5 ตารางความจริงจากทดลองตอนท่ี 2 

ขั้นตอนการทดลอง ตอนที ่2 วงจร Full Adder 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_8b โดยใช้
เมนู File -> New   Project Wizard  
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2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xor, and2, or2, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 8.7 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_8b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_8b.scf เพื่อจ าลองการท างานของวงจร 

 
รูปท่ี 8.8 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

Name:                100.0ns   200.0ns    300.0ns     400.0ns   500.0ns   600.0ns    700.0ns     800.0ns 
  

   A  

  

   B  

  

   Cin  

  

   Sum  
  

  Count  
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ขาในวงจร ต าแหน่งขาบน FPGA 
A 72 
B 74 

Cin 76 
Sum 3 

Count 1 

ตารางท่ี 8.6 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 8.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 8.9 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี 
LED_D0 และ LED_D1 จากนั้นบนัทึกผลลงในตาราง 
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Cin 
(SW2) 

A 
(SW1) 

B 
(SW0) 

Sum 
(LED D1) 

Count 
(LED D0) 

LOW LOW LOW   
LOW LOW HIGH   
LOW HIGH LOW   
LOW HIGH HIGH   
HIGH LOW LOW   
HIGH LOW HIGH   
HIGH HIGH LOW   
HIGH HIGH HIGH   

ตารางท่ี 8.7 ตารางความจริงจากทดลองตอนท่ี 2 

 

ขั้นตอนการทดลอง ตอนที ่3 วงจร Full Adder 7483 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_8b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 7483, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 8.10 วงจรส าหรับการทดลองตอนท่ี 3 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_8c.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  
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8. สร้างไฟล ์Vector Waveform ในช่ือ lab_8c.scf เพื่อจ าลองการท างานของวงจร 

a. ก าหนดสัญญาณให้เป็นแบบ Count ซ่ึงท าไดโ้ดยการคลิกขวาท่ีช่ือสัญญาณจากนั้นจะมี
เมนู Value -> Count Value… ดงัรูปท่ี 8.11a 

 

รูปท่ี 8.11a ก าหนดค่าในช่อง Radix 

b. ก าหนดค่าในช่อง Radix. ใหเ้ป็น Hexadecimal  ในสัญญาณ A ใหก้ าหนดค่าในช่อง 
Starting Value เป็น 0 และ Increment By มีค่าเท่ากบั 1 ดงัรูปท่ี 8.11b 

 
รูปท่ี 8.11b ก าหนดค่าเร่ิมตน้ใหก้บัสัญญาณ A 
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c. ก าหนดค่าในช่อง Radix ใหเ้ป็น Hexadecimal  ในสัญญาณ B ใหก้ าหนดค่าในช่อง 
Starting Value เป็น 0 และ Increment By มีค่าเท่ากบั F ดงัรูปท่ี 8.11c 

 

รูปท่ี 8.11c ก าหนดค่าเร่ิมตน้ใหก้บัสัญญาณ B 

Name:                                   100.0ns    200.0ns    300.0ns    400.0ns    500.0ns    600.0ns    700.0ns    800.0ns   900.0ns        1.0us 
  

    A[3..0]  
  

    B[3..0]  

  

   Sum[3..0]  

  

  Count  

  

รูปท่ี 8.12 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 

1 3 7 B F 0 2 6 8 F 

F C A

\

8 5 3 5 9 D F 
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ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A0 72 B3 72 
A1 70 Sum0 1 
A2 68 Sum1 3 
S3 66 Sum2 7 
B0 64 Sum3 11 
B1 59 Count 28 
B2 55   

ตารางท่ี 8.8 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 8.13 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 8.13 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1, SW2, SW3, SW4, SW5, Sw6 

และ SW7 แลว้ดูผลทางลอจิก ท่ี LED D0, LED D1, LED D2, LED D3 และ LED 1 จากนั้น
บนัทึกผลลงในตาราง 



140 

B3 
(SW7) 

B2 
(SW6) 

B1 
(SW5) 

B0 
(SW4) 

A3 
(SW3) 

A2 
(SW2) 

A1 
(SW1) 

A0 
(SW0) 

Count 
(LED 1) 

Sum3 
(LED D3) 

Sum2 
(LED D2) 

Sum1 
(LED D1) 

Sum0 
(LED D0) 

0 0 0 0 0 0 0 0      
0 0 0 1 0 0 0 1      
0 0 1 0 0 0 1 0      
0 0 1 1 0 0 1 1      
0 1 0 0 0 1 0 0      
0 1 0 1 0 1 0 1      
0 1 1 0 0 1 1 0      
0 1 1 1 0 1 1 1      
1 0 0 0 1 0 0 0      
1 0 0 1 1 0 0 1      
1 0 1 0 1 0 1 0      
1 0 1 1 1 0 1 1      
1 1 0 0 1 1 0 0      
1 1 0 1 1 1 0 1      
1 1 1 0 1 1 1 0      
1 1 1 1 1 1 1 1      

ตารางท่ี 8.9 ตารางความจริงจากทดลองตอนท่ี 3 

สรุปผลการทดลอง 
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การทดลองที ่9 

วงจรลบเลขฐานสอง (Subtractor) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

2. เพื่อเรียนรู้การท างานของวงจรลบเลขฐานสองแบบ Half Subtractor และ Full 

Subtractor 

3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรลบเลขฐานสองแบบ Half Subtractor 

และ Full Subtractorได ้
4. สามารถดาวน์โหลดวงจรไอซี เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 หลกัการลบในระบบจ านวนใด ๆ หากตวัลบมีค่ามากกวา่ตวัตั้ง ตวัตั้งจะตอ้งมีการยมืจาก
หลกัท่ีสูงกวา่จะท าใหห้ลกัท่ีถูกยมืค่าลดลง ซ่ึงในการสร้างวงจรเลขฐานสองจึงตอ้งมีความเก่ียวขอ้ง
กบัตวัยมืดว้ยเช่นกนั 

 วงจรลบเลขฐานสองแบ่งออกเป็นสองชนิดเช่นเดียวกบัวงจรบวกซ่ึงไดแ้ก่ วงจรลบ
เลขฐานสองแบบ Half Subtractor และแบบ Full Subtractor ซ่ึงวงจรแบบ Half Subtractor จะเป็น
วงจรลบแบบไม่มีการน าตวัยืมท่ีถูกยมืจากหลกัต ่ากวา่มาร่วมค านวณดว้ย และส าหรับวงจรแบบ 
Full Sub tractor จะเป็นวงจรลบท่ีมีการน าตวัยมืท่ีถูกยมืไปของหลกัท่ีต ่ากวา่มาเป็นอินพุทของ
วงจรเพื่อใชร่้วมค านวณดว้ย ซ่ึงวงจรทั้งสองสามารถสร้างข้ึนจากการเขียนตารางความจริงโดยใช้
หลกัการลบเลขฐานสองมาพิจารณา ส าหรับวงจรลบแบบ Half Subtractor สามารถเขียนเป็นตาราง
ความจริงและสร้างเป็นวงจรไดด้งัตารางท่ี  9.1 และรูปท่ี  9.1 
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อนิพุท เอาต์พุท 

A 
(ตัวตั้ง) 

B 
(ตัวลบ) 

D = A - B 
(ผลลบ) 

Bo 
(ตัวยมื) 

หมายเหตุ 

0 0 0 0 0-0 = ยมื 0 
0 1 1 1 0-1 = ยมื 1 
1 0 1 0 1-0 = ยมื 0 
1 1 0 0 1-1 = ยมื 0 

ตารางท่ี 9.1 ตารางความจริงของวงจร Half Subtractor 

B (     )

A (       )
D (    )

Bo (      )

  D   = AB + AB
  Bo = AB

 

รูปท่ี 9.1 วงจร Half subtract 

 ส่วนวงจรลบแบบ Full Sub tractor จะสามารถเขียนเป็นตารางความจริงและวงจรไดต้าราง
ท่ี และรูปท่ี ตามล าดบั จะสังเกตไดอิ้นพุทของวงจร Full Sub tractor จะมีอินพุทของยมืท่ีถูกยมืไป
ของบิตต ่ากวา่มาค านวณดว้ย 
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อนิพุท เอาต์พุท 

A 
(ตัวตั้ง) 

B 
(ตัวลบ) 

Bi 
(ตัวถูกยมืจากบิตต ่ากว่า) 

D = A - B - Bi 
(ผลลบ) 

Bo 
(ตัวยมืจากบิตสูงกว่า) 

หมายเหตุ 

0 0 0 0 0 0-0-0= 0 ยมื 0 
0 0 1 1 1 0-0-1= 1 ยมื 1 
0 1 0 1 1 0-1-0= 0 ยมื 1 
0 1 1 0 1 0-1-1= 0 ยมื 1 
1 0 0 1 0 0-1-1= 0 ยมื 0 
1 0 1 0 0 1-0-1= 0 ยมื 0 
1 1 0 0 0 1-1-0= 0 ยมื 0 
1 1 1 1 1 1-1-1= 1 ยมื 1 

ตารางท่ี 9.2 ตารางความจริงของวงจรจร Full Subtractor 

Half Subtractor

D (    )

Bo 
(                      )

Bi 
(                       )

A (       )

B (     )

                                        
   D   = ABBi + ABBi + ABBi + ABBi
   Bo = AB + ABi + BBi 

                                                     
  Half Subtrator 2                         
   D   = (A      B)      Ci
   Bo = AB + Ci(A        B)

Half Subtractor

 

รูปท่ี 9.2 วงจร Full subtract 

วธีิการลบเลขฐานสองอีกแบบท่ีนิยมใชคื้อการใช ้2’s Complement ซ่ึงมีวธีิการดงัน้ี 

1. เปล่ียนตวัลบใหเ้ป็น 2’s Complement (กลบับิตเป็นตรงกนัขา้มแลว้บวกดว้ย 1 เขา้ท่ีบิต LSB) 

2. น าตวัเลข 2’s Complement ท่ีไดจ้ากขอ้ 1 ไปบวกกบัตวัตั้ง แลว้พิจารณาผลลพัธ์ท่ีไดด้งัน้ี 

 a. ถา้เกิดตวัทดแสดงวา่ ผลลพัธ์ท่ีไดมี้ค่าเป็นบวก และใหต้ดัตวัทดทิ้ง 
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 b. ถา้ไม่เกิดตวัทดแสดงวา่ ผลลพัธ์ท่ีไดเ้ป็นเลขลบ และใหน้ าผลไปแปลงเป็นตวัเลข 2’s 

Complement อีกคร้ัง 

จากวิธีดงักล่าวจะเห็นไดว้า่เป็นการลบท่ีอาศยัการบวก แต่ใช้การแปลงตวัลบและพิจารณาผลลพัธ์
แทน ซ่ึงหลกัการเหล่าน้ีเราสามารถน าไอซี 7483 ซ่ึงเป็นไอซี Full Adder ขนาด 4 บิต มาสร้างเป็น
วงจรลบเลขฐานสองได ้โดยใช ้นอตเกทมาท าให้ตวัลบเป็น 2’s Complement ร่วมกบัขา C0 และ
อาศยั เอ็กซ์คลูซีฟออร์ เกทท่ีเราจะน ามาใชคื้อ ในกรณีท่ีให้อินพทขาใดขาหน่ึงเป็นลอจิกต ่า มนัจะ
ให้เอาต์พุทเหมือนกับอินพุทขาท่ีเหลือ ซ่ึงจากหลักการเราสามารถน ามาใช้ควบคุมให้เกิดการ
เปล่ียนแปลงผลลพัธ์เป็นคอมพรีเมนตห์รือไม่แปลงก็ได ้โดยวงลบแบบใช ้2’s Complement แสดง
ดงัรูปท่ี 9.4 

  

A

B
Y = A     B

 

 

รูปท่ี 9.3 เอก็ซ์คลูซีฟออร์เกท ตารางท่ี 9.3 ตารางความจริงของเอก็ซ์คลูซีฟออร์เกท 

 

รูปท่ี 9.4 วงจรลบท่ีสร้างจากหลกัการ 2’s Complement 

 

 

อนิพุท  เอาต์พุท 
A B Y 
0 0 0 
0 1 1 
1 0 1 
1 1 0 
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ขั้นตอนการทดลอง ตอนที ่1 วงจร Half Subtrator 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_9a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xor, and2, not, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 9.5 วงจรส าหรับการทดลองท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_9a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_9a.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 
  

   A  

  

   B  

  

   Sum  
  

  Count   
  

รูปท่ี 9.6 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 
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11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 74 
B 76 

Diff 3 
Bout 1 

ตารางท่ี 9.4 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 9.7 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 9.7 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิก ท่ี LED D0

และ LED D1 จากนั้นบนัทึกผลลงในตาราง 
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A 
(SW1) 

B 
(SW0) 

Diff 
(LED D1) 

Bout 
(LED D0) 

LOW LOW   
LOW LOW   
HIGH HIGH   
HIGH HIGH   

ตารางท่ี 9.5 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 วงจร Full Subtrator 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_9b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ xor, and2, not, or2, 

input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 9.8 วงจรส าหรับการทดลองท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_9b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_9b.scf เพื่อจ าลองการท างานของวงจร 
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Name:                100.0ns   200.0ns    300.0ns     400.0ns   500.0ns   600.0ns    700.0ns     800.0ns 
  

   A  

  

   B  

  

   Bin  

  

   Diff  
  

  Bout  
  

รูปท่ี 9.9 ผลการจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
A 72 
B 74 

Bin 76 
Diff 3 
Bout 1 

ตารางท่ี 9.6 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 9.10 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 



149 

D7 D6  D5  D4  D3  D2 D1  D0

  

  

  

  

  

  

  

  

  

  

  

  

8     4     2    1

  

  

  

  

  

  
LOGIC

MONITOR

DATABCD

Cyclone III

EP3C10E144C8N

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

    
    

    
    

    
    

    
    

    

    
    

    
    

    
    

    
    

    

FPGA 
UNIT

   SW7   SW6    SW5   SW4

   SW3   SW2    SW1   SW0

   SW3   SW2    SW1   SW0   SW7   SW6    SW5   SW4

SW0

SW1

SW2

SW3

SW4

SW5

SW6

SW7

LOGIC
SWITCH

    

    

    

    

    

    

PIN76

PIN74

PIN1

P
o

rt
_

C

Port_D

P
o

rt
_

A

Port_B

PIN3

PIN72

 

รูปท่ี 9.10 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี 
LED_D0 และ LED_D1 จากนั้นบนัทึกผลลงในตาราง 

A 
(SW2) 

B 
(SW1) 

Bin 
(SW0) 

Diff 
(LED D1) 

Bout 
(LED D0) 

LOW LOW LOW   
LOW LOW HIGH   
LOW HIGH LOW   
LOW HIGH HIGH   
HIGH LOW LOW   
HIGH LOW HIGH   
HIGH HIGH LOW   
HIGH HIGH HIGH   

ตารางท่ี 9.7 ตารางความจริงจากทดลองตอนท่ี 2 
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ขั้นตอนการทดลอง ตอนที ่3 การใช้งานไอซี 7483 เพือ่สร้างเป็นวงจรลบ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_9c โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 7483, xor, not, vcc, 

gnd, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 9.11 วงจรส าหรับการทดลองท่ี 3 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_9c.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_9c.scf เพื่อจ าลองการท างานของวงจร 

Name:                                   100.0ns    200.0ns    300.0ns    400.0ns    500.0ns    600.0ns    700.0ns    800.0ns   900.0ns        1.0us 
  

    A[3..0]  
  

    B[3..0]  

  

   Diff[3..0]  

  

   Sign  

  

รูปท่ี 9.12 ผลการจ าลองการท างาน 
9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

1 3 7 B F 0 2 6 8 F 

F C A 8 5 3 5 9 D F 
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11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A0 72 B3 53 
A1 70 Diff0 1 
A2 68 Diff1 3 
A3 66 Diff2 7 
B0 64 Diff3 11 
B1 59 Sign 28 
B2 55   

ตารางท่ี 9.8 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 9.13 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 9.13 การต่อวงจรบนชุดทดลอง 
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13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2, SW3, SW4, SW5, SW6 

และ SW7 แลว้ดูผลทางลอจิก ท่ี LED D0, LED D1, LED D2, LED D3 และ LED 1 จากนั้น
บนัทึกผลลงในตาราง 

B3 
(SW7) 

B2 
(SW6) 

B1 
(SW5) 

B0 
(SW4) 

A3 
(SW3) 

A2 
(SW2) 

A1 
(SW1) 

A0 
(SW0) 

Count 
(LED 1) 

Sum3 
(LED D3) 

Sum2 
(LED D2) 

Sum1 
(LED D1) 

Sum0 
(LED D0) 

1 1 1 1 0 0 0 0      
1 1 0 1 0 0 1 0      
1 0 1 1 0 1 0 0      
1 0 0 1 0 1 1 0      
1 0 0 0 1 0 0 0      
0 1 1 0 1 0 0 1      
0 1 0 0 1 0 1 1      
0 0 1 0 1 1 0 1      
0 0 0 0 1 1 1 1      

ตารางท่ี 9.9 ตารางความจริงจากทดลองตอนท่ี 3 

สรุปผลการทดลอง 
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การทดลองที ่10 

แลตช์ และ ฟลปิฟลอป (Latch and Flip-flop) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรแลตช์และฟลิปฟลอป 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรแลตช์และฟลิปฟลอปได ้  
 4. สามารถดาวน์โหลดวงจรไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรลอจิกแบ่งออกเป็น 2 ประเภทใหญ่ ๆ ไดแ้ก่ วงจรคอมบิเนชัน่ (Combination) และ 
วงจรซีเควนเชียล (Sequential) โดยท่ีวงจรคอมบิเนชัน่คือวงจรท่ีสร้างข้ึนมาจากเกทชนิดพื้นฐาน
ต่าง ๆ โดยการประยกุตใ์ชส้มการบรูลีน และค่าของระดบัลอจิกเอาตพ์ุทจะข้ึนอยูก่บัค่าปัจจุบนัของ
อินพุทเท่านั้น เช่น วงจรบวกเลขฐานสอง ในขนาดท่ีวงจรซีเคนเชียลจะมีค่าเอาต์พุทข้ึนอยู่กบัค่า
ปัจจุบนัของอินพุทและสถานะเดิมของวงจร เช่น วงจรควบคุมลิฟต์ซ่ึงในการเล่ือนลิฟต์แต่ละคร้ัง
วงจรจะตอ้งน ้าสถานะหรือชั้นท่ีลิฟตจ์อดอยูม่าพิจารณาดว้ยวา่จะตอ้งใหลิ้ฟตข้ึ์นหรือลงก่ีชั้น 

 อุปกรณ์พื้นฐานท่ีน ามาเป็นวงจรซีเควนเชียลคืออุปกรณ์ประเภทหน่วยเก็บขอ้มูล ได้แก่ 
แลตช์ (Latch) และฟลิปฟลอป (Flip-Flop) ซ่ึงทั้งสองมีความแตกต่างกนัท่ีแลตช์ใชร้ะดบัลอจิกใน
การท างาน (Level Sensitive) ส่วนฟลิปฟลอปใชข้อบของสัญญาณในการท างาน (Edge Sensitive) 

 

แลตช์ (Latch) 

 แลตช์ เป็นอุปกรณ์ประเภทไบสเตเบิลมลัติไวเบรเตอร์ (Bistable Multivibrator) ซ่ึง
หมายถึงวงจรท่ีมาค่าเอาต์พุทท่ีเป็นไปไดเ้พียงสองสถานะเท่านั้น นัน่คือสถานะเซท (SET) และ
รีเซท(RESET) ซ่ึงสภาวะท่ีเอาตพ์ุท Q มีค่าเป็น 1 และ Q^ มีค่าเป็น 0 ส่วนสภาวะรีเซท คือสภาวะท่ี
เอาตพ์ุท Q มีค่าเป็น 0 และ Q มีค่าเป็น 1  
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 ตวัอย่างวงจรแลตช์พื้นฐานไดแ้ก่ แลตช์แบบ S-R (Set-Reset) ซ่ึงมีสัญลกัษณ์ดงัรูปท่ี 
10.1a และรูปท่ี 10.1b เป็นวงจรแลตช์แบบ S-R ท่ีสร้างจากนอร์เกต การท างานของมนัจะให้ค่า
เอาตพ์ุทข้ึนกบัอินพุทขา R และ S ดงัตารางท่ี 10.1  

 

        

 

รูปท่ี 10.1a สัญลกัษณ์
ของแลตช์แบบ S-R 

ชนิดแอคทีฟไฮ 

รูปท่ี 10.1b วงจรของแลตช์แบบ  
S-R ชนิดแอคทีฟไฮ 

ตารางท่ี 10.1 ตารางความจริงของแลตช์
แบบ S-R ชนิดแอคทีฟไฮชนิดแอคทีฟไฮ 

วงจรและสัญลกัษณ์ในรูปท่ี 10.1a  และรูปท่ี 10.1b เป็นแลตช์เซท – รีเซทแบบแอคทีฟไฮ 
(Active High) ส่วนแลตช์แบบ เซท-รีเซทชนิดแอคทีฟโลวจ์ะสร้างข้ึนจากแนนด์เกทดงัรูปท่ี 10.2a, 

10.2b และตารางท่ี 10.2 

       

 

รูปท่ี 10.2a สัญลกัษณ์
ของแลตช์แบบ S-R 

ชนิดแอคทีฟโลว ์

รูปท่ี  10.2b วงจรของแลตช์แบบ  
S-R ชนิดแอคทีฟโลว ์

ตารางท่ี 10.2 ตารางความจริงของแลตช์
แบบ S-R ชนิดแอคทีฟไฮชนิดแอคทีฟโลว ์

 

 
 

อนิพุท เอาต์พุท โหมดการ 
ท างาน S R Qt+1 Qt+1 

0 0 Qt Qt ไม่เปล่ียนแปลง 
0 1 0 1 รีเซท 
1 0 1 0 เซท 
1 1 1 1 หา้มใชง้าน 

อนิพุท เอาต์พุท โหมดการ 
ท างาน S R Qt+1 Qt+1 

0 0 1 1 หา้มใช ้
0 1 0 1 เซท 
1 0 1 0 รีเซท 
1 1 Qt Qt ไม่เปล่ียนแปลง 
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แลตช์ชนิด Gated S-R 

 แลตช์ชนิด Gated S-R เป็นแลตท่ี์การเพิ่มชุดลอจิกเกทซ่ึงเรียกวา่ Steering Gate เขา้ไปใน
วงจรแลตช์ S-R เพื่อใชส้ าหรับเปิดปิด การท างานของแลตช์ S-R ซ่ึงตามปกติเม่ืออินพุทของแลตช์ 
S-R มีการเปล่ียนแปลงจะส่งผลให้เอาต์พุทมีการเปล่ียนแปลงทนัท่ี แต่ส าหรับท างานของแลตช์
ชนิด R-S นั่นจะแตกต่างกนั โดยท่ีถ้าหากอินพุทมีการเปล่ียนแปลง สถานของแลตช์จะยงัไม่
เปล่ียนแปลงทนัที แต่จะตอ้งรอสัญญาณควบคุมอีกสัญญาณหน่ึงก่อนเพื่ออนุญาติให้แลตช์เปล่ียน
สภาวะได ้ซ่ึงสัญญาณควบคุมน้ีจะเป็นตวัท่ีไปเปิดการท างานของลอจิกเกทท่ีเพิ่มเขา้ไปนัน่เอง 

 รูปท่ี 10.3a เป็นแลตช์ชนิด Gated S-R ท่ีสร้างจากแลตช์ S-R แบบแอคทีฟไฮ และรูปท่ี 
10.3b เป็นแลตช์ชนิด Gated S-R ท่ีสร้างจากแลตช์ S-R แบบแอคทีฟโลว ์ช่ึงทั้งสองวงจรให้
ผลลพัธ์ท่ีเหมือนกนั และจะท างานต่อเม่ือ สัญญาณท่ีขา E มีค่าเป็นลอจิก 1 เท่านั้น 

                  

รูปท่ี 10.3a การสร้างแลตช์ Gated S-R จาก
แลตช์ชนิดแอคทีฟไฮ 

รูปท่ี 10.3b การสร้างแลตช์ Gated S-R จาก
แลตช์ชนิดแอคทีฟโลว ์

 
 
 
 
 
 

 

 

 

 

 

 
 

อนิพุท เอาต์พุท โหมดการ 
ท างาน E S R Qt+1 Qt+1 

1 0 0 Qt Qt ไม่เปล่ียนแปลง 
1 0 1 0 1 รีเซท 
1 1 0 1 0 เซท 
1 1 1 1 1 หา้มใช ้
0 X X Qt Qt หยดุการท างาน 

รูปท่ี 10.4 สัญลกัษณ์ของแลตช์แบบ Gated S-R ตารางท่ี 10.3 ตารางความจริงของแลตช์แบบ 
Gated S-R 
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แลตช์ชนิด Gated D 

 แลตช์ชนิด Gated D หรือมีช่ืออีกช่ือหน่ึงวา่ Transparent Latch เป็นวงจรท่ีถูกพฒันามา
จาดแลตช์ชนิด Gated S-R เพื่อใชเ้ป็นอุปกรณ์พื้นฐานส าหรับเก็บขอ้มูล การท างานของมนัจะมี 2 
โหมด นัน่คือเม่ือสัญญาณ Enable เป็นลอจิก 1 แลตช์จะมีสภาพเหมือนไม่มีตวัตน (Transparent) 

หรือก็คือสภาพท่ีเอาตพ์ุทมีค่าลอจิกเหมือนกบัทางอินพุทและเม่ือสัญญาณ Enable มีค่าลอจิกเป็น 0 

แลตช์จะอยูใ่นสภาวะเก็บขอ้มูลท่ีปรากฏท่ีขา D ในช่วงท่ีขา Enable มีลอจิกเป็น 1 คร้ังล่าสุด ซ่ึง
โครงสร้างสัญลกัษณ์และ ตารางความจริงของแลตช์ชนิด Gated D แสดงดงัรูป 10.5a, 10.5b และ
ตารางท่ี 10.4 

       

 

รูปท่ี 10.5a การสร้างแลตช์  Gated D 
จากแลตช์ Gated S-R               

      ตารางท่ี 10.4 ตารางความจริงของแลตช์  Gated D 

 
รูปท่ี 10.5b สัญลกัษณ์ของแลตช์  Gated D 

 

ฟลปิฟลอป 

 ฟลิปฟลอปเป็นอุปกรณ์ท่ีท าการเปล่ียนแปลงเอา้ท์พุทท่ีขอบของสัญญาณอินพุทพิเศษท่ี
เรียกว่า สัญญาณนาฬิกา ซ่ึงอาจท างานท่ีขอบขาข้ึนและขอบขาลงของสัญญาณนาฬิกาก็ได ้โดย
สังเกตท่ีสัญลกัษณ์หากมีวงกลมท่ีขาสัญญาณนาฬิกาแสดงวา่ฟลิบฟลอบตวันั้นท างานท่ีขอบขาลง 
และถา้สัญลกัษณ์ของสัญญาณนาฬิกาไม่มีวงกลมแสดงวา่ฟลิปฟลอปตวันั้นท างานท่ีขอบขาข้ึนของ
สัญญาณนาฬิกา  
 เราสามารถกล่าวไดว้า่แลตช์ท่ีมีสัญญาณนาฬิกาดา้นอินพุทก็คือ ฟลิปฟลอปนั้นเอง แต่มนั
จะต่างกนัท่ีแลตช์ใช้สัญญาณ Enable ในการท างาน ซ่ึงมนัจะท างานท่ีสภาวะต่าง ๆ ตลอดเวลาท่ี

อนิพุท เอาต์พุท โหมดการ 
ท างาน 

หมายเหตุ 
 E D Qt+1 Qt+1 

0 X Qt Qt ไม่เปล่ียนแปลง เก็บขอ้มูล 
0 1 0 1 รีเซท ไม่มีตวัตน 

(Transparent) 1 0 1 0 เซท 
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สัญญาณ Enable คงค่าอยู่ใน ลอจิกระดบัใดระดบัหน่ึง แต่ส าหรับฟลิปฟลอปแลว้ มนัจะท างาน
เฉพาะในกรณีท่ีสัญญาณนาฬิกามีการเปล่ียนแปลงเท่านั้น 

 

ฟลปิฟลอปแบบ D 

 ฟลิปฟลอปแบบ D มีลกัษณะการท างานคลา้ยกบัแลตช์แบบ Gated D แต่เอาพุตจะมีการ
เปล่ียนแปลงในกรณีสัญญาณนาฬิกาเปล่ียนแปลงเท่านั้นอาจเป็นขาข้ึนหรือขาลงข้ึนอยูก่บัชนิดของ
การกระตุน้ ฟลิปฟลอป 

 

รูปท่ี 10.6 วงจรฟลิปฟลอป D 

 
 
 

 
 
 
รูปท่ี 10.7 สัญลกัษณ์ของ 

ฟลิปฟลอป D 

ตารางท่ี 10.5 ตารางความจริงของฟลิปฟลอป D 

 

ฟลปิฟลอปแบบ S-R  

 แลตช์ S-R ท่ีใชแ้นนดเ์กทและแลตช์ S-R ท่ีใชน้อร์เกทบา้งคร้ังถูกเรียกวา่ ฟลิปฟลอป S-R 

ซ่ึงถือวา่เป็นส่ิงท่ีผดิเม่ืออา้งอิงจากนิยามของฟลิปฟลอปท่ีกล่าวในท่ีน้ี ทั้งน้ีเน่ืองจากทั้ง 2 วงจร ไม่
มีขาสัญญาณนาฬิกานั้นเอง ในความเป็นจริงแลว้ฟลิปฟลอป S-R จะคลา้ยกบัแลตช์ Gated S-R ท่ี
ใชส้ัญญาณนาฬิกาและวงจรตรวจจบัขอบสัญญาณนาฬิกาเพิ่มเขา้มาแทนสัญญาณ Enable  

อนิพุท เอาต์พุท โหมดการท างาน 
CLK D Qt+1 Qt+1 

 0 0 1 รีเซท 
 1 1 0 เซท 

0 X Qt Qt หยดุการท างาน 
1 X Qt Qt หยดุการท างาน 
 X Qt Qt หยดุการท างาน 
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รูปท่ี 10.8 วงจรฟลิปฟลอป 

 
 
 
 
 
 
 

รูปท่ี 10.9 สัญลกัษณ์ของฟลิปฟลอป 
S-R 

     ตารางท่ี 10.6 ตารางความจริงของฟลิปฟลอป S-R 

 

ฟลปิฟลอป J-K  

 ฟลิปฟลอป J-K เป็นฟลิปฟลอปท่ีพฒันาข้ึนจากฟลิปฟลอป S-R แต่จะมีการแกไ้ขในกรณี
ท่ี S และ R เป็นลอจิก1 ทั้งคู่ ซ่ึงเป็นเง่ือนไขท่ีห้ามใชข้องฟลิปฟลอป S-R โดยในฟลิปฟลอป J-K 
จะใหผ้ลลอจิกเป็นการกลบัลอจิกเอาตพ์ุทใหเ้ป็นตรงกนัขา้มซ่ึงเราเรียกวา่ ทอ็กเกิล (Toggle) 

 

รูปท่ี  10.10 วงจรฟลิปฟลอป J-K 

 
 
 
 

อนิพุท เอาต์พุท โหมดการท างาน 
CLK S R Qt+1 Qt+1 

 0 0 Qt Qt ไม่เปล่ียนแปลง 
 0 1 0 1 รีเซท 
 1 0 1 0 เซท 
 1 1 1 1 หา้มใชง้าน 
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รูปท่ี 10.11 สัญลกัษณ์ของฟลิปฟลอป 
J-K 

ตารางท่ี 10.7 ตารางของของฟลิปฟลอป J-K 

 

ฟลปิฟลอป T  

ฟลิปฟลอป T ซ่ึง T ยอ่มาจาก Toggle เป็นฟลิปฟลอปท่ีสร้างจากฟลิปฟลอป J-K โดยใช้
คุณสมบติัทอ็กเกิลท่ีเกิดข้ึนในฟลิปฟลอป J-K เท่านัน่ ฟลิปฟลอป T จะมีอินพุทเพียงขาเดียวเท่านัน่
โดยเม่ือขา T ถูกกระตุ่นดว้ยสญญาณนาฬิกา มนัจะท าการกลบัค่าเอาต์พุทให้มีลอจิกเป็นตรงกนั
ขา้ม 

 

รูปท่ี 10.12a การสร้างฟลิปฟลอป T จากฟลิป
ฟลอป J-K 

รูปท่ี 10.12b สัญลกัษณ์ของฟลิปฟลอป T 

 
 
 

 
 

ตารางท่ี 10.8 ตารางความจริงของฟลิปฟลอป T 
 

 

 

 

 

อนิพุท เอาต์พุท โหมดการท างาน 
CLK J K Qt+1 Qt+1 

 0 0 Qt Qt ไม่เปล่ียนแปลง 
 0 1 0 1 รีเซท 
 1 0 1 0 เซท 
 1 1 Qt Qt ทอ็กเกิล 

อนิพุท เอาต์พุท โหมดการท างาน 
T Qt+1 Qt+1 

 Qt Qt ทอ็กเกิล 
 Qt Qt ทอ็กเกิล 
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ฟลปิฟลอป T แบบมีสัญญาณนาฬิกา 
ฟลิปฟลอป T ชนิดน้ีเป็นฟลิปฟลอป T ท่ีถูกควบคุมดว้ยสัญญาณนาฬิกา โดยฟลิปฟลอป

จะท าการทอ็กเกิลเอาตพ์ุทในกรณีท่ีอินพุท T มีลอจิกเป็น 1 และมีสัญญาณนาฬิกาเขา้มากระตุน้ท่ีขา 
CLK แต่ในกรณีท่ีค่าลอจิกท่ีขา T มีค่าลอจิก 0 นัน่แมว้า่จะมีสัญญาณนาฬิกาเขา้มากระตุน้ก็ตาม ค่า
ระดบัลอจิกทางเอาตพ์ุทก็ยงัมีค่าไม่เปล่ียนแปลง 

 
 

รูปท่ี 10.13a การสร้างฟลิปฟลอป T แบบมี
สัญญาณนาฬิกาจากฟลิปฟลอป J-K 

รูปท่ี 10.13b สัญลกัษณ์ของ T แบบมีสัญญาณ
นาฬิกา 

 
 
 
 

 
 
 
 

ตารางท่ี 10.9 ตารางความจริงของฟลิปฟลอป 

อนิพุทแบบอะซิงโครนัส (Asynchronous Input) 

 อินพุทของฟลิปฟลอปแบ่งเป็น 2 ชนิด ไดแ้ก่ อินพุทแบบซิงโครนสั (Synchronous Input) 
และอินพุทแบบอะซิงโครนัส (Asynchronous Input) ซ่ึงอินพุทแบบซิงโครนัสคืออินพุทท่ีไม่
สามารถเปล่ียนแปลงค่าลอจิกทางเอาตพ์ุทไดโ้ดยตรง แต่จะตอ้งรอให้มีสัญญาณนาฬิกาป้อนเขา้มา
ก่อน เช่น ขาอินพุท D, J และ K เป็นตน้ 

 อินพุทแบบอะซิงโครนัส คืออินพุทของพลิปฟลอปท่ีสามารถเปล่ียนแปลงค่าลอจิกทาง
เอาตพ์ุทไดท้นัทีโดยไม่จ  าเป็นตอ้งรอสัญญาณนาฬิกาซ่ึงขาเหล่าน่ีไดแ้ก่ ขา Preset และขา Clear ซ่ึง
จะไดก้ล่าวถึงต่อไป 

 ขา Preset คือขาอินพุทแบบอะซิงโครนสัท่ีมีหนา้ท่ีในการเซทเอาตพ์ุทของฟลิปฟลอปให้ 

อนิพุท เอาต์พุท โหมดการท างาน 
CLK T Qt+1 Qt+1 

 0 Qt Qt ไม่เปล่ียนแปลง 
 0 Qt Qt ไม่เปล่ียนแปลง 
 1 Qt Qt ทอ็กเกิล 
 1 Qt Qt ทอ็กเกิล 
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อยูใ่นภาวะเซต (SET) แบบทนัทีทนัใดโดยไม่ตอ้งรอการป้อนสัญญาณนาฬิกา ส่วนขา Clear จะมี
หน้าท่ีในการรีเซท (RESET) สภาวะเอาต์พุทของฟลิปฟลอบแบบทนัทีทนัใดโดยไม่ต้องรอ
สัญญาณนาฬิกาเช่นกนั 

 ขา Clear มีทั้งแบบแอคทีฟไฮและแอคทีฟโลว ์ซ่ึงจะท าให้ผลการท างานท่ีเหมือนกนั แต่
แตกต่างกนัเพียงระดบัลอจิกท่ีป้อนให้โดยถา้เป็นขาแบบแอคทีฟไฮ เราจะตอ้งป้อนลอจิก 1 เพื่อให้
มนัท างาน ส่วนถา้เป็นขาแบบแอคทีฟโลว ์เราจะตอ้งป้อนลอจิก  0 เพื่อใหม้นัท างาน 
 

 

รูปท่ี 10.14 สัญลกัษณ์ของฟลิป
ฟลอป 

ตารางท่ี 10.10 ตารางความจริงของฟลิปฟลอป J-K ท่ีมีขา
อินพุทแบบอะซิงโครนสัในโหมดแอคทีฟโลว ์

 

ขั้นตอนการทดลอง ตอนที ่1 แลตช์ S-R แบบแอคทฟีไฮ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ให้เลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nor2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

 

 

รูปท่ี 10.15 วงจรส าหรับการทดลองตอนท่ี 1 

อนิพุท โหมดการท างาน 
PRE CLR 

1 1 ท างานตามโหมดสัญญาณนาฬิกาปกติ 
0 1 Qt = 1 (SET โดยไม่สนใจสัญญาณ CLK) 
1 0 Qt = 0 (RESET โดยไม่สนใจสัญญาณ CLK) 
0 0 ไม่มีการใชง้านในกรณีน้ี 
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6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10a.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    S  

  

    R  

  

    Q  

  

    Q_NOT  
  

รูปท่ี 10.16 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA 

S 74 
R 76 
Q 3 

Q_NOT 1 

ตารางท่ี 10.11 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.17 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.17 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1แลว้ดูผลทางลอจิก ท่ี LED D0 

และ LED D1 จากนั้นบนัทึกผลลงในตาราง 

S 
(SW1) 

R 
(SW0) 

Q 
(LED D1) 

Q_NOT 
(LED D0) 

LOW LOW   
LOW HIGH   
HIGH LOW   
HIGH HIGH   

ตารางท่ี 10.12 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 แลตช์ S-R แบบแอคทฟีโลว์ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 
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3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nand2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป  

 

รูปท่ี 10.18 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10b.scf เพื่อจ าลองการท างานของวงจร 

Name:                                     100.0ns                200.0ns                300.0ns                 400.0ns 

  

    S_NOT  

  

    R_NOT  

  

    Q  

  

    Q_NOT  
  

รูปท่ี 10.19 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 
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ขาในวงจร ต าแหน่งขาบน FPGA 
S_NOT 74 
R_NOT 76 

Q 3 
Q_NOT 1 

ตารางท่ี 10.13 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.20 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.20 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1แลว้ดูผลทางลอจิก ท่ี LED D0 

และ LED D1 จากนั้นบนัทึกผลลงในตาราง 
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S_NOT 

(SW1) 

R_NOT 

(SW0) 

Q 

(LED D1) 

Q_NOT 

(LED D0) 

LOW LOW   

LOW HIGH   

HIGH LOW   

HIGH HIGH   

ตารางท่ี 10.14 ตารางความจริงจากการทดลองตอนท่ี 2 

ขั้นตอนการทดลอง ตอนที ่3 แลตช์ S-R แบบแอคทฟีโลว์ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nor2, and2, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 10.21 วงจรส าหรับการทดลองตอนท่ี 3 

  

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10c.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10c.scf เพื่อจ าลองการท างานของวงจร 
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Name:               100.0ns    200.0ns    300.0ns     400.0ns   500.0ns   600.0ns    700.0ns     800.0ns 
  

  E  

  

  S  

  

  R  

  

  Q  
  

  Q_NOT  
  

รูปท่ี 10.22 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
S 74 
R 76 
E 72 
Q 3 

Q_NOT 1 

ตารางท่ี 10.15 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.23 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.23 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิก ท่ี 

LED D0 และ LED D1 จากนั้นบนัทึกผลลงในตาราง 

E 

(SW2) 

S 

(SW1) 

R 

(SW0) 

Q 

(LED D1) 

Q_NOT 

(LED D0) 

LOW LOW LOW   

LOW LOW HIGH   

LOW HIGH LOW   

LOW HIGH HIGH   

HIGH LOW LOW   

HIGH LOW HIGH   

HIGH HIGH LOW   

HIGH HIGH HIGH   

ตารางท่ี 10.16 ตารางความจริงจากการทดลองตอนท่ี 3 
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ขั้นตอนการทดลอง ตอนที ่4 แลตช์แบบ Gated S-R ทีส่ร้างจากแลตช์ S-R ชนิดแอคทีฟโลว์ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10d โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nand2, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 10.24 วงจรส าหรับการทดลองตอนท่ี 4 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10d.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10d.scf เพื่อจ าลองการท างานของวงจร 

Name:               100.0ns    200.0ns    300.0ns     400.0ns   500.0ns   600.0ns    700.0ns     800.0ns 
  

  E  

  

  S  

  

  R  

  

  Q  
  

  Q_NOT  
  

รูปท่ี 10.25 ผลจ าลองการท างาน 

 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
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10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 

S 74 

R 76 

E 72 

Q 3 

Q_NOT 1 

ตารางท่ี 10.17 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.26 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.26 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 แลว้ดูผลทางลอจิกท่ี  
LED D0 และ LED D1 จากนั้นบนัทึกผลลงในตาราง 
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E 
(SW2) 

S 
(SW1) 

R 
(SW0) 

Q 
(LED D1) 

Q_NOT 
(LED D0) 

LOW LOW LOW   
LOW LOW HIGH   
LOW HIGH LOW   
LOW HIGH HIGH   
HIGH LOW LOW   
HIGH LOW HIGH   
HIGH HIGH LOW   
HIGH HIGH HIGH   

ตารางท่ี 10.18 ตารางความจริงจากการทดลองตอนท่ี 4 

ขั้นตอนการทดลอง ตอนที ่5 แลตช์แบบ Gated D 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10e โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ nor2, and2, not, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 10.27 วงจรส าหรับการทดลองตอนท่ี 5 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10e.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10e.scf เพื่อจ าลองการท างานของวงจร 
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Name:               100.0ns    200.0ns    300.0ns     400.0ns   500.0ns   600.0ns    700.0ns     800.0ns 

  

  E  

  

  D  

  

  Q  

  

  Q_NOT  

  

รูปท่ี 10.28 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
D 76 
E 74 
Q 3 

Q_NOT 1 

ตารางท่ี 10.19 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.29 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.29 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิก ท่ี LED D0 

และ LED D1 จากนั้นบนัทึกผลลงในตาราง 

E 
(SW1) 

D 
(SW0) 

Q 
(LED D1) 

Q_NOT 
(LED D0) 

LOW LOW   
LOW HIGH   
HIGH LOW   
HIGH HIGH   

ตารางท่ี 10.20 ตารางความจริงจากการทดลองตอนท่ี 5 

ขั้นตอนการทดลอง ตอนที ่6 แลตช์แบบ Gated D และฟลปิฟลอป D 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10f โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 
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3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ latch, dff, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 10.30 วงจรส าหรับการทดลองตอนท่ี 6 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10f.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10f.scf เพื่อจ าลองการท างานของวงจร โดยก าหนด 
Grid Size เป็น 50 ns และในส่วนของสัญญาณ CLK ก าหนดใหเ้ป็นแบบ Clock ซ่ึงท าไดโ้ดยการ
คลิกขวาท่ีช่ือสัญญาณ จากนั้นจะมีเมนู Pop-up ปรากฏข้ึน ใหเ้ลือกท่ีเมนู Value -> Clock… แลว้
ก าหนดค่า Period เป็น 200 ns ดงัรูปท่ี 10.31b จากนั้นจ าลองการท างานและบนัทึกผลการทดลอง 

 

รูปท่ี 10.31a คลิกขวาท่ีสัญญาณเพื่อเรียกเมนู Pop-up รูปท่ี 10.31b ก าหนดคาบของสัญญาณนาฬิกา 
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Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    D  

  

    D_Latch  

  

    D_FF  
  

รูปท่ี 10.32 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 
11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
D 76 

CLK 74 
D_Latch 3 

D_FF 1 

ตารางท่ี 10.21 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.33 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.33 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ SW1 แลว้ดูผลทางลอจิกท่ี LED D0 

และ LED D1 จากนั้นบนัทึกผลลงในตาราง 

CLK 
(SW1) 

D 
(SW0) 

D_Latch 
(LED D1) 

D_FF 
(LED D0) 

LOW LOW   
LOW HIGH   
HIGH HIGH   
HIGH LOW   
LOW LOW   
LOW LOW   
HIGH LOW   
HIGH HIGH   

ตารางท่ี 10.22 ตารางความจริงจากการทดลองตอนท่ี 6 
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ขั้นตอนการทดลอง ตอนที ่7 ฟลปิฟลอปแบบ J-K 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10g โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ jkff, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 10.34 วงจรส าหรับการทดลองตอนท่ี 7 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10g.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10g.scf เพื่อจ าลองการท างานของวงจร 
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Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    PRE_N  

  

    CLR_N  

  

    J  

  

    K  

  

    Q  
  

รูปท่ี 10.35 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA 

CLK 74 
PRE_N 66 
CLR_N 68 

J 70 
K 72 
Q 1 

ตารางท่ี 10.23 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 10.36 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.36 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, SW1, SW2 และ SW3 ท าการกดสวทิช์ 
PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึกผลลงในตาราง 
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PRE_N 
(SW3) 

CLR_N 
(SW2) 

J 
(SW1) 

K 
(SW0) 

CLK 
(PULSEO_Q) 

Q 
(LED D0) 

HIGH HIGH LOW LOW   
HIGH HIGH HIGH LOW   
HIGH HIGH LOW HIGH   
HIGH HIGH HIGH HIGH   
LOW HIGH LOW LOW   
LOW HIGH HIGH LOW   
LOW HIGH LOW HIGH   
LOW HIGH HIGH HIGH   
HIGH LOW LOW LOW   
HIGH LOW HIGH LOW   
HIGH LOW LOW HIGH   
HIGH LOW HIGH HIGH   

ตารางท่ี 10.24 ตารางความจริงจากการทดลองตอนท่ี 7 

 

ขั้นตอนการทดลอง ตอนที ่8 ฟลปิฟลอปแบบ T 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_10h โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ tff, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 10.37 วงจรส าหรับการทดลองตอนท่ี 8 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_10h.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_10h.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    PRE_N  

  

    CLR_N  

  

    T  

  

    Q  
  

รูปท่ี 10.38 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
CLK 74 

PRE_N 68 
CLR_N 70 

T 72 
Q 1 

ตารางท่ี 10.25 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 10.39 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ SW0, SW1 และ SW2 ท าการกดสวิทช์ 
PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0 จากนั้นบนัทึกผลลงในตาราง 
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PRE_N 
(SW2) 

CLR_N 
(SW1) 

T 
(SW0) 

CLK 
(PULSEO_Q) 

Q 
(LED D0) 

HIGH HIGH LOW   
HIGH HIGH HIGH   
HIGH HIGH LOW   
HIGH HIGH HIGH   
LOW HIGH LOW   
LOW HIGH HIGH   
LOW HIGH LOW   
LOW HIGH HIGH   
HIGH LOW LOW   
HIGH LOW HIGH   
HIGH LOW LOW   
HIGH LOW HIGH   

ตารางท่ี 10.26 ตารางความจริงจากการทดลองตอนท่ี 8 

สรุปผลการทดลอง 

 

 

 

 

 

 

 

 

 

 

 

 

 



184 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



185 

การทดลองที ่11 

วงจรนับแบบอะซิงโครนัส(Asynchrononous Counter) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรนบัแบบอะซิงโครนสั 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรนบัแบบอะซิงโครนสัได ้
อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
วงจรนับในระบบดิจิตอลแบ่งเป็น 2 ชนิด ได้แก่วงจรนับแบบอะซิงโครนัส 

(Asynchronous Counter) ซ่ึงในการทดลองน้ีเราจะเป็นการศึกษาเฉพาะในส่วนของวงจรนับ
แบบอะซิงโครนสั เท่านั้น ส่วนวงจรนบัแบบซิงโครนสัจะไดศึ้กษาในการทดลองถดัไป  
 วงจรนบัแบบแบบอะซิงโครนสัเป็นวงจรท่ีประกอยข้ึนจากการน าฟลิปฟลอบมาต่ออนุกรม
กนัโดยสัญาณนาฬิกาจะถูกป้อนเขา้ไปท่ีฟลิปฟลอปตวัแรกเพียงตวัเดียวเท่านัน่ และเอาตพ์ุทของฟ
ลิปฟลอปแต่ละตวัจะถูกป้อนเป็นสัญญาณนาฬิกาให้ฟลิปฟลอปตวัถดัไป ฟลิปฟลอปแต่ละตวัจะ
ถูกกระตุน้ไม่พร้อมกนัโดยจะท างานไล่มาจากตวัแรกและส่งต่อการกระตุน้ไปยงัฟลิแฟลอปตวั
ถดัไป ส าหรับจ านวนฟลิปฟลอปท่ีตอ้งใช้ในวงจรจะมีจ านวนบิตของเลขท่ีตอ้งการนับ เช่น ถ้า
ตอ้งการนบัเลขฐาน 2 ขานด 3 บิต นบัไดต้ั้งแต่ 0 (000) ถึง 7 (111) เราตอ้งใชฟ้ลิปฟลอบจ านวน 3 

ตวัมาต่ออนุกรมกนั 

 

รูปท่ี 11.1 วงจรนบัอะซิงโครนสัขนาด 3 บิต แบบนบัข้ึน 
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รูปท่ี 11.2 รูปคล่ืนสัญญาณของวงจรนบัอะซิงโครนสั 3 บิต แบบนบัข้ึน 

 จากรูปท่ี เป็นวงจรนบัข้ึนโดยใชฟ้ลิปฟลอป J-K ชนิดแอคทีฟโลว ์ซ่ึงเราสามารถดดัแปลง
เป็นวงจรนบัลงไดด้งัรูปท่ี 11.3 ส่วนในรูปท่ี 11.4 และ 11.5 เป็นวงจรนบัอะซิงโครนสัแบบใขฟ้ลิป
ฟลอป J-K ชนิดแอคทีฟไฮ ซ่ึงจะสังเกตไดว้า่มีลกัษณะการต่อตรงกนัขา้มกบัการใชฟ้ลิปฟลอป J-

K ชนิดแอคทีฟโลว ์

 
รูปท่ี 11.3 วงจรนบัอะซิงโครนสัขนาด 3 บิต แบบนบัลง 

 
รูปท่ี 11.4 วงจรนบัอะซิงโครนสัขนาด 3 บิต แบบนบัข้ึน โดยใชฟ้ลิปฟลอบ J-K แบบแอคทีฟไฮ 
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รูปท่ี 11.5 วงจรนบัอะซิงโครนสัขนาด 3 บิต แบบนบัลง โดยใชฟ้ลิปฟลอบ J-K แบบแอคทีฟไฮ 

 เน่ืองจากการท างานฟลิปฟลอปแต่ละตวัจะเป็นการกระตุน้จากฟลิปฟลอปตวัท่ีอยู่ก่อน
หน้ามนั ดังนั้ นในการใช้งานจริงจะเกิดปัญหาจากค่าความหน่วงเวลาภายในของฟลิปฟลอป 
(Propagation Delay) ยิ่งในวงจรนับมีการใช้ฟลิปฟลอปมากเท่าใด ค่าความหน่างเวลาน้ีจะถูก
สะสมมากข้ึนเท่านั้น ซ่ึงค่าความหน่วงสะสมน้ีจะตอ้งไม่มากเกินคาบเวลาของสัญญาณนาฬิกา จาก
สาเหตุน้ีเองจึงท าให้วงจรนนัอะซิงโครนัสไม่สามารถน ามาใช้กบัการนบัท่ีมีจ  านวนบิตมาก ๆ ท่ี
ความถ่ีสูงได ้

 
รูปท่ี 11.6 ค่าความเวลาในฟลิปฟลอปท่ีมีผลต่อการท างานของวงจรอะซิงโครนสั 
 

ขั้นตอนการทดลอง ตอนที ่1 วงจรนับอะซิงโครนัส แบบนับลง 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_11a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ jkff, vcc, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 11.7 วงจรส าหรับการทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_11a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_11a.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 11.8 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation เสร็จแลว้ให้ ซูมเพื่อดูค่าความหน่วงเวลา
ของฟลิปฟลอปในหนา้ต่าง Vector Waveform โดยใชเ้มนู Viwe -> Zoom In เสร็จแลว้บนัทึกผล
การทดลอง 
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รูปท่ี 11.9 ผลการจ าลองการท างาน 

10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA 

CLK 74 
A 1 
B 3 
C 7 
D 11 

ตารางท่ี 11.1 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 11.10 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

Name:                                                  50.0ns                      100.0ns                      150.0ns                      200.0ns      

  

     CLK  

  

    D  

  

    C  

  

    B  

  

    A  
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รูปท่ี 11.10 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยท าการกดสวทิช์ PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED 

D2 และ LED D3 จากนั้นบนัทึกผลลงในตาราง 
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CLK 
(PULSEO_Q) 

D 
(LED D3) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

     
     
     
     
     
     

     
     
     

     
     
     

ตารางท่ี 11.2 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 วงจรนับอะซิงโครนัส แบบนับขึน้ 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_11b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ jkff, not, vcc, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 11.11 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_11b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_11b.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 11.12 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation เสร็จแลว้ให ้ซูมเพื่อดูค่าความหน่วงเวลา
ของฟลิปฟลอปในหนา้ต่าง Vector Waveform โดยใชเ้มนู Viwe -> Zoom In เสร็จแลว้บนัทึกผล
การทดลอง 

 
 
 
 



193 

Name:                                                  50.0ns                      100.0ns                      150.0ns                      200.0ns      

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 11.13 ผลการจ าลองการท างาน 

10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 

ขาในวงจร ต าแหน่งขาบน FPGA 
CLK 74 

A 1 
B 3 
C 7 
D 11 

ตารางท่ี 11.3 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 11.14 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 11.14 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยท าการกดสวทิช์ PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED 

D2 และ LED D3 จากนั้นบนัทึกผลลงในตาราง 
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ตารางท่ี 11.4 ตารางความจริงจากการทดลองตอนท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่12 

วงจรนับแบบซิงโครนัส (Synchrononous Counter) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรนบัแบบซิงโครนสั 

 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรนบัแบบซิงโครนสัได ้
อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรนบัแบบซิงโครนสั (Syncronous Counter) สร้างข้ึนจากฟลิปฟลอปเช่นเดียวกนักบั
วงจรอะซิงโครนสั แต่สัญญาณนาฬิกาจะถูกป้อนเขา้ท่ีฟลิปฟลอปทุกตวัโดยตรง ซ่ึงฟลิปฟลอปทุก
ตวัจะจะท างานได้พร้อมกนัโดยไม่เกิดปัญหาค่าหน่วงเวลาสะสมแบบวงจรอะซิงโครนสั ดงันั้น
วงจรนับชนิดน้ีจึงสามารถน าไปใช้งานท่ีความถ่ีสูง ๆ ได้ จากลักษณะการต่อวงจรท่ีมีสัญญาณ
นาฬิกาต่อเขา้ท่ีฟลิปฟลอปทุกตวัจึงท าให้บางคร้ังเราเรียกวงจรจรนบัชนิดน้ีวา่วงจรนบัแบบขนาน 
(Parallel Counter) 

 ขั้นตอนการออกแบบวงจรนับซิงโครนัสเร่ิมจากการเขียนสเตรทไดอะแกรม (State 

Diagram) แลว้ใชต้ารางเอ็กซ์ไซทช์ัน่ (Excitaion Table) สร้างตารางความจริง จากนั้นน าตาราง
ความจริงไปท าการลดรูปและสร้างเป็นลอจิก  
 ส าหรับตารางเอก็ซ์ไซดเ์ทชัน่ของ J-K ฟลิปฟลิปโดยท่ี X คือค่า Don’ Care หมายถึงลอจิก
เป็น 0 หรือ 1 ก็ได ้
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ตารางท่ี 12.1 ตารางความจริงของ JK  

ฟลิปฟลอป 
ตารางท่ี 12.2 ตารางเอก็ไซทเ์ทชัน่ของ JK  

ฟลิปฟลอป 

ตารางเอก็ซ์ไซทเ์ทชัน่สร้างมาจากการสังเกตตารางความจริงดงัน้ี 

1. ถา้เอาตพ์ุท Q เปล่ียนค่าจาก 0 เป็น 0 เหตุการณ์น้ีจะเกิดข้ึนจาก 2 กรณีคือ 

 1.1 กรณีท่ี J เป็น 0 และ K เป็น 0 (คงสถานะไม่เปล่ียนแปลง) 

1.2 กรณีท่ี J เป็น 0 และ K เป็น 1  

2. ถา้เอาตพ์ุท Q เปล่ียนค่าจาก 0 เป็น 1 เหตุการณ์น้ีจะเกิดข้ึนจาก 2 กรณีคือ 

 2.1 กรณีท่ี J เป็น 1 และ K เป็น 0  

2.2 กรณีท่ี J เป็น 1 และ K เป็น 1 (ทอ็กเกิลกลบัสถานะ) 

3. ถา้เอาตพ์ุท Q เปล่ียนค่าจาก 1 เป็น 0 เหตุการณ์น้ีจะเกิดข้ึนจาก 2 กรณีคือ 

 3.1 กรณีท่ี J เป็น 0 และ K เป็น 1  

3.2 กรณีท่ี J เป็น 1 และ K เป็น 1 (ทอ็กเกิลกลบัสถานะ) 

4. ถา้เอาตพ์ุท Q เปล่ียนค่าจาก 1 เป็น 1 เหตุการณ์น้ีจะเกิดข้ึนจาก 2 กรณีคือ 

 2.1 กรณีท่ี J เป็น 1 และ K เป็น 0 (คงสถานะไม่เปล่ียนแปลง) 

2.2 กรณีท่ี J เป็น 1 และ K เป็น 0  

ตวัอยา่งขั้นตอนการออกแบบวงจรนบัซิงโครนสั 3 บิตโดยใช ้J-K ฟลิปฟลอปสามารถท าไดด้งัน้ี 

1. เขียนสเตทไดอะแกรมดงัรูปท่ี 12.1 เพื่อดูขั้นตอนการเปล่ียนแปลงสภาวะเอาตพ์ุท 

อนิพุท เอาต์พุท โหมดการท างาน 

J K Qt+1 

0 0 Qt ไม่เปล่ียนแปลง 
0 1 0 รีเซท 
1 0 1 เซท 
1 1 Qt ทอ็กเกิล 

เอาต์พุท อนิพุท 
Qt Qt+1 J K 
0 0 0 X 
0 1 1 X 
1 0 X 1 
1 1 X 0 
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รูปท่ี 12.1 สเตทไดอะแกรมของวงจรนบัซิงโครนสั 

2. เขียนตารางความจริงโดยใชต้ารางเอก็ซ์ไซทเ์ทชัน่ 

สถานะปัจจุบันของเอาต์พุท สถานะต่อไปของเอาต์พุท อนิพุทของฟลิปฟลอป 

Q2 Q1 Q0 Q2 Q1 Q0 J2 K2 J1 K1 J0 K0 

0 0 0 0 0 1 0 X 0 X 1 X 
0 0 1 0 1 0 0 X 1 X X 1 
0 1 0 0 1 1 0 X X 0 1 X 
0 1 1 1 0 0 1 X X 1 X 1 
1 0 0 1 0 1 X 0 0 X 1 X 
1 0 1 1 1 0 X 0 1 X X 1 
1 1 0 1 1 1 X 0 X 0 1 X 
1 1 1 0 0 0 X 1 X 1 X 1 

ตารางท่ี 12.3 ตารางความจริงของวงจรนบัซิงโครนสั 3 บิต แบบใชฟ้ลิปฟลอบ JK 
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3. ลดรูปวงจรลอจิกจากตารางความจริง 

 

รูปท่ี 12.2 K – Map ของวงจรนบัซิงโครนสั 3 บิต แบบใชฟ้ลิปฟลอป JK 

จาก K-Map เราสามารถเขียนสมการลอจิกไดด้งัน้ี 

J2 = Q1Q0 K2 = Q1Q0 

J1 = Q0 K1 = Q0 

J0 = 1 K0 = 1 

4. สร้างวงจรโดยเช่ือมต่อขา CLK ของฟลิปฟลอปทุกตวัเขา้ดว้ยกนั จากนั้นน าสมการท่ีไดม้าสร้าง
เป็นวงจรลอจิกทางดา้นอินพุทของฟลิปฟลอปแต่ละตวั 
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รูปท่ี 12.3 วงจรนบัอะซิงโครนสัขนาด 3 บิต 

 นอกจากการใช ้J-K ฟลิปฟลอป มาสร้างเป็นวงจรนบัซิงโครนสัแลว้ยงัสามารถน าฟลิป
ฟลอป D มาใชเ้ช่นกนั ซ่ึงขั้นตอนการออกแบบจะเป็นเช่นเดียวกบัการใช ้J-K ฟลิปฟลอปแต่จะใช้
ตารางเอก็ซ์ไซทเ์ทชัน่ของ D ฟลิปฟลอปดงัตารางท่ี 12.5 

 
 
 
 
 

ตารางท่ี 12.4 ตารางความจริงของ J-K ตารางท่ี 12.5 ตารางเอก็ซ์ไซทเ์ทชัน่ของ J-K ฟลิปฟลอป 

ตวัอยา่งขั้นตอนการออกแบบวงจนนบัซิงโครนสั 3 บิตโดยใช ้D ฟลิปฟลอปสามารถท าไดด้งัน้ี 

1. เขียนสเตทไดอะแกรมดงัรูปท่ี 12.1 เพื่อดูขั้นตอนการเปล่ียนแปลงสภาวะเอาตพ์ุท 

2. เขียนตารางความจริงโดยใชต้ารางเอก็ซ์ไซทเ์ทชัน่ 

 

 

 

 

 

เอาต์พุท อนิพุท 
Qt Qt+1 D 

0 0 0 
0 1 1 
1 0 0 
1 1 1 

อนิพุท เอาต์พุท โหมดการท างาน 
D Qt+1 

0 Qt รีเซท 
1 0 เซท 
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สถานะปัจจุบันของเอาต์พุท สถานะต่อไปของเอาต์พุท อนิพุทของฟลิปฟลอป 

Q2 Q1 Q0 Q2 Q1 Q0 D2 D1 D0 
0 0 0 0 0 1 0 0 1 
0 0 1 0 1 0 0 1 0 
0 1 0 0 1 1 0 1 1 
0 1 1 1 0 0 1 0 0 
1 0 0 1 0 1 1 0 1 
1 0 1 1 1 0 1 1 0 
1 1 0 1 1 1 1 1 1 
1 1 1 0 0 0 0 0 0 

ตารางท่ี 12.6 ตารางความจริง 

3. ลดรูปวงจรลอจิกจากตารางความจริง 

 
 
 
 

 
 

 
 
 
 

 
รูปท่ี 12.4 K – Map ของวงจรนบัซิงโครนสั 3 บิต แบบใชฟ้ลิปฟลอป D 

จาก K-Map เราสามารถเขียนสมการลอจิกไดด้งัน้ี 

D2 = Q2Q1Q0 + Q2Q0 + Q2Q1 

D1 = Q1Q0 + Q1Q0 = Q1  Q0 
D0 = Q0 
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     Q2          
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4. สร้างวงจรโดยเช่ือมต่อขา CLK ของฟลิปฟลอปทุกตวัเขา้ดว้ยกนั จากนั้นน าสมการท่ีไดม้าสร้าง
เป็นวงจรลอจิกทางดา้นอินพุทของฟลิปฟลอปแต่ละตวั 

 

รูปท่ี 12.5 วงจรนบัอะซิงโครนสัขนาด 3 บิต แบบนบัข้ึน 

ขั้นตอนการทดลอง ตอนที ่1 วงจรนับซิงโครนัส 3 บิต แบบใช้ JK ฟลปิฟลอป 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_12a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ jkff, and2, vcc, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
 

รูปท่ี 12.6 วงจรส าหรับการทดลองตอนท่ี 1 
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6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_12a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_12a.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 12.7 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation เสร็จแลว้ให้ ซูมเพื่อดูค่าความหน่วงเวลา
ของฟลิปฟลอปในหนา้ต่าง Vector Waveform โดยใชเ้มนู Viwe -> Zoom In เสร็จแลว้บนัทึกผล
การทดลอง 

Name:                                                  50.0ns                      100.0ns                      150.0ns                      200.0ns      

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 12.8 ผลการจ าลองการท างาน 

10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 
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ขาในวงจร ต าแหน่งขาบน FPGA 
CLK 74 

A 1 
B 3 
C 7 

ตารางท่ี 12.7 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 12.9 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

  
  

  
  

Q

Q

Q

Q

PULSE0

PULSE1

PULSE 
SWITCH

D7 D6  D5  D4  D3  D2 D1  D0

  

  

  

  

  

  

  

  

  

  

  

  

8     4     2    1

  

  

  

  

  

  
LOGIC

MONITOR

DATABCD

Cyclone III

EP3C10E144C8N

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

  
  

    
    

    
    

    
    

    
    

    

    
    

    
    

    
    

    
    

    

FPGA 
UNIT

PIN74

PIN1

P
o

rt
_C

Port_D

P
o

rt
_A

Port_B

PIN7

 

รูปท่ี 12.9 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยท าการกดสวิทช์ PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0, LED D1 และ 
LED D2 จากนั้นบนัทึกผลลงในตาราง 
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CLK 

(PULSEO_Q) 

C 

(LED D2) 

B 

(LED D1) 

A 

(LED D0) 

    

    

    

    

    

    

    

    

    

    

    

    

ตารางท่ี 12.8 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 วงจรนับซิงโครนัส 3 บิต แบบใช้ D ฟลปิฟลอป 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_12b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ dff, and2, and3, xor, 

or3, not, vcc, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 



207 

 

รูปท่ี 12.10 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_12b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_12b.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 12.11 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation เสร็จแลว้ให้ ซูมเพื่อดูค่าความหน่วงเวลา
ของฟลิปฟลอปในหนา้ต่าง Vector Waveform โดยใชเ้มนู Viwe -> Zoom In เสร็จแลว้บนัทึกผล
การทดลอง 
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Name:                                                  50.0ns                      100.0ns                      150.0ns                      200.0ns      

  

     CLK  

  

    D  
  

    C  

  

    B  
  

    A  
  

รูปท่ี 12.12 ผลการจ าลองการท างาน 

10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA 
CLK 74 

A 1 
B 3 
C 7 

ตารางท่ี 12.9 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 12.13 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 12.13 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวิตช์ PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0, 

LED D1 และ LED D2 จากนั้นบนัทึกผลลงในตาราง 
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CLK 
(PULSEO_Q) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

    
    
    
    
    
    

    
    
    

    
    
    

ตารางท่ี 12.10 ตารางความจริงจากการทดลองตอนท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่13 

วงจรนับรูปแบบไอซีส าเร็จรูป 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรนบัท่ีอยูใ่นไอซีส าเร็จรูป 
 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรนบัท่ีอยูใ่นไอซีส าเร็จรูปได ้

 4. สามารถดาวน์โหลดวงจรลงไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้
อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
จากการทดลองท่ีผา่นมาเป็นการศึกษาถึงหลงัการท างานพื้นฐานของวงจรนบัอะซิงโครนสั 

และวงจรนับซิงโครนัส ส าหรับการทดลองในบทน้ีจะเป็นการศึกษาทดลองไอซีท่ีท าหน้าท่ีเป็น
วงจรนบัแบบอะซิงโครนสัซ่ึงไดแ้ก่ เบอร์ 7493 และวงจรนบัแบบซิงโครนสัเบอร์ 74190   

 ไอซีเบอร์ 7493 เป็นไอซีนบัเลขฐานสองขนาด 4 บิตแบบอะซิงโครนสั มีโครงสร้างดงัรูป
ท่ี 13.1 ซ่ึงภายในประกอบไปด้วยปลิฟฟลอป 4 ตวั และมีการแบ่งวงจรภายในออกเป็น 2 ส่วน
ไดแ้ก่วงจรนบัแบบโมดูโล 2 (Modulo 2 : MOD-2)ซ่ึงมีเอาทพ์ุตออกท่ีขา QA และวงจรนบัโมดูโล 
8 (MOD-8) ซ่ึงมีเอาทพ์ุตออกท่ีขา QB, QC และ QD ในใชเ้ราสามารถเลือกใชเ้พียงวงจรใดวงจร
หน่ึงก็ได ้แต่หากตอ้งการใช้งานเป็นวงจรนับ 4 บิตก็สามารถท าได้โดยการต่อขา QA เขา้กบั 
INPUT  B เพื่อเช่ือมต่อสัญญาณนาฬิกาจากวงจรนบั MOD-2  เขา้กบัวงจรนบั MOD-8 

 

รูปท่ี13.1 วงจรภายในไอซี 7493 
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นับ เอาต์พุท 

QD QC QB QA 

0 L L L L 

1 L L L H 

2 L L H L 

3 L L H H 

4 L H L L 

5 L H L H 

6 L H H L 

7 L H H H 

 

ตารางท่ี 13.1 ตารางความจริงการนบัของไอซี 7493 

เอาต์พุท อนิพุท 
RO(1) RO(2) QD QC QB QA 

H H L L L L 

L X COUNT 

X L COUNT 

ตารางท่ี 13.2 ตารางความจริงของฟังกช์ัน่การรีเซทวงจรนบัของไอซี 7493 

ไอซีเบอร์ 7493 มีแนนด์เกทอยูภ่ายในส าหรับสร้างวงจรรีเซทเพื่อใชส้ร้างวงจรนบัโมดูโล
แบบอ่ืนๆ เช่น วงจรนบัแบบ MOD-10  ซ่ึงสามารถแสดงดงัรูปท่ี 13.2 การนบัของวงจรนบั MOD-

10 นั้นจะเร่ิมตน้นบัจาก 0 (0000) ไปจนถึง 9(1001) และเม่ือวงจรนบัมาถึงค่าถดัไปคือ 10(1010) 

เราจะตอ้งน าค่าลอจิกของเอาตพ์ุทในขณะน้ีไปรีเซทวงจรนบัเพื่อให้มนักลบัไปเร่ิมตน้เป็นค่า 0000 

ใหม่อีกคร้ัง จากตารางท่ี 13.2 จะเห็นไดว้า่เราจะตอ้งเลือกบิตท่ีเป็น 1 มาท าเป็นสัญญาณรีเซท ซ่ึง
ในกรณีน้ีตอ้งใช้บิต 3 และบิต 1 (จาก 1010) มาต่อเขา้ท่ีขา R0(1) และ R0(2) เพื่อสร้างเป็น
สัญญาณรีเซท 

ไอซีน้ีท าหนา้ท่ีเป็นวงจรนบัอีกตวัหน่ึงท่ีจะศึกษาในการทดลองน้ีคือ ไอซีเบอร์ 74190 ซ่ึง
เป็นไอซีวงจรนบั BCD (BCD Counter) โดยมีวงจรภายในเป็นวงจรนบัแบบซิงโครนสั สามารถ
เซทให้นบัข้ึน-ลงไดโ้ดยการเซทค่าลอจิกท่ีขาอินพุท down/up โดยเม่ือป้อนลอจิก 0 มนัจะท างาน
เป็นวงจรนบัข้ึน และถา้ป้อน 1 มนัจะท างานเป็นวงจรนบัลง 

นับ เอาต์พุท 

QD QC QB QA 

8 H L L L 

9 H L L H 

10 H L H L 

11 H L H H 

12 H H L L 

13 H H L H 

14 H H H L 

15 H H H H 
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รูปท่ี 13.3 ไอซี 74190 

ไอซีตวัน้ีสามารถเลือกจดัการท างานไดทุ้กอยา่ง นัน่คือ เราสามารถเซทใหเ้อาตพ์ุทไดโ้ดย
การป้อนลอจิก 0 เขา้ไปท่ีขา LOAD และใส่ค่าเอาตพ์ุทท่ีตอ้งการเขา้ทางขาอินพุท DATA (A,B,C 

และ D) ซ่ึงจะท าใหค้่าทางเอาตพ์ุทเปล่ียนแปลงทนัทีโดยไม่ตอ้งรอสัญญาณนาฬิกา 
 นอกจากน้ียงัมีขาเอาตพ์ุท 2 ขา ส าหรับใชเ้ช่ือมต่อเพื่อเพิ่มจ านวนหลกัในการนบั 
(Cascade) ไดแ้ก่ขา Ripple Clock และ MAX/MIN  Count โดยท่ีขา MAX/MIN จะผลิตสัญญาณ
พลัลท่ี์จะมีค่าเป็นลอจิก 1 มีช่วงเวลาเท่ากบัสัญญาณนาฬิกา 1 ลูก เม่ือการนบัมาถึงค่าสูงสุดในกรณี
นบัข้ึน และเม่ือการนบัมาถึงค่าต ่าสุดในกรณีนบัลง ส่วนขา  Ripple Clock จะผลิตสัญญาณพลัลท่ี์มี
ลอจิก 0 ในช่วงเลาเท่ากบัส่วนของสัญญาณนาฬิกาท่ีเป็นลอจิก 0 เม่ือการนบัมาถึงค่าสูงสุดในกรณี
นบัข้ึน และเม่ือมีการนบัมาถึงค่าต ่าสุดในกรณีนบัลง ในการต่อเพิ่มไอซีเพื่อใหใ้นการนบัไดจ้  านวน
หลกัท่ีมากข้ึน เราสามารถน าขาเอาตพ์ุท Ripple Clock น้ีไปเช่ือมต่อกบัขา Enable ของไอซีตวั
ถดัไปในกรณีท่ีต่อขาสัญญาณนาฬิการ่วมกนั หรืออาจต่อขา Ripple Clock ไปท่ีขา Clock ของไอซี
ตวัถดัไปในกรณีท่ีไอซีแต่ละตวัต่อขา Enable ร่วมกนัก็ได ้
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รูปท่ี 13.4 วงจรภายในของไอซี 74190 

 

รูปท่ี 13.5 รูปแบการท างานของไอซี 74190 

VCCLDN INPUT

GNDD INPUT

GNDC INPUT

GNDB INPUT

GNDGN INPUT

GNDA INPUT

VCCDNUP INPUT

GNDCLK INPUT

RCONOUTPUT

MXMNOUTPUT

QAOUTPUT

QBOUTPUT

QCOUTPUT

QDOUTPUT

NAND3

57

NAND3

58

OR3

59

AND3

60

AND3

61

AND3

62

AND3

63

AND3

64

CLRN

D
PRN

Q

DFF

51

CLRN

D
PRN

Q

DFF

50

CLRN

D
PRN

Q

DFF

49

CLRN

D
PRN

Q

DFF

48

XOR

47

XOR

46

XOR

45

XOR

44

OR2

43

OR2

42

OR2

41

AND4

40

AND4

39

AND4

38

NOT

37

NOT

36

NOT

35

NOT

34

NOT

33

NOT

32

NOT

31

NOT

30

NOT

29

NAND2

26

NAND2

25

NAND2

24

NAND2

23

NAND2

22

NAND2

21

NAND2

20

NAND2

19

BAND2

13

BAND2

12

AND6

3

74190

TITLE
MacroFunction

COMPANY
ALTERA CORPORATION

DESIGNER
Applications Engineering

NUMBER 1.00 REV A

DATE
Tue May 18 16:26:25 1999

SHEET
1

OF
1



215 

 

ขั้นตอนการทดลอง ตอนที ่1 การใช้งานไอซี 7493 เป็นวงจรนับ MOD-10 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_13a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 7493, input และ 
output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
รูปท่ี 13.6 วงจรส าหรับการทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_13a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_13a.scf โดยตั้งค่า Grid Size เท่ากบั 50ns เพื่อจ าลอง
การท างานของวงจร 

 
รูปท่ี 13.7 ผลจ าลองการท างาน 
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9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA 

CLK 74 
A 1 
B 3 
C 7 
D 11 

ตารางท่ี 13.3 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 13.8 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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 รูปท่ี 13.8 การต่อวงจรบนชุดทดลอง  

13. ทดสอบวงจรโดยท าการกดสวทิช์ PULSEO_Q แลว้ดูผลทางลอจิกท่ี LED D0, LED D1 และ 
LED D2 จากนั้นบนัทึกผลลงในตาราง 
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CLK 
(PULSEO_Q) 

D 
(LED D3) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

     
     
     
     
     
     

     
     
     

     
     
     

ตารางท่ี 13.4 ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 การใช้งานไอซี 74190 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_13b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74190, vcc, gnd, 

input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 13.9 วงจรส าหรับการทดลองตอนท่ี 2 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_13b.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_13b.scf โดยตั้งค่า Grid Size เท่ากบั 50ns เพื่อจ าลอง
การท างานของวงจร 

 

รูปท่ี 13.10 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. เพิ่มวงจรถอดรหสั 7447 เพื่อแปลงรหสั BCD ใหก้ลายเป็นตวัเลขดงัรูป 
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รูปท่ี 13.11 วงจรส าหรับการทดลองตอนท่ี 2 

10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
CLK 72 Seg_c 7 
DnUp 74 Seg_d 11 
MxMn 111 Seg_e 28 
Rcon 113 Seg_f 31 
Seg_a 1 Seg_g 33 
Seg_b 3   

ตารางท่ี 3.5 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 13.12 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0 และ ท าการกดสวทิช์ PULSEO_Q แลว้ดู
ผลทางลอจิกท่ี LED D0, LED D1 และ SEVENT SEGMENT DIGIT A จากนั้นบนัทึกผลลงใน
ตาราง 
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DnUp 
(SW0) 

CLK 
(PULSEO_Q) 
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รูปแบบ LED บน 
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DnUp 
(SW0) 

CLK 
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C 
(LED D2) 

B 
(LED D1) 

รูปแบบ LED บน 
SEVENT 

SEGMENT 
1     
1     
1     

ตารางท่ี 3.6 ตารางความจริงจากการทดลองตอนท่ี 2 

สรุปผลการทดลอง 
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การทดลองที ่14 

วงจรเลือ่นข้อมูล (Shift Register) 

วตัถุประสงค์ 

1. เรียนรู้การใชง้านโปรแกรม Quartus II 8.1 Web Edition ในการสร้างแผนผงัวงจร
ดิจิตอล สร้างรูปคล่ืน คอมไพล ์และจ าลอง การทงานของวงจร 

 2. เพื่อเรียนรู้การท างานของวงจรวงจรเล่ือนขอ้มูล 
 3. วเิคราะห์รูปคล่ืน สร้างตารางความจริงจากวงจรวงจรเล่ือนขอ้มูลได ้

 4. สามารถดาวน์โหลดวงจรลงไอซี FPGA เพื่อทดสอบการท างานจริงของวงจรได ้

อุปกรณ์ส าหรับการทดลอง 

 1. ชุดทดลองการเรียนรู้เทคโนโลยไีอซี FPGA 

 2. สาย USB Blaster  

 3. สายไฟส าหรับต่อวงจร 

 4. โปรแกรม Quartus II 8.1 Web Edition 

ทฤษฎี 
 วงจรเล่ือนขอ้มูล (Shift  Register) เป็นวงจรท่ีมีบทบาทส าคญัในการส่ือสารขอ้มูลใน
ระบบดิจิตอล รวมถึงการค านวณทางคณิตศาสตร์ อุปกรณ์หลักท่ีใช้สร้างวงจรเล่ือนข้อมูลคือ  
รีจิสเตอร์  (Register) ซ่ึงเป็นตวัเก็บขอ้มูลท่ีสร้างจากฟลิปฟลอบ ซ่ึงอาจเป็น D  ฟลิปฟลอปหรือ 
JK ฟลิปฟลอปก็ได ้ฟลิปฟลอปแต่ละตวัจะเก็บขอ้มูลไดต้วัละ 1 บิต ดงันั้นขนาดของรีจิสเตอร์จึง
ข้ึนอยูก่บัจ  านวนฟลิปฟลอปท่ีใช ้

วงจรเล่ือนขอ้มูลแบ่งออกเป็น 4 ชนิดไดแ้ก่ 

 1.วงจรเล่ือนขอ้มูลแบบอนุกรมเขา้-อนุกรมออก (Serial  ln/Serial Out : SISO) 

 2.วงจรเล่ือนขอ้มูลแบบอนุกรมเขา้-ขนานออก (Serial  ln/Parallel Out : SIPO) 

 3.วงจรเล่ือนขอ้มูลแบบขนานเขา้-อนุกรมออก (Parallel  ln/Serial Out : PISO) 

 4. 3.วงจรเล่ือนขอ้มูลแบบขนานเขา้-ขนานออก (Parallel  ln/ Parallel Out : PIPO) 

 

รูปท่ี 14.1a วงจรเล่ือนขอ้มูลแบบอนุกรมเขา้-อนุกรมออก 
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รูปท่ี 14.1b วงจรเล่ือนขอ้มูลแบบอนุกรมเขา้-ขนานออก 

 
 

รูปท่ี 14.1c วงจรเล่ือนขอ้มูลแบบขนานเขา้-อนุกรมออก 

 

รูปท่ี 14.1d วงจรเล่ือนขอ้มูลแบบขนานเขา้-ขนานออก 

ตวัอยา่งวงจรเล่ือนขอ้มูลแบบพื้นฐานแสดงดงัรูปท่ี 14.2 ซ่ึงเป็นวงจรเล่ือนขอ้มูลแบบ
อนุกรมเขา้-ขนานออก ขนาด 4 บิต การท างานเร่ิมจากส่งสัญญาณ Clear  เพื่อก าหนดให้ฟลิป
ฟลอปทุกตวัมีค่าขอ้มูลเป็น 0  ท่ีเวลา t0 และใหข้าData ม่ีค่าเป็น 1 เม่ือขอบขาข้ึนของสัญญาณ
นาฬิกามาถึงท่ีเวลา t1 ขอ้มูล 1 จะถูกป้อนเขา้ไปเก็บไวใ้นฟลิปฟลอป A และขอ้มูลเดิมท่ีมีอยูใ่นฟ
ลิปฟลอป A  จะถูกส่งต่อไปใหฟ้ลิปฟลอป B ส่วนขอ้มูลเดิมของฟลิปฟลอป B  ก็จะถูกเล่ือนไป
เก็บไวใ้นฟลิปฟลอป C และฟลิปฟลอป C  จะส่งขอ้มูลเดิมของมนัไปเก็บท่ีฟลิปฟลอป D เช่นกนั  
ดงันั้นขณะน้ีค่าเอาตพ์ุทของวงจรจะเป็น 0001  
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เม่ือถึงเวลา t2 ขา Data ยงัมีค่าเป็น  1  ซ่ึงจะถูกเล่ือนเขา้ไปเก็บไวใ้น ฟลิปฟลอป A  และ
ขอ้มูลเดิมของฟลิปฟลอปแต่ละตวัจะถูกเล่ือนไปเก็บยงัตวัถดัไปเช่นเดิม ซ่ึงค่าเอาตพ์ุทในขณะน้ีจะ
มีค่าเป็น 0011 

เม่ือถึงเวลา t3 ขณะน้ีขา Data  เปล่ียนลอจิก 1  เป็น   0 ขอ้มูลจะเล่ือนเขา้ไปและเอาตพ์ุ
ทของวงจรขณะน้ีจะมีค่าเป็น   0110 

เม่ือถึงเวลา t4 ขา Data  เปล่ียนค่าลอจิกเป็น 1 ขอ้มูลจะเล่ือนเขา้ไปและเอาตพ์ุทของวงจร
ขณะน้ีจะมีค่าเป็น  1101  

 

รูปท่ี 14.2 วงจรเล่ือนขอ้มูล 

 

รูปท่ี 14.3 รูปคล่ืนการท างานของวงจรเล่ือนขอ้มูล 

 

 

                                          0.00ns                200.0ns                   400.0ns                 600.0ns                  800.0ns                       1.0us 
   

 Clock    1  2  3  4  5 
   

     Serial    

Data input    1  1  0  1  0 
   

Clear   

   

 A    1  1  0  1  0 
             

 B    0  1  1  0  1 
             

 C    0  0  1  1  0 
             

 D    0  0  0  1  1 
  T0  T1  T2  T3  T4  T5 
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ไอซีท่ีท าหนา้ท่ีเป็นวงจรเล่ือนขอ้มูลท่ีนิยมใชก้นัมากไดแ้ก่ เบอร์ 74194 (4 Bit-Universal    

Shift Register) เน่ืองจากสามารถสร้างเป็นวงจรเล่ือนขอ้มูลไดห้ลายแบบ เช่น วงจรเล่ือนขอ้มูล
แบบขนานเขา้-ขนานออก (PIPO), อนุกรมเขา้-ขนานออก (SIPO) และ อนุกรมเขา้-อนุกรมออก 
(SISO) เป็นตน้ นอกจากน้ียงัสามารถต่อขยายใหเ้ป็นวงจรเล่ือนขอ้มูลมากกวา่ 4 บิตได ้

 

รูปท่ี 14.4 ไอซี 74194 

ไอซี 74194 เป็นไอซีท่ีท าหนา้ท่ีขอบขาข้ึนของสัญญาณนาฬิกา โดยท่ีโหมดการท างานของ 
74194 แสดงดงัรูป 14.1 ซ่ึงมีทั้งหมด 5 โหมด ไดแ้ก่ รีเซท, โฮลด์ (Hold) หรือคงสภาวะเดิม, เล่ือน
ซา้ย, เล่ือนขวา และ โหมดขอ้มูลขนาน  (Parallel Load) 

โหมดรีเซทจะเกิดข้ึนเม่ือมีการป้อนลอจิก 0 เขา้ท่ีขา CLEAR  ซ่ึงจะท าให้ค่าเอาตพ์ุทท่ีถูก
เคลียร์ค่าเป็น  0000  (QA,QB,QC,QD)  ทั้งหมดโดยไม่สนวา่ค่าลอจิกทางขาขอ้มูลอินพุทจะมีค่า
เป็นอะไร 

ส าหรับโหมดท่ีเหลืออีก 4 โหมดจะถูกควบคุมดว้ยการป้อนลอจิกเขา้ท่ีขา S0 และ S1 ดงัน้ี 

-เม่ือขา S0 = 0 และ S1 = 0 วงจรเล่ือนขอ้มูลจะเขา้สู่โหมดโฮลดห์รือก็คือการคงสภาวะ
ขอ้มูลทางเอาตพ์ุท 

-โหมดเล่ือนซ้ายจะเกิดข้ึนเม่ือขา S0 =  0  และ  S1  =  1  ขอ้มูลจะถูกป้อนเขา้ท่ีขา Serial  

Input (Shift  Left) หรือ DSL  โดยขอ้มูลจะถูกโหลดเขา้ไปท่ี QD  และขอ้มูลเดิมจะถูกเล่ือนซ้าย
ไปยงั QA เม่ือมีการกระตุน้ของสัญญาณนาฬิกาท่ีขอบขาข้ึน 

-โหมดเล่ือนขวาจะเกิดข้ึนเม่ือขา S0 = 1 และ S1 = 0 ขอ้มูลจะถูกป้อนเขา้ท่ีขา Serial 

Input (Shift Right) หรือ DSR และเม่ือ การกระตุน้ของสัญญาณนาฬิกาท่ีขอบขาข้ึน ขอ้มูลจะถูก
โหลดเขา้ไปท่ี QA และขอ้มูลเดิมจะถูกเล่ือนไปทาง QD   
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-โหมดสุดทา้ยคือโหมดโหลดขนาน หรือบางคร้ังเรียกวา่ Broadside Load จะเกิดข้ึนเม่ือขา 
S0 = 1 และ S1 = 1 ขอ้มูลจากขาอินพุทแบบขนานจะถูกโหลดเขา้ไปยงัเอาตพ์ุทเม่ือถูกกระตุน้ดว้ย
สัญญาณนาฬิกาขาข้ึน 

ในการใชง้าน  74194  นั้นสามารถประยกุตไ์ดห้ลากหลาย ไม่วา่จะเป็นการโหลดขอ้มูล
อินพุทแบบขนาน หรือ อนุกรมก็ได ้และการอ่านขอ้มูลเอาตพ์ุทก็สามารถอ่านไดท้ั้งแบบขนานและ
อนุกรมเช่นกนั (อ่านจากขาขอ้มูลเดียว เช่น QD เป็นตน้) 

อินพทุ เอาต์พทุ 

MODE CLEA
R 

MODE CL
K 

SERIAL PARALLFL 
QA QB QC QD S1 S0 LEF

T 
RIGH

T 
A B C D 

Hold H X X L X X X X X X QA0 QB0 QC0 QD0 

Reset L X X X X X X X X X L L L L 

Hold H L L X X X X X X X QA0 QB0 QC0 QD0 

Shift 
Left 

H H L  H X X X X X QBn QCn QDn H 

H H L  L X X X X X QBn QCn QDn L 

Shift 
Right 

H L H  X H X X X X H QAn QBn QCn 

H L H  X L X X X X L QAn QBn QCn 

Parallel 
Load 

H H H  X X a b c d a b c d 

ตารางท่ี 14.1 ตารางความจริงของ 74149 

X : Don’t care 

a, b, c, d : ระดบัลอจิกท่ีคงท่ีท่ีป้อนเขา้ท่ีขา A, B, C และ D ตามล าดบั 

QA0, QB0, QC0, QD0 : เอาตพ์ุทไม่มีการเปล่ียนแปลง 

QAn, QBn, QCn, QDn : ระดบัลอจิกของ QA, QB, QC และ QD หลงัจากถูกกระตุน้ดว้ยสัญญาณ
นาฬิกา 
 
ขั้นตอนการทดลอง ตอนที ่1 วงจรเลือ่นข้อมูลแบบใช้ฟลปิฟลอป 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_14a โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ dff, input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 
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รูปท่ี 14.5 วงจรส าหรับการทดลองตอนท่ี 1 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_14a.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_14a.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    CLR  

  

    DATA  

  

    D  
  

     C  
  

    B  
  

     A  
  

รูปท่ี 14.6 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 
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ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A 1 CLK 72 
B 3 CLR 76 
C 7 DATA 74 
D 11   

ตารางท่ี 14.2 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 14.7 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 14.7 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, และ SW1 ท าการกดสวทิช์ PULSEO_Q 

แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED D2, และ LED D3 จากนั้นบนัทึกผลลงในตาราง 
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PRE_N 
(SW0) 

CLR_N 
(SW1) 

CLK 
(PULSEO Q) 

D 
(LED D3) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

HIGH HIGH      
HIGH HIGH      
HIGH HIGH      
HIGH HIGH      
LOW HIGH      
LOW HIGH      
LOW HIGH      
LOW HIGH      

ตารางท่ี 14.3  ตารางความจริงจากการทดลองตอนท่ี 1 

ขั้นตอนการทดลอง ตอนที ่2 การใช้ไอซี 74149 เป็นวงจรเลือ่นซ้ายแบบ SISO และ SIPO 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_14b โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74194, vcc, gnd, 

input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 
 รูปท่ี 14.8 วงจรส าหรับการทดลองตอนท่ี 2 

 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_14b.gdf 
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7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_14b.scf เพื่อจ าลองการท างานของวงจร 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    CLR  

  

    SL  

  

    D  
  

     C  
  

    B  
  

     A  
  

รูปท่ี 14.9 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A 1 CLK 72 
B 3 CLR 76 
C 7 SL 74 
D 11   

ตารางท่ี 14.4 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 14.10 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 14.10 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, และ SW1 ท าการกดสวทิช์ PULSEO_Q 

แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED D2 และ LED D3 จากนั้นบนัทึกผลลงในตาราง 

CLR 
(SW0) 

SL 
(SW1) 

CLK 
(PULSEO Q) 

D 
(LED D3) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

LOW HIGH      
HIGH HIGH      
HIGH HIGH      
HIGH LOW      
HIGH LOW      
HIGH LOW      
HIGH HIGH      
HIGH LOW      
HIGH LOW      

ตารางท่ี 14.5 ตารางความจริงจากการทดลองตอนท่ี 2 
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ขั้นตอนการทดลอง ตอนที ่3 การใช้ไอซี 74149 เป็นวงจรเลือ่นขวาแบบ SISO และ SIPO 

1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_14c โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74194, vcc, gnd, 

input และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 14.11 วงจรส าหรับการทดลองตอนท่ี 3 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_14c.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_14c.scf เพื่อจ าลองการท างานของวงจร 
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รูปท่ี 14.12 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 
A 1 CLK 72 
B 3 CLR 76 
C 7 SR 74 
D 11   

ตารางท่ี 14.6 ต  าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 14.13 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 

Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    CLR  

  

    SR  

  

    D  
  

     C  
  

    B  
  

     A  
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รูปท่ี 14.13 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, และ SW1 ท าการกดสวทิช์ PULSEO_Q 

แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED D2, และ LED D3 จากนั้นบนัทึกผลลงในตาราง 

CLR 
(SW0) 

SR 
(SW1) 

CLK 
(PULSEO Q) 

D 
(LED D3) 

C 
(LED D2) 

B 
(LED D1) 

A 
(LED D0) 

LOW HIGH      
HIGH HIGH      
HIGH HIGH      
HIGH LOW      
HIGH LOW      
HIGH LOW      
HIGH HIGH      
HIGH LOW      
HIGH LOW      

ตารางท่ี 4.7 ตารางความจริงจากการทดลองตอนท่ี 3 
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ขั้นตอนการทดลอง ตอนที ่4 การใช้ไอซี 74149 เป็นวงจรโหลดข้อมูลแบบขนาน 
1. เปิดโปรแกรม Quartus II 8.1 Web Edition แลว้ท าการสร้างโปรเจคใหม่ในช่ือ lab_14d โดยใช้
เมนู File -> New   Project Wizard  
2. สร้างไฟลส์ าหรับวาดแผนวงจรโดยใชเ้มนู File -> New 

3. จากนั้นหนา้ต่าง New จะปรากฏข้ึน ใหเ้ลือกท่ี Block Diagram/Schematic File เสร็จแลว้คลิก 
OK 

4. ท าการวาดอุปกรณ์ โดยดบัเบิลคลิกบน Graphic Editor แลว้เลือกอุปกรณ์ 74194, vcc, input 

และ output 

5. ลากเส้นเช่ือมต่ออุปกรณ์ต่าง ๆ เขา้ดว้ยกนัดงัรูป 

 

รูปท่ี 14.14 วงจรส าหรับการทดลองตอนท่ี 4 

6. ใหท้ าการบนัทึกโดยบนัทึกในช่ือ lab_14d.gdf 

7. ท าการคอมไพลเ์พื่อตรวจสอบวงจรท่ีวาดไว ้โดยใชเ้มนู Processing -> Start compilation  

8. สร้างไฟล ์Vector Waveform ในช่ือ lab_14d.scf เพื่อจ าลองการท างานของวงจร 
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Name:                               100.0ns    200.0ns     300.0ns    400.0ns    500.0ns     600.0ns    700.0ns    800.0ns    900.0ns        1.0us 

  

     CLK  

  

    CLR  

  

    SR  

  

    D  
  

     C  
  

    B  
  

     A  
  

รูปท่ี 14.15 ผลจ าลองการท างาน 

9. เรียกหนา้ต่าง Simulator เพื่อค านวณการจ าลองการท างานของวงจรโดยเลือกจากแถบเคร่ืองมือ 
หรือใชก้ารเลือกจากเมนู Processing -> Start Simulation  
10. ก าหนดขาจากหนา้ต่าง Pin Planner โดยใชเ้มนู Assignments -> Pins 

11. เปล่ียนต าแหน่งขาอินพุท และเอาตพ์ุทใหเ้ป็นดงัน้ี 

 
ขาในวงจร ต าแหน่งขาบน FPGA ขาในวงจร ต าแหน่งขาบน FPGA 

CLK 74 CLR 66 
A 72 QA 1 
B 70 QB 3 
C 68 QC 7 
D 64 QD 11 

ตารางท่ี 14.8 ต าแหน่งสัญญาณในวงจรและต าแหน่งขาบน FPGA 

12. ต่อวงจรตามรูปท่ี 14.16 แลว้ดาวน์โหลดโปรแกรมลงไอซี FPGA 
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รูปท่ี 14.16 การต่อวงจรบนชุดทดลอง 

13. ทดสอบวงจรโดยการเปล่ียนสถานะของสวติช์ SW0, และ SW1 ท าการกดสวทิช์ PULSEO_Q 

แลว้ดูผลทางลอจิกท่ี LED D0, LED D1, LED D2, และ LED D3 จากนั้นบนัทึกผลลงในตาราง 

 

 

 

 

 

 

 

 

 

 

 



241 

 
CLR 

(SW4) 

A 

(SW0) 

B 

(SW1) 

C 

(SW2) 

D 

(SW3) 

CLK 

(PULSEO Q) 

D 

(LED D3) 

C 

(LED D2) 

B 

(LED D1) 

A 

(LED D0) 

LOW HIGH HIGH HIGH HIGH      
HIGH LOW LOW LOW LOW      
HIGH LOW LOW LOW HIGH      
HIGH LOW LOW HIGH LOW      
HIGH LOW LOW HIGH HIGH      
HIGH LOW HIGH LOW LOW      
HIGH LOW HIGH LOW HIGH      
HIGH LOW HIGH HIGH LOW      
HIGH LOW HIGH HIGH HIGH      
HIGH HIGH LOW LOW LOW      
HIGH HIGH LOW LOW HIGH      
HIGH HIGH LOW HIGH LOW      
HIGH HIGH LOW HIGH HIGH      
HIGH HIGH HIGH LOW LOW      
HIGH HIGH HIGH LOW HIGH      
HIGH HIGH HIGH HIGH LOW      
HIGH HIGH HIGH HIGH HIGH      

ตารางท่ี 14.9 ตารางความจริงจากการทดลองตอนท่ี 4 

สรุปผลการทดลอง 
 


